Survey by Qualaroo
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 20 of 21

Thread: Why engine check light came on?

  1. #1
    Senior PakWheeler Follow
    afnanSJfayaz's Avatar
    Join Date
    Nov 2010
    Location
    Newcastle upon Tyne
    Posts
    1,164
    Follows
    1
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Why engine check light came on?

    The car is 2011 GLi Auto, 10k driven on petrol, no CNG. I had an amp and a sub woofer installed 3 days ago. Yesterday while coming home the AC was on "2" and the my sound system was on a loud sound, I was pressing the accelerator considerably but the car wasn't accelerating as it should. Then I saw that the check light came on. Came home reset the ECU by detaching the Negative terminal of the battery. Engine check light was gone after this, my question is why did it come on in the first place, was it because of the sound system, the AC or both? Or was there some sort of overload on the engine?

    THREAD UPDTATE: Bought an OBD scanner for myself after this incident. Sound system uninstalled a month ago. Got error code P2121. Please help.

    THREAD UPDATE:got code p2121 again. This car is driving me mad now. Got this problem for the third time this year. Please help me what to do. For the time being i am plugging and erasing the code using the obdii tool. Please help me, what is the permanent solution? I know its something related to the accelerator pedal as I have to literally floor it to get it to just crawl. Sound system was removed ages ago, everything is bone stock now. (24-2-2014.)


  2. #2
    Senior PakWheeler Follow
    afnanSJfayaz's Avatar
    Join Date
    Nov 2010
    Location
    Newcastle upon Tyne
    Posts
    1,164
    Follows
    1
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    If in wrong section, MODS please transfer it to the suitable one.

  3. #3
    Senior PakWheeler Follow
    afnanSJfayaz's Avatar
    Join Date
    Nov 2010
    Location
    Newcastle upon Tyne
    Posts
    1,164
    Follows
    1
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Bumpppppp.

  4. #4
    Senior PakWheeler Follow
    afnanSJfayaz's Avatar
    Join Date
    Nov 2010
    Location
    Newcastle upon Tyne
    Posts
    1,164
    Follows
    1
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Come on, please help me PW.

  5. #5
    PakWheeler Follow
    junaid_mir's Avatar
    Join Date
    Aug 2012
    Location
    Gujrat
    Posts
    277
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Buy obdii scanner and check ur self .dignose ur car nd clear that error ur self.

    Sent from my GT-I9300 using Tapatalk 2

  6. #6
    Senior PakWheeler Follow
    talhawaleed's Avatar
    Join Date
    May 2009
    Location
    Islamabad
    Posts
    1,812
    Follows
    1
    Following
    0
    Mentioned
    115 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by afnanSJfayaz View Post
    The car is 2011 GLi Auto, 10k driven on petrol, no CNG. I had an amp and a sub woofer installed 3 days ago. Yesterday while coming home the AC was on "2" and the my sound system was on a loud sound, I was pressing the accelerator considerably but the car wasn't accelerating as it should. Then I saw that the check light came on. Came home reset the ECU by detaching the Negative terminal of the battery. Engine check light was gone after this, my question is why did it come on in the first place, was it because of the sound system, the AC or both? Or was there some sort of overload on the engine?
    Heavy electrical load on vehicles at times provides error codes which may not even related to the real issue. For example, if Alternator is not able to provide enough current and maintain the desired Voltage then you can get to see an error code for low fuel pressure, which may point that fuel pump was not able to maintain the constant pressure across injectors so result was bad fuel supply to the pistons.

    Problem could have started from an equipment which was consuming most of the power generated by the alternator and result was very low electrical power left for fuel pump in-order for it to do its job properly and maintain proper fuel pressure.

    OBD 2 kit could have helped you to diagnose the issue immediately but I guess you are good to go now.

  7. #7
    PakWheeler Follow
    Dragoon's Avatar
    Join Date
    Apr 2011
    Location
    Islamabad
    Posts
    444
    Follows
    0
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by afnanSJfayaz View Post
    The car is 2011 GLi Auto, 10k driven on petrol, no CNG. I had an amp and a sub woofer installed 3 days ago. Yesterday while coming home the AC was on "2" and the my sound system was on a loud sound, I was pressing the accelerator considerably but the car wasn't accelerating as it should. Then I saw that the check light came on. Came home reset the ECU by detaching the Negative terminal of the battery. Engine check light was gone after this, my question is why did it come on in the first place, was it because of the sound system, the AC or both? Or was there some sort of overload on the engine?
    Same thing happened to my friend's Honda City 2007. He also have a subwoofer. He was driving w/o AC but when I (sitting next to him) turned on the audio system, the Engine Check light came on after 2 minutes. He said it was normal.
    So it must be because of the electrical load on the car's engine.

  8. #8
    Senior PakWheeler Follow
    afnanSJfayaz's Avatar
    Join Date
    Nov 2010
    Location
    Newcastle upon Tyne
    Posts
    1,164
    Follows
    1
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    thread updated.

  9. #9
    PakWheeler Follow
    mianaasim's Avatar
    Join Date
    Nov 2013
    Location
    Lahore
    Posts
    264
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by afnanSJfayaz View Post
    thread updated.
    so now u r scanning and deleting by urself?????

  10. #10
    Senior PakWheeler Follow
    afnanSJfayaz's Avatar
    Join Date
    Nov 2010
    Location
    Newcastle upon Tyne
    Posts
    1,164
    Follows
    1
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by mianaasim View Post
    so now u r scanning and deleting by urself?????
    Yes. I got the scanner from my uncle. He got the code and found the problem and erased it there and then. After that took it to a toyota dealer wo cleaned the o2 sensor.

    Sent from my SM-N9005 using Tapatalk

  11. #11
    Senior PakWheeler Follow
    Teeboyuk's Avatar
    Join Date
    Sep 2012
    Location
    Other
    Posts
    1,608
    Follows
    1
    Following
    0
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Fit a cap to ur sound system. Poor battery and alternator are getting the life sucked out of them.
    Pakistan.. Toyota hilux..golf mk2 gtd..rolla 2.0d..nissian sunny.. Yamaha pw 50.. Coventry uk....audi v8 d11..golf mk2 rallye..honda crx..evo 8..golf mk2 gtd..Vauxhall insignia..

  12. #12
    Senior PakWheeler Follow
    afnanSJfayaz's Avatar
    Join Date
    Nov 2010
    Location
    Newcastle upon Tyne
    Posts
    1,164
    Follows
    1
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Thread updated, please care to read the main post.

  13. #13
    Senior PakWheeler Follow
    umarkhan1's Avatar
    Join Date
    Nov 2010
    Location
    Sargodha
    Posts
    2,308
    Follows
    6
    Following
    8
    Mentioned
    51 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    2

    Default

    Quote Originally Posted by afnanSJfayaz View Post
    Thread updated, please care to read the main post.
    check the wiring to throttle position sensor
    Just Do It Your Self!!!!!

  14. #14
    PakWheeler Follow
    dakait's Avatar
    Join Date
    Jul 2010
    Location
    Karachi
    Age
    28
    Posts
    171
    Follows
    0
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Change ur alternator or checked it by some expert, problem occured with ur alternator which not working properly...

  15. #15
    Senior PakWheeler Follow
    afnanSJfayaz's Avatar
    Join Date
    Nov 2010
    Location
    Newcastle upon Tyne
    Posts
    1,164
    Follows
    1
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by dakait View Post
    Change ur alternator or checked it by some expert, problem occured with ur alternator which not working properly...
    Okay. I will do that. Dealership is saying that p2121 means that something is seriously wrong with the engine wiring harness. Searched the internet and got a problem with the TPS.

    Sent from my SM-N9005 using Tapatalk

  16. #16
    PakWheeler Follow
    danijadoon's Avatar
    Join Date
    Sep 2011
    Location
    Abbotabad
    Posts
    10
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    hi afnanSJfayaz
    as you already know the fault code is about TPS sensor,
    first thing you tell your mechanic is to check the operation of tps with a scan tool and most likely it is gonna show that butterfly is only opening between 10-25%. then check the connector plug for any loose connection, check current, resistance, then clean the contacts and sensor tip, clean the throtle body and then perform the same steps and if any little difference or no difference comes up, then you should b replacing the tps sensor, these are few things to do before going any further for wiring harness or ecm

  17. #17
    PakWheeler Follow
    Shakills's Avatar
    Join Date
    Apr 2006
    Location
    London
    Posts
    678
    Follows
    1
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    reseting the the MIL by disconnecting will only reset and it will not solve the issue that caused it. most likely its the TPS/APPS sensor, above post actually give good pointers to solve this.
    -

  18. #18
    Newbie Follow
    hussain.saqib's Avatar
    Join Date
    May 2014
    Location
    Islamabad
    Age
    62
    Posts
    1
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    With the same problem I took my car to Toyota Garden Motors. They say the entire wiring has to be changed. It will cost me around 45k. what should I do?

  19. #19
    PakWheeler Follow
    Shakills's Avatar
    Join Date
    Apr 2006
    Location
    London
    Posts
    678
    Follows
    1
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Thats strange for engine light you have to replace wiring? Not unless if the wires are short or burnt. If all fine physically, they trying to rip off or they couldnt diagnose the problem.

    What r fault codes?

    Sent from my GT-I9505 using PW Forums mobile app
    -

  20. #20
    PakWheeler Follow
    shadab_lodhi's Avatar
    Join Date
    Feb 2012
    Location
    Rawalpindi
    Posts
    82
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Dtc p2121

    Error Code: P 2121
    Description: Throttle/ Pedal Position Sensor/ Switch "D" Circuit Range/ Performance.
    Trouble Area: - Accelerator Pedal Position Sensor.
    - ECM
    Solution:
    This DTC relates to the Accelerator Pedal Position (APP) Sensor. Replace the whole accelerator pedal assembly (located to the right side of brake pedal) with a good known one even purchased from the junk.
    Delete the code manually or with any scan tool. Relearn the idle air control valve and enjoy.

+ Reply to Thread
Page 1 of 2 12 LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •