Survey by Qualaroo
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 20 of 22
Like Tree1Likes

Thread: Need help from Corolla Experts ( 2009 onwards )

  1. #1
    PakWheeler Follow
    RavAGE's Avatar
    Join Date
    Oct 2009
    Location
    Lahore
    Age
    26
    Posts
    817
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Need help from Corolla Experts ( 2009 onwards )

    Salam everyone,
    Well i own a Toyota Corolla 2009 GLi..... 100K km's on the clock..... i have been facing a problem recently..... my car misfires / is missing alot..... it started after i removed the CNG Kit from my car..... the previous owner had CNG installed but after buying it from him i never ever let the engine touch CNG..... for the past 30,000 km's i have driven it only on petrol and there was no missing problem whatsoever..... but it all started after i removed the CNG kit recently due to this weird noise the cylinder was making while on bumps.....
    Engine isnt drinking mobile oil and the mobile oil is still clean not dirty which was last replaced like two months back..... mobile oil is fine..... radiator is fine and everything.... i dont feel any problems in the performance before and now of the engine apart from the misfire..... hill climb is fine and no issues...... but the misfire problem is just killing me...... i got the engine checked from Toyota Airport Motors.... and they claimed that one of the cylinders is showing low compression..... how and why all of a sudden is the car misfiring and one cylinder is on low compression?..... the car has been running on petrol for the last 30-40,000km's..... i dont know..... i just need some help from experts regarding this problem because the Toyota Airport guys told me the engine will need an overhaul and stuff.... but i dont trust them..... i never trusted them regarding engine issues.... so if anyone can help me out and identify the problem.....
    Also there is no black smoke from the back... and Toyota Airport Motors diagnostic computer didnt show any errors related to engine
    I can sell the car anytime and buy another car most probably same year GLi but with less miles on the clock.... but i m not done with this one yet.... i dont wanna give up.... i m sure its a minor problem and not a big one.... i just need some help from experts.....

    Kindly please reply as its really frustrating me cx rest of the car is perfectly fine but this missing problem is killing me..... and has totally destroyed the driving experience and pleasure

  2. #2
    PakWheeler Follow
    RavAGE's Avatar
    Join Date
    Oct 2009
    Location
    Lahore
    Age
    26
    Posts
    817
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    No one interested to help?

  3. #3
    Senior PakWheeler Follow
    faiz.aslam.121's Avatar
    Join Date
    Jan 2013
    Location
    Oslo
    Age
    21
    Posts
    7,464
    Follows
    5
    Following
    0
    Mentioned
    148 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Get engine compression done and tuning of the engine. The rest, experts can guide you better.

    Sent from my HTC One_M8 using Tapatalk
    Turbo lag is like foreplay. You know it's coming. And it's gonna be good.

  4. #4
    Senior PakWheeler Follow
    COOLTAHIR's Avatar
    Join Date
    Feb 2011
    Location
    Select City
    Age
    19
    Posts
    4,702
    Follows
    9
    Following
    0
    Mentioned
    132 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    1
    Good Answers
    0

    Default

    bro in my oppinion just take your ride to any dealership and get it tunned properly if any sensor or any part of engine need replacement just replace it.and check your ride for one week if problem presist than overhul as delership says.but 100k kms is nothing for corolla .
    FeeL YoUng DriVE YoUnG......

  5. #5
    Senior PakWheeler Follow
    sjehsan's Avatar
    Join Date
    Mar 2009
    Location
    Lahore
    Age
    28
    Posts
    3,086
    Follows
    0
    Following
    0
    Mentioned
    47 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    bro take your car to Pak Motors at back side of Sureya Azeem Hospital in chuburgi..... they will sort out your matter!
    Sent from my own Desktop Computer using my own Keyboard !!!

  6. #6
    PakWheeler Follow
    5555's Avatar
    Join Date
    May 2009
    Location
    Lahore
    Age
    25
    Posts
    688
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    it could be a problem with ignition wiring as they are attached with cng kit wiring as cng is removed so there could be a damage to any of the wire............................remove the battery terminal for about a minute or two and then attach it back then start engine
    but most probably there is issue with ignition wiring

  7. #7
    PakWheeler Follow
    RavAGE's Avatar
    Join Date
    Oct 2009
    Location
    Lahore
    Age
    26
    Posts
    817
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Thanks alot for the help..... yes one thing i forgot to mention... that startup of the car is perfectly fine too.... engine starts on half sulf and there is no black smoke even on startup.... @5555 i will try out the battery terminal procedure....
    @ Cool Tahir... yes bro totally agreed 100K is nothing for a Toyota engine.... also regular maintenance has been done from Toyota Airport..... even major maintenance after the purchase of car.....

    Still need some more opinions and procedures from other experts aswell..... i really want to remove this problem from my car.... i just hope its a minor fault and not a major one.....

  8. #8
    Senior PakWheeler Follow
    a_n_memon88's Avatar
    Join Date
    Jun 2010
    Location
    Lahore
    Age
    28
    Posts
    1,872
    Follows
    0
    Following
    0
    Mentioned
    44 Post(s)
    Tagged
    18 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Well the CNG guy did not properly uninstall the CNG setup and has messed up with one of your injectors. Get each and every inch of wiring to injectors checked I hope there would be some spot producing sparks there rectify it and you will be happy

  9. #9
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,402
    Follows
    131
    Following
    0
    Mentioned
    3989 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    can you perform a compression test and post the readings
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  10. #10
    PakWheeler Follow
    RavAGE's Avatar
    Join Date
    Oct 2009
    Location
    Lahore
    Age
    26
    Posts
    817
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I did perform a compression test.... Cylinder one is giving lower compression compared to the other 3 cylinders..... 1st cylinder is giving a reading around 50-70..... i dont remember exactly but thats what i remember....

  11. #11
    PakWheeler Follow
    RavAGE's Avatar
    Join Date
    Oct 2009
    Location
    Lahore
    Age
    26
    Posts
    817
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    other 3 cylinders are giving perfect compression....

  12. #12
    PakWheeler Follow
    RavAGE's Avatar
    Join Date
    Oct 2009
    Location
    Lahore
    Age
    26
    Posts
    817
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Can there be some other minor problem due to which cylinder 1 is giving lower compression?.... apart from the Valves problem which needs an overhaul...

  13. #13
    Senior PakWheeler Follow
    faiz.aslam.121's Avatar
    Join Date
    Jan 2013
    Location
    Oslo
    Age
    21
    Posts
    7,464
    Follows
    5
    Following
    0
    Mentioned
    148 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Faulty coils or something to do with CNG could've had something to do with one of your cylinders....
    Turbo lag is like foreplay. You know it's coming. And it's gonna be good.

  14. #14
    Senior PakWheeler Follow
    aamirq's Avatar
    Join Date
    Oct 2006
    Location
    Karachi
    Age
    31
    Posts
    1,726
    Follows
    0
    Following
    1
    Mentioned
    26 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    have u tried changing the spark plugs? the spark plugs that ur presently using take them out take a picture of them and post it here! the color of the spark plugs shud make stuff a bit easier!
    or it can be possible tht one of ur coil is weak? or maybe the engine is sucking in excess air from some pipe that has a hole in it or maybe isnt fitted properly? if u show us the spark plugs it will be easier to diagnose the problem as in if ur car is running lean,rich,normal etc..
    "The world ain't all sunshine and rainbows. It's a very ruff, mean place, and no matter how tuff you think you are, it will always bring you to your knees and keep you there permanently if you let it.You or nobody ain't never gonna hit as hard as life, but it ain't about how hard you hit, it's about how hard you can get hit and keep moving forward, how much you can take and keep moving forward. If you know what you're worth, go out and get what you're worth, but you gotta be willing to take the hit."
    - Sylvester Stallone

  15. #15
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,402
    Follows
    131
    Following
    0
    Mentioned
    3989 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    Quote Originally Posted by RavAGE View Post
    I did perform a compression test.... Cylinder one is giving lower compression compared to the other 3 cylinders..... 1st cylinder is giving a reading around 50-70..... i dont remember exactly but thats what i remember....

    theres your problem - fix it, usually caused by bad valve seats.
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  16. #16
    PakWheeler Follow
    RavAGE's Avatar
    Join Date
    Oct 2009
    Location
    Lahore
    Age
    26
    Posts
    817
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @aamirq yes bro i have changed the spark plugs.... when i took my car to Toyota Airport.... i asked them to change the spark plugs because at first i thought changing spark plugs would fix the problem.... they installed Denso Spark Plugs new ones.... but the problem is still there.....

  17. #17
    Senior PakWheeler Follow
    aamirq's Avatar
    Join Date
    Oct 2006
    Location
    Karachi
    Age
    31
    Posts
    1,726
    Follows
    0
    Following
    1
    Mentioned
    26 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    and u forgot to mention as in when does the car misfire? when u suddenly accelerate ya while its idling or when ur just driving normally
    "The world ain't all sunshine and rainbows. It's a very ruff, mean place, and no matter how tuff you think you are, it will always bring you to your knees and keep you there permanently if you let it.You or nobody ain't never gonna hit as hard as life, but it ain't about how hard you hit, it's about how hard you can get hit and keep moving forward, how much you can take and keep moving forward. If you know what you're worth, go out and get what you're worth, but you gotta be willing to take the hit."
    - Sylvester Stallone

  18. #18
    PakWheeler Follow
    RavAGE's Avatar
    Join Date
    Oct 2009
    Location
    Lahore
    Age
    26
    Posts
    817
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @Xulfiqar .... bro for that i need to do an overhaul?..... like whats the procedure ?... is it costly and will take time.... if its a proper overhaul then i would probably sell the car and buy another car with lower km's on the clock....

  19. #19
    PakWheeler Follow
    RavAGE's Avatar
    Join Date
    Oct 2009
    Location
    Lahore
    Age
    26
    Posts
    817
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    the car misfires on idle.... ....when i suddenly accelerate it doesnt misfire that much.... but on idle it misfires like crazy.... normal drive it doesnt misfire.....

  20. #20
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,402
    Follows
    131
    Following
    0
    Mentioned
    3989 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    this is a small job, get the mechanic to remove the head and inspect the valves, if the seats are burnt - regrind them, if they are pitted they can be repaired with new inserts. Its not a big job.

    Make sure the mechanic tightens the head with a torque ratchet (torque wrench).
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

+ Reply to Thread
Page 1 of 2 12 LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •