Survey by Qualaroo
+ Reply to Thread
Results 1 to 17 of 17
Like Tree3Likes
  • 1 Post By umarkhan1
  • 1 Post By engineer_shazz
  • 1 Post By waseef

Thread: EFI Cold Start

  1. #1
    PakWheeler Follow
    mehranhu's Avatar
    Join Date
    Dec 2012
    Location
    Islamabad
    Posts
    80
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Red face EFI Cold Start

    as salam o alaikum,
    My corolla 16 Volve engine, EFI, have First start problm.

    Everyday, when i start for first time in morning (or any time) the engine turns Off when auto switching to CNG from PETROL; (No matter how much accelerator or trottle i give, it must tuns off and i have to start it again).

    After this, switching works better for the whole day, and next day, in cold start again it goes OFF during first switch from Petrol to CNG.

    Any suggestions plz


  2. #2
    Senior PakWheeler Follow
    umarkhan1's Avatar
    Join Date
    Nov 2010
    Location
    Sargodha
    Posts
    2,312
    Follows
    6
    Following
    8
    Mentioned
    51 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    2

    Default

    get the cng kit serviced and also install a relay.coolant pipes are connected with the cng kit or not??
    Just Do It Your Self!!!!!

  3. #3
    PakWheeler Follow
    engineer_shazz's Avatar
    Join Date
    Apr 2014
    Posts
    154
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    well nothing wrong with ur engine or either your cng kit
    its happens due to operating temperature of engine in the morning

    do one thing start your engine and let it reach to its maximum operating temperature which will take almost 2 to 3 mints
    then switch to cng with the accelatrtion of 3000 rpm.

    and if your problem still there then also adjust cng ***

  4. #4
    Senior PakWheeler Follow
    waseef's Avatar
    Join Date
    Apr 2008
    Location
    Peshawar
    Posts
    1,969
    Follows
    1
    Following
    0
    Mentioned
    27 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i have the same problem no matter summer or winter for the ist time at anytime it starts perfect but when automatic swtich turns to CNG engine stalls, in rest of the day it starts in ist attempt.

  5. #5
    PakWheeler Follow
    mehranhu's Avatar
    Join Date
    Dec 2012
    Location
    Islamabad
    Posts
    80
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    coolant pipes are connected.
    CNG serviced, throttle services, vacuum volv (hightlight load management) checked and replaced. AC vacum wall checked; working.

  6. #6
    PakWheeler Follow
    mehranhu's Avatar
    Join Date
    Dec 2012
    Location
    Islamabad
    Posts
    80
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Thanks; this works, but in EFI, i don't like manual switched, the default way is, car should start on petrol and switch auto to cng; so that i should not have to click cng switch each morning.
    (is there some adjustment of time ; i mean, can one incease the time of auto switching in efi management?)

  7. #7
    Senior PakWheeler Follow
    Fahad.Ayub's Avatar
    Join Date
    Aug 2013
    Location
    Karachi
    Age
    21
    Posts
    1,959
    Follows
    3
    Following
    2
    Mentioned
    32 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    2
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    2

    Default

    Quote Originally Posted by mehranhu View Post
    as salam o alaikum,
    My corolla 16 Volve engine, EFI, have First start problm.

    Everyday, when i start for first time in morning (or any time) the engine turns Off when auto switching to CNG from PETROL; (No matter how much accelerator or trottle i give, it must tuns off and i have to start it again).

    After this, switching works better for the whole day, and next day, in cold start again it goes OFF during first switch from Petrol to CNG.

    Any suggestions plz
    Walikum Assalam
    Does your car have the thermostat valve installed ? Is your cars fan auto or direct ?
    car is not reaching operational temperature quick check the above 2 things
    What i do in my cars is that i start the car on petrol after 2-3 mins. convert it to CNG

  8. #8
    PakWheeler Follow
    mehranhu's Avatar
    Join Date
    Dec 2012
    Location
    Islamabad
    Posts
    80
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Fahad.Ayub View Post
    Walikum Assalam
    Does your car have the thermostat valve installed ? Is your cars fan auto or direct ?
    car is not reaching operational temperature quick check the above 2 things
    What i do in my cars is that i start the car on petrol after 2-3 mins. convert it to CNG
    Thanks for reply Fahad:
    Fan was AUTO; Thermostate was installed whole winter. (i changed both yesterday for AC performance When they are intalled and AUTO, same issue was present, and after changing! again same. I think these don't effect my problem.

    And yes! if i start it on Petrol (only petrol) and then switch it manually after 3 minutes, it works fine.

    But all i want to discuss is the EFI's attractive feature that if last night i parked the car on cNG, next morning, engin will start on petrol, and auto switch to CNG. here comes the problem, this auto switching time is very low; so that engine don't get enough heated to switch.
    Can we alter this time of autoswitch from petrol to cng ?

    In the EFI's behavior discussed above, initial start is done over petrol and then auto changed to CNG, I like it very much so my mind don't accept manual switching from petrol to cng. It is surely a bug, and i want to solve it with YOU PEOPLE's help rather than just compromise and do the CNG/PETROL switching manually.

  9. #9
    Senior PakWheeler Follow
    Fahad.Ayub's Avatar
    Join Date
    Aug 2013
    Location
    Karachi
    Age
    21
    Posts
    1,959
    Follows
    3
    Following
    2
    Mentioned
    32 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    2
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    2

    Default

    Quote Originally Posted by mehranhu View Post
    Thanks for reply Fahad:
    Fan was AUTO; Thermostate was installed whole winter. (i changed both yesterday for AC performance When they are intalled and AUTO, same issue was present, and after changing! again same. I think these don't effect my problem.

    And yes! if i start it on Petrol (only petrol) and then switch it manually after 3 minutes, it works fine.

    But all i want to discuss is the EFI's attractive feature that if last night i parked the car on cNG, next morning, engin will start on petrol, and auto switch to CNG. here comes the problem, this auto switching time is very low; so that engine don't get enough heated to switch.
    Can we alter this time of autoswitch from petrol to cng ?

    In the EFI's behavior discussed above, initial start is done over petrol and then auto changed to CNG, I like it very much so my mind don't accept manual switching from petrol to cng. It is surely a bug, and i want to solve it with YOU PEOPLE's help rather than just compromise and do the CNG/PETROL switching manually.
    What car are we talking about and which engine ?

  10. #10
    PakWheeler Follow
    mehranhu's Avatar
    Join Date
    Dec 2012
    Location
    Islamabad
    Posts
    80
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Fahad.Ayub View Post
    What car are we talking about and which engine ?
    Toyotta Corolla AE100;
    16 VOLVE EFI.

    It is Corolla SE SALOON; Auto Transmision, 1993 model.

  11. #11
    PakWheeler Follow
    makniazi's Avatar
    Join Date
    Oct 2010
    Location
    Peshawar
    Posts
    428
    Follows
    0
    Following
    0
    Mentioned
    26 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    reprogram your cng switch to convert at a higher rpm start the car leave it for a min then give some accelerator to convert also add relay to cng kit
    All you need in this life is ignorance and confidence, and then success is sure.

  12. #12
    PakWheeler Follow
    mehranhu's Avatar
    Join Date
    Dec 2012
    Location
    Islamabad
    Posts
    80
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by makniazi View Post
    reprogram your cng switch to convert at a higher rpm start the car leave it for a min then give some accelerator to convert also add relay to cng kit

    (*) Thats the most interesting scene makniazi; who will program it for me?

    And which side should i add the relay on kit. please tell me exact so that i can force electrician to do that; wesai un logo ki apni stories hoti hain.

  13. #13
    PakWheeler Follow
    makniazi's Avatar
    Join Date
    Oct 2010
    Location
    Peshawar
    Posts
    428
    Follows
    0
    Following
    0
    Mentioned
    26 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Add a relay on the blue wire and reprograming is simple i have the manual some where if you have original landi renzo switch i'll upload the manual in a while let me look for it
    All you need in this life is ignorance and confidence, and then success is sure.

  14. #14
    PakWheeler Follow
    makniazi's Avatar
    Join Date
    Oct 2010
    Location
    Peshawar
    Posts
    428
    Follows
    0
    Following
    0
    Mentioned
    26 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Swit096 20091202 here you go this is how to program i will try to find one in english if u have problem with this have it somewhere
    All you need in this life is ignorance and confidence, and then success is sure.

  15. #15
    PakWheeler Follow
    mehranhu's Avatar
    Join Date
    Dec 2012
    Location
    Islamabad
    Posts
    80
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Thanks. Already reprogrammed and set switching rpm to 1800. I am sure it has solved the issue. Thanks for guide and manual.
    I'll update status in the morning inshaAllah.

    Relay is already installed, reprogramming is really what I was expecting. Thanks again

  16. #16
    PakWheeler Follow
    mehranhu's Avatar
    Join Date
    Dec 2012
    Location
    Islamabad
    Posts
    80
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Issue Resolved ! Thanks to All, specially 'makniazi '.

    The problem was with Conversion switch, it was switching at 900 or 1000 rpm. I reprogrammed it, fed it to convert at 1800rpm (aprox).
    In the morning, i ignited the engine and it didn't switched auto; waited for me to give throttle, green led was blinking, starting rpm was 900; i waited 2/3 minutes, rmp raised to 1000 as the engine heated a bit. then i gave throttle, increased rpm to 1800 and it switched perfectly with no dying.

    Thanks God, we have got technical people to discuss things with (Y)

  17. #17
    PakWheeler Follow
    makniazi's Avatar
    Join Date
    Oct 2010
    Location
    Peshawar
    Posts
    428
    Follows
    0
    Following
    0
    Mentioned
    26 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    mehranhu I am glad I helped you
    Regards

    Sent from my HTC One X using PW Forums mobile app
    All you need in this life is ignorance and confidence, and then success is sure.

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •