Survey by Qualaroo
+ Reply to Thread
Results 1 to 7 of 7

Thread: Please help!!! Se Saloon engine problem

  1. #1
    PakWheeler Follow
    omerjamil's Avatar
    Join Date
    May 2005
    Location
    Lahore
    Age
    32
    Posts
    12
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Post Please help!!! Se Saloon engine problem

    Hello Everyone!!!
    I have a 2004 Se Saloon (1600cc). My car's engine is bubbling at idle, recently I had the car tuned with throttle body was cleaned etc but the problem still persists. There is also a slight grinding noise from the engine when it goes above 2500 rpm. The engine sound at start up is also different than before, can anyone please suggest a solution?
    The car is very heavy on fuel (8 Km/l max), and the acceleration seems slower than normal.
    The cars engine does not blow nor does it decrease or burn lubricant, the engine oil is changed consistently at around 2500-3000 km. The car has been inspected by technicians at toyota and they suggested Hi Octane Fuel since then I have been using a tank full of Hi Octane once a month, but the problem persists.

    I would be grateful if someone can suggest a possible solution
    Thanks

  2. #2
    PakWheeler Follow
    ch.talal's Avatar
    Join Date
    Mar 2014
    Location
    Lahore
    Posts
    662
    Follows
    0
    Following
    0
    Mentioned
    19 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    2

    Default

    Bubbles in radiator?

  3. #3
    Senior PakWheeler Follow
    Ehsan4808's Avatar
    Join Date
    Sep 2007
    Location
    Lahore
    Age
    34
    Posts
    1,811
    Follows
    7
    Following
    0
    Mentioned
    53 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by ch.talal View Post
    Bubbles in radiator?
    I think that the OP means that the car wobbles at idles... Its just like people say "Wheel Balance karwa lo as car bubbling kar rahi hai , Instead of using the word Wobbling, they say Bubbling ..

  4. #4
    Senior PakWheeler Follow
    epigenius's Avatar
    Join Date
    Apr 2012
    Location
    Islamabad
    Posts
    1,085
    Follows
    0
    Following
    0
    Mentioned
    33 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    use an OBD to gather data and see what error it gives you BTW are you done with regular maintainance???if the car is on CNG try another venturi and those who suggest you higher octane are jahil and secondly you are not doing it right when it comes to engine oil you are replacng it at 3000 whereas it should be replaced at 5000km

  5. #5
    PakWheeler Follow
    saeedmagsi's Avatar
    Join Date
    Nov 2011
    Location
    Quetta
    Posts
    229
    Follows
    0
    Following
    0
    Mentioned
    34 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    0

    Default

    A proper tune up may solve your problem.

    Sent from my A600 using PW Forums mobile app

  6. #6
    Senior PakWheeler Follow
    vagabondpiper's Avatar
    Join Date
    Jun 2010
    Location
    Islamabad
    Age
    34
    Posts
    1,327
    Follows
    1
    Following
    0
    Mentioned
    23 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by omerjamil View Post
    Hello Everyone!!!
    I have a 2004 Se Saloon (1600cc). My car's engine is bubbling at idle, recently I had the car tuned with throttle body was cleaned etc but the problem still persists. There is also a slight grinding noise from the engine when it goes above 2500 rpm. The engine sound at start up is also different than before, can anyone please suggest a solution?
    The car is very heavy on fuel (8 Km/l max), and the acceleration seems slower than normal.
    The cars engine does not blow nor does it decrease or burn lubricant, the engine oil is changed consistently at around 2500-3000 km. The car has been inspected by technicians at toyota and they suggested Hi Octane Fuel since then I have been using a tank full of Hi Octane once a month, but the problem persists.

    I would be grateful if someone can suggest a possible solution
    Thanks
    1.Wobbling or Vibration at idle : Get the idle rpms checked on OBD and get them adjusted
    2.Grinding noise : Are you sure all the screws of plastic cover ovehead engine are present and tightened properly?
    3.8km/l and car feels heavy : I assume you've auto transmission. My SE 04 gives 8-9 km/L in city driving and also feels bit heavy in acceleration. Don't use hi octane youll feel your car further heavier.
    No one cares for Toyota more then Toyota

  7. #7
    PakWheeler Follow
    omerjamil's Avatar
    Join Date
    May 2005
    Location
    Lahore
    Age
    32
    Posts
    12
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Thankyou for all your replies..
    My car has never been run on cng, and its manual.
    I shall have the screws tightened, can anyone please suggest a good mechanic for an OBD? I live in Lahore DHA

+ Reply to Thread

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •