Survey by Qualaroo
+ Reply to Thread
Results 1 to 5 of 5

Thread: Obd1 4afe error code 42- VSS -xulfiqar bhai help plz

  1. #1
    PakWheeler Follow
    chali's Avatar
    Join Date
    May 2005
    Location
    Islamabad
    Age
    29
    Posts
    677
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Obd1 4afe error code 42- VSS -xulfiqar bhai help plz

    My corolla 1996 with 4afe giving error code 42 which is of vehicle speed sensor
    apperantly car is running fine
    speedo meter is working fine
    Rpm works correctly


    Just Curious why is car giving code
    Which parts shall i check to get rid of the error code


    I noticed that some times ,once in 15 days the speedo doesn't work untill it reaches 20 km/hr - that too once twice or thrice a month


    Other question is what is ECON in air conditioning mode!
    I heard it cuts off the compressor when u accelerate-but i never felt any such thing is because of 42 code...?..
    CHOUDHRY ALI - GOLD & GREEN because Old is gold and hybrids are green

  2. #2
    Senior PakWheeler Follow
    capsat's Avatar
    Join Date
    Apr 2006
    Location
    Select City
    Age
    10
    Posts
    12,592
    Follows
    31
    Following
    6
    Mentioned
    1017 Post(s)
    Tagged
    19 Thread(s)
    Problems Posted
    2
    Problems Solved
    5
    Best Answers
    3
    Good Answers
    6

    Default

    answer is within your question

    Quote Originally Posted by chali View Post
    My corolla 1996 with 4afe giving error code 42 which is of vehicle speed sensor
    apperantly car is running fine
    speedo meter is working fine
    Rpm works correctly


    Just Curious why is car giving code
    Which parts shall i check to get rid of the error code


    I noticed that some times ,once in 15 days the speedo doesn't work untill it reaches 20 km/hr - that too once twice or thrice a month


    Other question is what is ECON in air conditioning mode!
    I heard it cuts off the compressor when u accelerate-but i never felt any such thing is because of 42 code...?..
    change the VSS [ vehicle speed sensor ] - for ECON click me
    - www.crackwheels.com - A skilled Dictator is much more beneficial to Country......than a Democracy of Ignorant people

  3. #3
    Senior PakWheeler Follow
    Owais_Yunus's Avatar
    Join Date
    Sep 2005
    Location
    Islamabad
    Age
    28
    Posts
    2,224
    Follows
    4
    Following
    0
    Mentioned
    60 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Take out the grip on the vss and see if it has corrosion. Is it a stock 4afe or has it been swapped into the car? If its a swap, its possible that the ecu isnt getting the speed signal from the speedometer (SPD).

  4. #4
    PakWheeler Follow
    chali's Avatar
    Join Date
    May 2005
    Location
    Islamabad
    Age
    29
    Posts
    677
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Its a swap . But matter of fact is that i replaced whole dashboard wiring only for the sake of original grips for ecu and changed the instrument cluster meter and uncut engine wiring .
    CHOUDHRY ALI - GOLD & GREEN because Old is gold and hybrids are green

  5. #5
    PakWheeler Follow
    mehranhu's Avatar
    Join Date
    Dec 2012
    Location
    Islamabad
    Posts
    80
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Same problem. Please put your expert oinion

    Mine is Corolla SE Saloon auto. 1993.
    I doubt came with genuine 4E-FE.
    Previous owner replaced it with 5A-FE (may be).

    Now the ACU is 5A-FE, and the engine is 4A-FE (16 Volvo 1.5)

    The problem arrived after I put engine from pindi.
    Error code 42.

    Speedometer and trip works fine. Never shows problem.
    If I drive it on soft panel, (non aggressive) it works fine.
    But when I run on heavy feet (driver speaking ) each gear shift is above 3500 rpm approx. and check engine light is comes every time I run heavy. It shows up on 3rd gear and above (auto transmission, so 3rd gear is not must).

    I have checked error code many times and it is 42.
    Replaced speed sensor in gear with a qabli, same looking piece. But again light shown up on test drive. (Then I returned the sensor and put back my own)

    The question is, if gear shifts are good and speedometer is good, where is the problem even I replaced VSS.

    Is there any compatibility issue with 5a's ACU with 4a's VSS?

    Is there a problem in wiring?

    How can I debug it? Please help

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •