Survey by Qualaroo
+ Reply to Thread
Results 1 to 14 of 14
Like Tree4Likes
  • 1 Post By capsat
  • 1 Post By afnanSJfayaz
  • 2 Post By avais

Thread: Altis 1.6 engine light urgent help

  1. #1
    PakWheeler Follow
    avais's Avatar
    Join Date
    Oct 2005
    Location
    Lahore
    Age
    29
    Posts
    249
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Altis 1.6 engine light urgent help

    Need urgent help!
    I have Altis 1.6 cruistronic 2012. Check engine light appears and light turns on and then throttle stop working. Then if i turn off engine and turn it on again throttle works fine but the engine light and message still appears.
    I got checked with toyata the asked me to get engine wire and throttle change costing 60-70k. This they were not well awared the read codes fromm book and told wt to do.


    Anyone having similar issues? Please advice how its solved.

    Waiting for urgent early reply.

    "SIMPLICITY IS THE BEST BEAUTY"

  2. #2
    Senior PakWheeler Follow
    afnanSJfayaz's Avatar
    Join Date
    Nov 2010
    Location
    Newcastle upon Tyne
    Posts
    1,164
    Follows
    1
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Bro had same problem. You're floor mat is obstructing the accelerator pedal causing the engine check light to come one. P2121 might be the code that appeared.

  3. #3
    PakWheeler Follow
    avais's Avatar
    Join Date
    Oct 2005
    Location
    Lahore
    Age
    29
    Posts
    249
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Yes its the code

  4. #4
    PakWheeler Follow
    avais's Avatar
    Join Date
    Oct 2005
    Location
    Lahore
    Age
    29
    Posts
    249
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Did you remove mat entirety? Or just pulled little? Further how long it takes light to go off? As i removed its not instantly going

  5. #5
    Senior PakWheeler Follow
    afnanSJfayaz's Avatar
    Join Date
    Nov 2010
    Location
    Newcastle upon Tyne
    Posts
    1,164
    Follows
    1
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by avais View Post
    Did you remove mat entirety? Or just pulled little? Further how long it takes light to go off? As i removed its not instantly going
    Bro this is a common issue, manager told me this at Toyota GT motors. I got the types of mat which are fixed down by 2 pins on the drivers side. That solved the problem. Also when the problem occured I had an OBD 2 Scanner so whenever the engine light came on I would delete the light immediately.

  6. #6
    PakWheeler Follow
    avais's Avatar
    Join Date
    Oct 2005
    Location
    Lahore
    Age
    29
    Posts
    249
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Bro from where we can get OBD 2 scanner n how much it costs?
    Really appreciate your help.

  7. #7
    Senior PakWheeler Follow
    capsat's Avatar
    Join Date
    Apr 2006
    Location
    Select City
    Age
    10
    Posts
    12,578
    Follows
    31
    Following
    6
    Mentioned
    1017 Post(s)
    Tagged
    19 Thread(s)
    Problems Posted
    2
    Problems Solved
    5
    Best Answers
    3
    Good Answers
    6

    Default

    remove the driver side floor mat,. Remove positive terminal from battery at night. connect & start next day morning. Keep floor mat away from driver side.
    - www.crackwheels.com - A skilled Dictator is much more beneficial to Country......than a Democracy of Ignorant people

  8. #8
    Senior PakWheeler Follow
    afnanSJfayaz's Avatar
    Join Date
    Nov 2010
    Location
    Newcastle upon Tyne
    Posts
    1,164
    Follows
    1
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by avais View Post
    Bro from where we can get OBD 2 scanner n how much it costs?
    Really appreciate your help.
    I got it online from amazon but you dont have to get it. I have it for shoqia purposes only. This isn't the soultion. Try and get these mats, I have them in my car and it should solve the problem. We tend to push the floor mat upwards, towards the pedals whilst sitting in the car which causes the problem. I made a thread about this problem too and went to toyota abbott motors. They gave me all sorts of crap like o2 sensors are faulty and engine wiring needs a check and blah blah. Anyways they cleaned the o2 sensor and the check light vanished probably because they disconnected the battery. Then for my 20k service I went to Toyota gt motors and politely asked them if they could clean the o2 sensor along with all the normal stuff they do at the 20k service, the manager who was there was quite shocked and asked me why I wanted the sensor to be cleaned. I told him all the problems such as little or no throttle response and he started laughing. He then opened my driver side door and there it was my mat was clearly pushed up behind the accelerator.
    It's worth spending 2000 rupees to go to Toyota GT than to be advised by incompetent rip off's.
    Attached Images Attached Images  

  9. #9
    PakWheeler Follow
    avais's Avatar
    Join Date
    Oct 2005
    Location
    Lahore
    Age
    29
    Posts
    249
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Thank you so much. I pulled the mat and problem is solved yet. Lets hope no issues later. Thanks alot again

  10. #10
    Senior PakWheeler Follow
    capsat's Avatar
    Join Date
    Apr 2006
    Location
    Select City
    Age
    10
    Posts
    12,578
    Follows
    31
    Following
    6
    Mentioned
    1017 Post(s)
    Tagged
    19 Thread(s)
    Problems Posted
    2
    Problems Solved
    5
    Best Answers
    3
    Good Answers
    6

    Default

    Quote Originally Posted by avais View Post
    Thank you so much. I pulled the mat and problem is solved yet. Lets hope no issues later. Thanks alot again
    Good to hear your problem solved, this is the spirit of this very forum to learn & to help, stay blessed

    ever wonder why there are no floor mats in a brand new car from factory
    - www.crackwheels.com - A skilled Dictator is much more beneficial to Country......than a Democracy of Ignorant people

  11. #11
    PakWheeler Follow
    avais's Avatar
    Join Date
    Oct 2005
    Location
    Lahore
    Age
    29
    Posts
    249
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I am having issue again after removing. Mat some more suggestions??

  12. #12
    Senior PakWheeler Follow
    afnanSJfayaz's Avatar
    Join Date
    Nov 2010
    Location
    Newcastle upon Tyne
    Posts
    1,164
    Follows
    1
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Give me some time. I remember some procedure I tried when I had the problem. Try this and see if it works but i need to search my hard drive to find the screenshot.

    Sent from my SM-N9005 using Tapatalk

  13. #13
    Senior PakWheeler Follow
    afnanSJfayaz's Avatar
    Join Date
    Nov 2010
    Location
    Newcastle upon Tyne
    Posts
    1,164
    Follows
    1
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Found it. This would keep the engine check light off the my car for 3-4 days untill I removed the mat and its been 8 months and no engine check light, Alhamdulillah. Can't seem to get a better view so that you can read it. Try zooming in.


    Altis 16  engine light urgent help -1538009
    Attached Images Attached Images  

  14. #14
    PakWheeler Follow
    avais's Avatar
    Join Date
    Oct 2005
    Location
    Lahore
    Age
    29
    Posts
    249
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Thanks

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •