Survey by Qualaroo
+ Reply to Thread
Results 1 to 17 of 17

Thread: Corolla diesel fans problem

  1. #1
    Senior PakWheeler Follow
    akash190's Avatar
    Join Date
    Feb 2011
    Location
    Kharian
    Age
    22
    Posts
    1,399
    Follows
    1
    Following
    0
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    3
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    3

    Default Corolla diesel fans problem

    okay guys am here with a new problem faced today when i got ac system cleaned and charged with the old gas just fill it some the problem is when i turn on ac fans run on slow speed when car is cool the temprature is down but when car reaches at 45-50% fans runs in high speed but not on slow while ac is on they are like after 5-10seconds with full speed for 5 seconds only but they dont run at slow speed what could be the problem

    A real driver knows exactly what's in his car.

  2. #2
    FBB
    FBB is offline
    PakWheeler Follow
    FBB's Avatar
    Join Date
    Sep 2015
    Location
    Peshawar
    Age
    39
    Posts
    521
    Follows
    1
    Following
    2
    Mentioned
    14 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Is the AC is connected through ECU?

    Sent from my Z12 using Tapatalk

  3. #3
    Senior PakWheeler Follow
    akash190's Avatar
    Join Date
    Feb 2011
    Location
    Kharian
    Age
    22
    Posts
    1,399
    Follows
    1
    Following
    0
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    3
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    3

    Default

    Quote Originally Posted by qamarahmad.awan View Post
    Is the AC is connected through ECU?

    Sent from my Z12 using Tapatalk
    Yes it is everything is genuine never opened no mess with anything
    A real driver knows exactly what's in his car.

  4. #4
    FBB
    FBB is offline
    PakWheeler Follow
    FBB's Avatar
    Join Date
    Sep 2015
    Location
    Peshawar
    Age
    39
    Posts
    521
    Follows
    1
    Following
    2
    Mentioned
    14 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    I am having Nissan, and it is also doing same, its radiator fan also operates at 2 variable speeds.
    When turning on AC it only circulate at normal speed that is required to cool the cabin and when temp rises it takes more speed to cool the engine and then becomes slow or say normal.
    It is not fault, its ECU which is controlling the fan speed as per requiremen.

    Sent from my Z12 using Tapatalk

  5. #5
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,405
    Follows
    131
    Following
    0
    Mentioned
    3990 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    Quote Originally Posted by akash190 View Post
    okay guys am here with a new problem faced today when i got ac system cleaned and charged with the old gas just fill it some the problem is when i turn on ac fans run on slow speed when car is cool the temprature is down but when car reaches at 45-50% fans runs in high speed but not on slow while ac is on they are like after 5-10seconds with full speed for 5 seconds only but they dont run at slow speed what could be the problem
    it sounds completely normal.

    the high speed function is kicked in if either the high pressure switch breaks contact to ground or the cooling fan thermistor breaks the ground contact. In that case the fans run in parallel at full speed.
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  6. #6
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,405
    Follows
    131
    Following
    0
    Mentioned
    3990 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    Quote Originally Posted by qamarahmad.awan View Post
    I am having Nissan, and it is also doing same, its radiator fan also operates at 2 variable speeds.
    When turning on AC it only circulate at normal speed that is required to cool the cabin and when temp rises it takes more speed to cool the engine and then becomes slow or say normal.
    It is not fault, its ECU which is controlling the fan speed as per requiremen.

    Sent from my Z12 using Tapatalk
    your nissan has similar fan operation but is done in a completely different way than toyota corolla diesel.
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  7. #7
    FBB
    FBB is offline
    PakWheeler Follow
    FBB's Avatar
    Join Date
    Sep 2015
    Location
    Peshawar
    Age
    39
    Posts
    521
    Follows
    1
    Following
    2
    Mentioned
    14 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by Xulfiqar View Post
    your nissan has similar fan operation but is done in a completely different way than toyota corolla diesel.
    So it is an issue according to your experience?

    Sent from my Z12 using Tapatalk

  8. #8
    PakWheeler Follow
    Salman922's Avatar
    Join Date
    Oct 2011
    Location
    Karachi
    Age
    24
    Posts
    510
    Follows
    1
    Following
    0
    Mentioned
    27 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    1

    Default

    It's completely normal, my cow does the same.

    Sent from my VS985 4G using Tapatalk

  9. #9
    Senior PakWheeler Follow
    akash190's Avatar
    Join Date
    Feb 2011
    Location
    Kharian
    Age
    22
    Posts
    1,399
    Follows
    1
    Following
    0
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    3
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    3

    Default

    Quote Originally Posted by qamarahmad.awan View Post
    I am having Nissan, and it is also doing same, its radiator fan also operates at 2 variable speeds.
    When turning on AC it only circulate at normal speed that is required to cool the cabin and when temp rises it takes more speed to cool the engine and then becomes slow or say normal.
    It is not fault, its ECU which is controlling the fan speed as per requiremen.

    Sent from my Z12 using Tapatalk
    They dont run at slow or normal speed, after seconds high speed relay kicks in and fans run for 20 seconds or less but thing is they dont run at low speed either they run at full speed with a gap of 10 seconds or turn off
    A real driver knows exactly what's in his car.

  10. #10
    Senior PakWheeler Follow
    akash190's Avatar
    Join Date
    Feb 2011
    Location
    Kharian
    Age
    22
    Posts
    1,399
    Follows
    1
    Following
    0
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    3
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    3

    Default

    One more thing i noticed that whenever compressor start fans doesnt starts at same time they start after aprox 5 seconds at full speed after running for 20 seconds or so they stop and dont run at normal/low speed, it was all good before recharging gas only the problem was low gas, what he did is filled compressor oil and some gas am facing this issue after i got it done, cooling is perfect car doesnt heatup all normal but am worried only for ac system
    A real driver knows exactly what's in his car.

  11. #11
    Senior PakWheeler Follow
    rozzzzz's Avatar
    Join Date
    Oct 2005
    Location
    Islamabad
    Posts
    21,925
    Follows
    12
    Following
    0
    Mentioned
    140 Post(s)
    Tagged
    5 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    2

    Default

    Quote Originally Posted by akash190 View Post
    One more thing i noticed that whenever compressor start fans doesnt starts at same time they start after aprox 5 seconds at full speed after running for 20 seconds or so they stop and dont run at normal/low speed, it was all good before recharging gas only the problem was low gas, what he did is filled compressor oil and some gas am facing this issue after i got it done, cooling is perfect car doesnt heatup all normal but am worried only for ac system
    nothing wrong with it .... few cars have double fan ..seprate for ac and radiator ..but most cars have single with different speeds

    turning ac on is ok ...fan will only start when it is required ..if it does after 5 second .. my corolla 2012 does same

    dont worry ..its not after gas charge ..you just have started noticing now
    MOTOR MANIACS ... An automotive service and repair workshop
    https://www.facebook.com/pages/Motor-Maniacs/721830141231922

  12. #12
    Senior PakWheeler Follow
    akash190's Avatar
    Join Date
    Feb 2011
    Location
    Kharian
    Age
    22
    Posts
    1,399
    Follows
    1
    Following
    0
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    3
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    3

    Default

    Quote Originally Posted by rozzzzz View Post
    nothing wrong with it .... few cars have double fan ..seprate for ac and radiator ..but most cars have single with different speeds

    turning ac on is ok ...fan will only start when it is required ..if it does after 5 second .. my corolla 2012 does same

    dont worry ..its not after gas charge ..you just have started noticing now
    okay then ill leave it, ac guy told me that its not normal so thats why i was more worried
    A real driver knows exactly what's in his car.

  13. #13
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,405
    Follows
    131
    Following
    0
    Mentioned
    3990 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    Quote Originally Posted by akash190 View Post
    One more thing i noticed that whenever compressor start fans doesnt starts at same time they start after aprox 5 seconds at full speed after running for 20 seconds or so they stop and dont run at normal/low speed, it was all good before recharging gas only the problem was low gas, what he did is filled compressor oil and some gas am facing this issue after i got it done, cooling is perfect car doesnt heatup all normal but am worried only for ac system
    your fans dont switch on at low speed when the A/C is started up?

    you have an issue then. - pop open the fuse box and check all the fan relays. If you have an old model you should have 3 fan relays.

    I have attached two generic toyota 3 relay fan system diagram and how they work

    parallel (full speed)

    Corolla diesel fans problem -1707178

    series (low speed)

    Corolla diesel fans problem -1707179

    I think you may be able to understand how they are working.

    If you have one single fan and the low speed is not functioning at all, then the above diagram is not valid.
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  14. #14
    Senior PakWheeler Follow
    akash190's Avatar
    Join Date
    Feb 2011
    Location
    Kharian
    Age
    22
    Posts
    1,399
    Follows
    1
    Following
    0
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    3
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    3

    Default

    Quote Originally Posted by Xulfiqar View Post
    your fans dont switch on at low speed when the A/C is started up?

    you have an issue then. - pop open the fuse box and check all the fan relays. If you have an old model you should have 3 fan relays.

    I have attached two generic toyota 3 relay fan system diagram and how they work

    parallel (full speed)

    Corolla diesel fans problem -1707178

    series (low speed)

    Corolla diesel fans problem -1707179

    I think you may be able to understand how they are working.

    If you have one single fan and the low speed is not functioning at all, then the above diagram is not valid.
    Yes fan dont switch on at low speed and Yes there are 3 relays on top of radiator, i will check fuse tomorrow
    A real driver knows exactly what's in his car.

  15. #15
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,405
    Follows
    131
    Following
    0
    Mentioned
    3990 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    Quote Originally Posted by akash190 View Post
    Yes fan dont switch on at low speed and Yes there are 3 relays on top of radiator, i will check fuse tomorrow
    how many fans do you have?
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  16. #16
    Senior PakWheeler Follow
    akash190's Avatar
    Join Date
    Feb 2011
    Location
    Kharian
    Age
    22
    Posts
    1,399
    Follows
    1
    Following
    0
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    3
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    3

    Default

    Quote Originally Posted by Xulfiqar View Post
    how many fans do you have?
    2 fans as its saloon
    A real driver knows exactly what's in his car.

  17. #17
    Senior PakWheeler Follow
    akash190's Avatar
    Join Date
    Feb 2011
    Location
    Kharian
    Age
    22
    Posts
    1,399
    Follows
    1
    Following
    0
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    3
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    3

    Default

    Quote Originally Posted by Xulfiqar View Post
    how many fans do you have?
    Xulfiqar bhai i got everything checked its fine one more thing i wanna add on cold start when fans run in slow speed but as soon car reaches its optimum temp they only runs at high speed with tripping
    A real driver knows exactly what's in his car.

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •