Survey by Qualaroo
+ Reply to Thread
Results 1 to 6 of 6

Thread: Corolla XLI 2012 Engine Vibrations Low RPM - Advice Needed

  1. #1
    PakWheeler Follow
    siqbal123456's Avatar
    Join Date
    May 2013
    Location
    Lahore
    Posts
    3
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Corolla XLI 2012 Engine Vibrations Low RPM - Advice Needed

    My Corolla XLI 2012 gives strong Engine vibrations due to Low RPM when clutch is pressed to change gears during motion. This happens at random intervals and with AC ON. This has been happening for couple of months. It is driven 83000 Km and always serviced at Toyota dealership. The Toyota workshop changed plugs, air filter, oil+filter, performed tuning and throttle Body Service, checked AC, checked oxygen sensor, checked engine mounts but could not find anything wrong. I have tried Hi-Octane and driven hard to clear any fuel clogs but no improvement. Toyota is clueless about this fault. Any advice from Pakwheels members would be welcome.

  2. #2
    PakWheeler Follow
    mani2020's Avatar
    Join Date
    Apr 2011
    Location
    Lahore
    Posts
    95
    Follows
    1
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Check coil

  3. #3
    PakWheeler Follow
    loveburger's Avatar
    Join Date
    Sep 2006
    Location
    Lahore
    Age
    33
    Posts
    155
    Follows
    0
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Throttle Body wasn't cleaned properly ,ask the Toyota Guys to re-clean the throttle refresh all the settings through computerized scanner

  4. #4
    PakWheeler Follow
    auto_rebel's Avatar
    Join Date
    Aug 2016
    Posts
    44
    Follows
    0
    Following
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    race thori ziada krdo

    Sent from my ALE-L21 using PW Forums mobile app

  5. #5
    PakWheeler Follow
    imrananr's Avatar
    Join Date
    Jun 2014
    Posts
    837
    Follows
    0
    Following
    5
    Mentioned
    19 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Very bad suggestion, as if it's a 70cc bike.
    Don't leave a highway for a byway....

  6. #6
    PakWheeler Follow
    ozanhasan's Avatar
    Join Date
    Mar 2010
    Location
    Karachi
    Posts
    7
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    install new 3 point ground wiring! Generator to battery+. battery - to body metal (near headlight) and engine to body/chassis!.. tried and tested on my 2011 xli with 70000 on the odo....

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •