Survey by Qualaroo
+ Reply to Thread
Results 1 to 13 of 13

Thread: Issue with cultus (No accelaration whatsoever rmp high picks up very slow)

  1. #1
    PakWheeler Follow
    generallee's Avatar
    Join Date
    Jun 2008
    Location
    Islamabad
    Posts
    970
    Follows
    0
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Issue with cultus (No accelaration whatsoever rmp high picks up very slow)

    My Cultus carbi 2007 is having a lot of problem lately. The car is not accelerating properly. I mean the clutch is released but it looks like someone is still holding up the car. RPM goes up but the car accelerates very slowly. No matter which gear it is the acceleration is poor.

    It is very annoying and makes the driver feels stupid as it seems someone is driving with brakes applied. I went to mechanic he said clutch was tight so he loosened it up but the problem only got worse. Please Help. I need expert advice fast.

    Jumpshare.com - Share and view over 250 file formats online (A venture from Pakistan)

  2. #2
    PakWheeler Follow
    gn2903's Avatar
    Join Date
    Dec 2008
    Location
    Karachi
    Age
    30
    Posts
    405
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    could b a problem with the clutch-plate, get that checked
    often is happens that the car's clutch plate slips, because of which the cars rpm rise as normal, but acceleration is v.slow
    Cleverly disguised as a responsible adult.

  3. #3
    Senior PakWheeler Follow
    scorpion80's Avatar
    Join Date
    May 2007
    Location
    Karachi
    Age
    36
    Posts
    4,320
    Follows
    0
    Following
    0
    Mentioned
    11 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    how much it is driven ??
    ..
    ur car is cng ?? its happening on both fuels ??
    -

  4. #4
    PakWheeler Follow
    akrizvi05's Avatar
    Join Date
    Nov 2010
    Location
    Lahore
    Posts
    3
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    It might be a problem with ur car clutch plates, In Cultus 3 cylinder pick up no doubt is low as compare to it's new model or other 1.0 vehicles. The best thing u check its clutch /pressure plates. it also depend how this car is driven through its life, if so harsh so it might effect the engine and C.plates etc. and secondly the engine oil and filter u used in yr car is very important.

  5. #5
    PakWheeler Follow
    generallee's Avatar
    Join Date
    Jun 2008
    Location
    Islamabad
    Posts
    970
    Follows
    0
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    it happens on both fuels. I have Cultus for 3 years (its 2007) and I know the actual and current acceleration difference. It must be the clutch plates then.
    Jumpshare.com - Share and view over 250 file formats online (A venture from Pakistan)

  6. #6
    PakWheeler Follow
    yasirzxc's Avatar
    Join Date
    Mar 2007
    Location
    Karachi
    Age
    35
    Posts
    64
    Follows
    0
    Following
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    swap the engine to 1.3 efi end ride in heaven

  7. #7
    Senior PakWheeler Follow
    adyiator's Avatar
    Join Date
    Feb 2005
    Location
    Lahore
    Age
    38
    Posts
    1,225
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Get your carburetors' butterfly checked. I also have this issue, & i'm told to repair the butterfly & all in & outs of carb. costs only 800.Rs max.
    I'm struggling to please ALLAH, I'll suggest you do the same.

  8. #8
    Senior PakWheeler Follow
    chinyoti's Avatar
    Join Date
    Sep 2005
    Location
    Karachi
    Age
    27
    Posts
    11,965
    Follows
    5
    Following
    0
    Mentioned
    108 Post(s)
    Tagged
    5 Thread(s)
    Problems Posted
    2
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    1

    Default

    looks like a dying clutch
    Get over the fact that Xli lacks power windows, Its an Xli because it lacks thoose features or else it would be a Gli or an Altis if had all the goodies.

  9. #9
    Senior PakWheeler Follow
    smartdevil_striker's Avatar
    Join Date
    Dec 2006
    Location
    Karachi
    Age
    30
    Posts
    3,359
    Follows
    8
    Following
    0
    Mentioned
    109 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    The Culprit is Dre in Clutch+Pressure Plate...The Work of Gear Box is to Shift after the Shifting Work depend upon Clutch Plate+Pressure Plate so check It...
    Platinum&Iridium Plugs,Performance 8MM Wires,Automotive Bulbs and Bosch Horns for sale Contact: 0333-3035482

  10. #10
    Senior PakWheeler Follow
    adyiator's Avatar
    Join Date
    Feb 2005
    Location
    Lahore
    Age
    38
    Posts
    1,225
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    don't forget to get you carburator butterfly checked.
    I'm struggling to please ALLAH, I'll suggest you do the same.

  11. #11
    PakWheeler Follow
    generallee's Avatar
    Join Date
    Jun 2008
    Location
    Islamabad
    Posts
    970
    Follows
    0
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    problem solved. needed to replace pressure plate and clutch plate.
    Jumpshare.com - Share and view over 250 file formats online (A venture from Pakistan)

  12. #12
    Senior PakWheeler Follow
    tayyabbaig's Avatar
    Join Date
    Nov 2008
    Location
    Oslo
    Age
    34
    Posts
    2,706
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Yes it should be the clutch+pressure plates for sure. Anyways congrats!

  13. #13
    Senior PakWheeler Follow
    wonder_guy's Avatar
    Join Date
    Oct 2005
    Location
    Lahore
    Age
    33
    Posts
    3,613
    Follows
    1
    Following
    0
    Mentioned
    17 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Does it also vibrates when u release the clutch...if so the clutch and pressure plate is the issue.
    Flavor of Life on a 2 Wheeler - Project |Suzuki GS 500e|
    http://www.pakwheels.com/forums/bikes-3-wheelers/220849-project-suzuki-gs-500-a

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •