Survey by Qualaroo
+ Reply to Thread
Page 2 of 2 FirstFirst 12
Results 21 to 28 of 28

Thread: cultus efi throwing petrol from exaust ?

  1. #1
    Senior PakWheeler Follow
    shqamar's Avatar
    Join Date
    Jan 2009
    Location
    Karachi
    Age
    37
    Posts
    1,715
    Follows
    2
    Following
    0
    Mentioned
    19 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default cultus efi throwing petrol from exaust ?

    hey guys ,
    my friend 2007 efi cultus throwing petrol from exaust , i wonder what could be the reason for that , the car is properly tuned recently , car when start on petrol shakes a bit but than it seems okie on the other hand it works absolutely perfect on cng , recently we just observed fresh petrol coming out from exaust , experts please let us know what could be the reason for that ? thanks in advance .

    Crackwheels.com

  2. #21
    Senior PakWheeler Follow
    shqamar's Avatar
    Join Date
    Jan 2009
    Location
    Karachi
    Age
    37
    Posts
    1,715
    Follows
    2
    Following
    0
    Mentioned
    19 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by SER_GTR View Post
    Injectors Dead....? car is running fine on petrol??? maybe injectors are leak....maybe they need cleaning.....!! maybe DEAD...but they don't get dead or leak that easy until or unless someone wired or mess with wiring so that injector remain open so long....!!
    i smell something fishy b.t.w
    thats correct they are not dead according to paksuzuki they are leaked hence petrol coming out from exaust when car starts on petrol although the leak is not a lot now but u can still smell petrol once car start on petrol note car runs absolutely perfect on cng and petrol both no missfiring no jerking nothing it just car smells petrol when start on petrol and petrol or steam coming out from exaust when running on petrol once it converts on cng it starts acting perfectly normal .
    Margallar brother we have already tried that cleaner unfortunately it aint working for us .
    doubletrouble dude thanks for sharing your valuable experience i will tell my friend lets see if we can get some good reliable mechanic .
    Crackwheels.com

  3. #22
    2c
    2c is offline
    Senior PakWheeler Follow
    2c's Avatar
    Join Date
    Aug 2007
    Location
    Sialkot
    Posts
    12,284
    Follows
    0
    Following
    0
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    did you try burning the liquid coming out of teh exhaust?
    what yoyu think is this that is petrol in reality it cold be water.

  4. #23
    Senior PakWheeler Follow
    shqamar's Avatar
    Join Date
    Jan 2009
    Location
    Karachi
    Age
    37
    Posts
    1,715
    Follows
    2
    Following
    0
    Mentioned
    19 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by 2c View Post
    did you try burning the liquid coming out of teh exhaust?
    what yoyu think is this that is petrol in reality it cold be water.
    yup it was petrol coming out from exaust mixed with water , its not bad yet that it mixed with oil , or oil looses or gained quantity yet but its definately petrol mixes with water .
    Crackwheels.com

  5. #24
    Site Banned Follow
    Ashfaq87's Avatar
    Join Date
    Aug 2010
    Location
    Lahore
    Age
    29
    Posts
    756
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    hmmm. go to some cng guy if u want ur car to start only on cng.

  6. #25
    Senior PakWheeler Follow
    shqamar's Avatar
    Join Date
    Jan 2009
    Location
    Karachi
    Age
    37
    Posts
    1,715
    Follows
    2
    Following
    0
    Mentioned
    19 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Ashfaq87 View Post
    hmmm. go to some cng guy if u want ur car to start only on cng.
    its not a permanent solution dude .
    Crackwheels.com

  7. #26
    Senior PakWheeler Follow
    shqamar's Avatar
    Join Date
    Jan 2009
    Location
    Karachi
    Age
    37
    Posts
    1,715
    Follows
    2
    Following
    0
    Mentioned
    19 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    verdict is efi cars are crap .
    Crackwheels.com

  8. #27
    PakWheeler Follow
    automaster's Avatar
    Join Date
    Nov 2008
    Location
    Karachi
    Posts
    185
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    salam @ all
    i have recently solve this problem a customer brouht a cultus EFI with same problem i have dignos and replace a emulator device of lambda cng .the problem is that fuel injection pulses going direct abt -12 volts after changing emu problem solved.
    Try to change what you can't accept & try to accept what you can't change

  9. #28
    Senior PakWheeler Follow
    shqamar's Avatar
    Join Date
    Jan 2009
    Location
    Karachi
    Age
    37
    Posts
    1,715
    Follows
    2
    Following
    0
    Mentioned
    19 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by automaster View Post
    salam @ all
    i have recently solve this problem a customer brouht a cultus EFI with same problem i have dignos and replace a emulator device of lambda cng .the problem is that fuel injection pulses going direct abt -12 volts after changing emu problem solved.
    thanks for solving my problem automaster can u please tell me how much it would cost me and your workshop adress so i will visit u for inspection thanks in advance .
    Crackwheels.com

+ Reply to Thread
Page 2 of 2 FirstFirst 12

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •