Survey by Qualaroo
+ Reply to Thread
Page 1 of 3 123 LastLast
Results 1 to 20 of 60
Like Tree7Likes

Thread: RPM drops on Petrol even carburetor & Butterfly repaired Cultus VXR

  1. #1
    PakWheeler Follow
    mahmad83's Avatar
    Join Date
    Mar 2010
    Location
    Lahore
    Age
    33
    Posts
    38
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default RPM drops on Petrol even carburetor & Butterfly repaired Cultus VXR

    Dear All,

    I had the issue of non stable RPM, after servicing of Carburetor and Butterfly, Issue is still there, When I give race to car, and RPM goes to 5-7K, then immediately after lifting race, RPM goes to zero, and car shutdown.

    I have no clue what is issue. Please respond asap.


  2. #2
    Senior PakWheeler Follow
    fahadwizz's Avatar
    Join Date
    Feb 2011
    Location
    Karachi
    Age
    35
    Posts
    2,383
    Follows
    1
    Following
    0
    Mentioned
    52 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    3

    Default

    I hope u also replaced your accelerator cable.

  3. #3
    Senior PakWheeler Follow
    schehxad's Avatar
    Join Date
    Jul 2009
    Location
    Muzaffarabad
    Age
    33
    Posts
    1,330
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    check for vaccum advancer pipe is it there in between distributor and carburetor
    SCHEHXAD

  4. #4
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,402
    Follows
    131
    Following
    0
    Mentioned
    3990 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    carburettor dash pot is inoperative - its there to hold the throttle open at abt 1600 rpm for about 1 second before gently releasing it.

    Its the vacuum diaphragm on the carb with a little plastic piece in it - that plastic piece is the device that slowly bleeds vacuum. If connected backwards it wont work and if not connected at all the dashpot effect will not work and you will suffer from what you are posting.
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  5. #5
    PakWheeler Follow
    mahmad83's Avatar
    Join Date
    Mar 2010
    Location
    Lahore
    Age
    33
    Posts
    38
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Mech has not replaced the Accelerator cable, I have check the plastic point on carb, it is connected. The cable is coming from body side, and when accelerator is released it goes backward (towards body).

    Please help

  6. #6
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,402
    Follows
    131
    Following
    0
    Mentioned
    3990 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    check operation of the dashpot - the dashpot should release the throttle (butterfly slowly - theres an adjustement screw on it also to fine tune the "holding" rpm. What you are describing is dashpot not working
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  7. #7
    PakWheeler Follow
    mahmad83's Avatar
    Join Date
    Mar 2010
    Location
    Lahore
    Age
    33
    Posts
    38
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Dear Zulfiqar,

    Mech did the adjustment, but mostly it is working stable, even I lift the race from 6-7K RPM, it goes to 1K RPM (also when applying brake).

    But 2/10, its behavior is same (Car goes down) due to RPM drops quickly to zero.

    Also can u give a favours, to tell me any good mechanic so that I can go there, and also can u share contact number, I will call u for this issue.


    Regards
    Ahmad

  8. #8
    PakWheeler Follow
    mahmad83's Avatar
    Join Date
    Mar 2010
    Location
    Lahore
    Age
    33
    Posts
    38
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    What about other members?

    Please help me in this regard.

  9. #9
    PakWheeler Follow
    isi0000's Avatar
    Join Date
    Feb 2011
    Location
    Islamabad
    Posts
    767
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @poster what if u start the car and leave it idle......is it shutdown???
    u drive the car and it shut down as u break to zero, is it???
    if so then it may b the issue of slow jet(in language of mechanics) requires cleaning
    "Women - always in trouble with them, but can`t live without them."
    Ayrton Senna

  10. #10
    PakWheeler Follow
    mahmad83's Avatar
    Join Date
    Mar 2010
    Location
    Lahore
    Age
    33
    Posts
    38
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Yes, you are right. When I apply the brake s, it goes down.
    Also when I release the accelerator while RPM is 6-7K, 2/10 times it goes down.

    Please help

  11. #11
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,402
    Follows
    131
    Following
    0
    Mentioned
    3990 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    Quote Originally Posted by mahmad83 View Post
    Yes, you are right. When I apply the brake s, it goes down.
    Also when I release the accelerator while RPM is 6-7K, 2/10 times it goes down.

    Please help

    leaky brake booster diaphragm or vacuum pipe to booster, remove pipe from manifold and plug the port - start engine and play around with the throttle - if its stable you have found your fault.
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  12. #12
    PakWheeler Follow
    kazmi_muzammil's Avatar
    Join Date
    Oct 2010
    Location
    Hyde Park
    Posts
    813
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by mahmad83 View Post
    Yes, you are right. When I apply the brake s, it goes down.
    Also when I release the accelerator while RPM is 6-7K, 2/10 times it goes down.

    Please help
    I don't think so it's the leaky diaphragm..

    Dear iv'e been through the same problem myself. I had a carby cultus back an 2003 one. Belonged to my Cousin who left it in Lahore with me so i kept it for about 2 years with me before selling it...

    Now i also encountered the same issue. We did all we could to resolve the issue, from butterflies to aeroplanes..

    What i found out was, i got the valve unit taken out.... Had a fight with my mech so serious i was gonna kill him because he wasn't agreeing.

    We poured petrol in it, what we found was that the valves were leaking as petrol leaked out from the edges of few valves. Now why did i come to that conclusion....

    Its simple, the car was driven on total gas when my cousin gave it to me, Gas is dry, has less moisture, it ruined the edges of the valves causing compression to leak out immediately and form also immediately... My car refused to pass the 80km/h speed limit as well and the car would eventually die down as soon as i pressed the pedal..

    So if you want first get the brake diaphragm checked as adviced by a pakwheel member expert.. But if that doesn't work ( and i think it will not), the issue is leaky valve and i suggest u get them replaced after checking with petrol as i told you...

    Take out the unit pour petrol into it, and look at the edges of valves if you see petrol leaking out from them...

    Here is a sample picture of the valves im talking about..

    RPM drops on Petrol even carburetor & Butterfly repaired Cultus VXR - images?qtbnANd9GcTuq6lwvij39TKjLBNa PpYhwtQEA9B0 75S9T 301S3VB9ceBN

  13. #13
    PakWheeler Follow
    kazmi_muzammil's Avatar
    Join Date
    Oct 2010
    Location
    Hyde Park
    Posts
    813
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Do let us know once uve resolved the issue out.

  14. #14
    PakWheeler Follow
    Hyder99's Avatar
    Join Date
    Oct 2009
    Location
    Rawalpindi
    Age
    24
    Posts
    15
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Weak Fuel pump which is usually in fuel tank nothing else..!!

  15. #15
    PakWheeler Follow
    mahmad83's Avatar
    Join Date
    Mar 2010
    Location
    Lahore
    Age
    33
    Posts
    38
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I got checked the fuel pump, it is working fine. Mech told that run the car on fuel for around 700 KM so that butterfly start work smoothly.

  16. #16
    PakWheeler Follow
    isi0000's Avatar
    Join Date
    Feb 2011
    Location
    Islamabad
    Posts
    767
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by mahmad83 View Post
    Yes, you are right. When I apply the brake s, it goes down.
    Also when I release the accelerator while RPM is 6-7K, 2/10 times it goes down.

    Please help
    you may also check the slow jet for any foreign particles or blockage.....
    "Women - always in trouble with them, but can`t live without them."
    Ayrton Senna

  17. #17
    PakWheeler Follow
    mahmad83's Avatar
    Join Date
    Mar 2010
    Location
    Lahore
    Age
    33
    Posts
    38
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Mech replaced the fuel jet, but same issue. Issue is more on while Car is on Petrol.

    Any help.

  18. #18
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,402
    Follows
    131
    Following
    0
    Mentioned
    3990 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    if the dashpot is OK, and you have got solid vacuum in the inlet manifold then only one thing comes to mind - the carburettor float height is either incorrect, or the needle valve is sticking, or may also be a choked fuel filter too.
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  19. #19
    PakWheeler Follow
    tjcivilian's Avatar
    Join Date
    May 2011
    Location
    Peshawar
    Age
    31
    Posts
    235
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    dude u r in real trouble... u have to replace ur carburator with another one. Once I had faced same peoblem in my 2003 cultus.
    I couldn't repair my breaks, so I made my horn louder...

  20. #20
    PakWheeler Follow
    mahmad83's Avatar
    Join Date
    Mar 2010
    Location
    Lahore
    Age
    33
    Posts
    38
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I checked with another mechanic, he told me that Butterfly and its road is little bit tight, so that when you press race, the RPM stuck when you apply brakes after some drive, they goes back ( around 1K RPM). Lets see..

    can you tell me Urdu name of Dashpot, so that I can share the same with mechanic?

+ Reply to Thread
Page 1 of 3 123 LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •