Survey by Qualaroo
+ Reply to Thread
Results 1 to 17 of 17

Thread: Cultus Low RPM on Startup

  1. #1
    PakWheeler Follow
    rauftirmizi's Avatar
    Join Date
    Jun 2011
    Location
    Islamabad
    Age
    36
    Posts
    11
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Cultus Low RPM on Startup

    The problem is that car starts with the rpm as low as 200. But the car does not shut off even at this rpm. I have to press accelerator to boost the rpms.Once car gets goind, there is no fluctuation or dropping of rpm on idle. The problem happens whether the car is hot or cold. The idle RPM setting is 1000.

    Also in the morning car starts with a long self. Once started it autochoke starts. Most of the times it starts with 1000 rpm and slowly rises to 1500 and sometimes it start with 1500 rpm and swiftly rises to 2000. Once it get warm, rpm drops to 1000 (idle setting) and stablizes.


    What could be the reason of low rpm on startup.


    Regards,
    Rauf


  2. #2
    Senior PakWheeler Follow
    rustam54's Avatar
    Join Date
    Aug 2006
    Location
    Lahore
    Posts
    1,004
    Follows
    1
    Following
    0
    Mentioned
    113 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Please explain your car specifications in detail. Model (Carburetor or EFI), Problem on CNG or petrol, last tunning schedule etc. You can view the following link that helps you in posting detailed info about your car and helps others in understanding and guiding you along the way.

    https://www.pakwheels.com/forums/sit...attention-mods
    The Soul's Journey After Death in Islam (www.bit.ly/SoulsJourney) -- Originally Shared by kse101

  3. #3
    PakWheeler Follow
    salishah85's Avatar
    Join Date
    Jan 2009
    Location
    Islamabad
    Age
    31
    Posts
    76
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    hay bro...it seems that you got a blown head gasket, firstly, to check it open its radiator tap when cold. turn engine on and than when it gets to normal temperature, see if they are bubbles in water while idle, because its taking long self to start up the engine, see if oil color is fine doesnt have any watery mixture in it,, you can see on your oil cover on the back of it after opening, now if its fine,get its tappet's loosen up. or get it adjusted....because cars tappets gets tight after some time running on cng ...Hope it may helo

  4. #4
    PakWheeler Follow
    6Forward's Avatar
    Join Date
    Feb 2012
    Location
    Lahore
    Posts
    203
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Your car needs to adjust RMP with chock from fast idling screw. Not from the idle rpm adjustment screw. ( Carburetor with Auto chock)
    And in EFI from throttle body ISCV (Idle speed control valve)

  5. #5
    PakWheeler Follow
    rauftirmizi's Avatar
    Join Date
    Jun 2011
    Location
    Islamabad
    Age
    36
    Posts
    11
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    My Car is Suzuki Cultus.
    Its model is 2003.
    It has no CNG and is on petrol.
    It has run 68000 Kms

    Regards,
    Rauf

  6. #6
    Newbie Follow
    usa2530's Avatar
    Join Date
    Mar 2012
    Posts
    1
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    how can i adjust mehran's RPM.. n one thing more that is there any impact on fuel after adjustment..

  7. #7
    PakWheeler Follow
    lonewolf1's Avatar
    Join Date
    Jun 2011
    Location
    Islamabad
    Posts
    248
    Follows
    3
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    as a sidenote, what is the best cultus (or general) electrician or mechanic in Islamabad?

  8. #8
    PakWheeler Follow
    sh4dow's Avatar
    Join Date
    Mar 2011
    Location
    Calgary
    Posts
    42
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    you need carborater service........
    *''*Someone has to fix the problems*''*

  9. #9
    PakWheeler Follow
    moonraider's Avatar
    Join Date
    Apr 2008
    Location
    Islamabad
    Age
    36
    Posts
    401
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    which is idle adjustment screw in cultus carby.. any pic please??
    NA cultus 06;stock g10 all motor;faulaadi pistons;half blocked air intake;saada air filter;NGK copper plugs;not so Free Flow exhaust & piping;50kg compressed CH3..want more??

  10. #10
    PakWheeler Follow
    rauftirmizi's Avatar
    Join Date
    Jun 2011
    Location
    Islamabad
    Age
    36
    Posts
    11
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @6Forward what is RMP?

    I have taken my car to mechanic and he told me that autochoke is not working.
    I have recently serviced my carburator and changed the cap and drain plug.
    I have heard that the choke of cultus operates with water.
    May be there is a problem with cap or drain plug.
    How to check for this?

  11. #11
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,405
    Follows
    131
    Following
    0
    Mentioned
    3991 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    if the cold start mechanism is stuck - fix it first.
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  12. #12
    PakWheeler Follow
    6Forward's Avatar
    Join Date
    Feb 2012
    Location
    Lahore
    Posts
    203
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @rauftirmizi
    sorry that is RPM
    choke opener operate with engine coolant (coolant temperature) but choke operates electrically.
    1. At morning when engine cold open air cleaner box and check on carburetor top that choke valve is fully closed. If closed its means choke is working (Electrically) and need to adjust RPM from fast idling screw it will increase choke RPM only.
    2. After starting few minutes choke opener will open choke slightly and when u give accelerate the engine choke breaker will break the choke.

  13. #13
    PakWheeler Follow
    6442's Avatar
    Join Date
    Nov 2011
    Location
    Lahore
    Posts
    171
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    clean the auto shock sensors............

  14. #14
    PakWheeler Follow
    6442's Avatar
    Join Date
    Nov 2011
    Location
    Lahore
    Posts
    171
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    the correct FF setting of sensor is ...it cold start with 1500 rpm and swiftly rises to 2000 & then gradually down

  15. #15
    PakWheeler Follow
    rauftirmizi's Avatar
    Join Date
    Jun 2011
    Location
    Islamabad
    Age
    36
    Posts
    11
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @6442 where is the autochoke sensor loated?

  16. #16
    PakWheeler Follow
    6Forward's Avatar
    Join Date
    Feb 2012
    Location
    Lahore
    Posts
    203
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Automatic Choke System

    Cultus Low RPM on Startup -390858 Cultus Low RPM on Startup -390860 Cultus Low RPM on Startup -390863 Cultus Low RPM on Startup -390865

  17. #17
    PakWheeler Follow
    lonewolf1's Avatar
    Join Date
    Jun 2011
    Location
    Islamabad
    Posts
    248
    Follows
    3
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Hello @rauftirmizi did you fix this issue? Which mechanic helped you in this. I am facing same in Islamabad.

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •