Survey by Qualaroo
+ Reply to Thread
Results 1 to 3 of 3

Thread: Cultus Engine Sound on Startup

  1. #1
    Newbie Follow
    tahirg2000's Avatar
    Join Date
    Mar 2012
    Location
    Karachi
    Posts
    1
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Cultus Engine Sound on Startup

    I bought a Suzuki Cultus 2010 EFI AC/Petrol about one month before. When I start the engine in the morning. The engine starts with very high RPM or with very high race. But after 2 or 3 minutes it becomes normal. But during this period it consumes more and more fuel. I want to ask that Is it the normal function of EFI engine or some setting problem exist. Thanks


  2. #2
    Senior PakWheeler Follow
    margallar's Avatar
    Join Date
    Oct 2009
    Location
    Lahore
    Posts
    9,960
    Follows
    6
    Following
    2
    Mentioned
    283 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    it is normal, the rpm stays high until the car has warmed up or unless u press the accelerator

  3. #3
    PakWheeler Follow
    ghufran_sidd's Avatar
    Join Date
    Aug 2008
    Location
    Karachi
    Age
    32
    Posts
    17
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    this is normal and is said to an AUTOCHOKE this will activate on cold start and when engine is in normal working temperature is backs to its normal R.P.M . and ofcourse fuel is burning more for startups

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •