Survey by Qualaroo
+ Reply to Thread
Page 2 of 3 FirstFirst 123 LastLast
Results 21 to 40 of 44
Like Tree2Likes

Thread: Cultus 08 VXRi CNG PROBLEM !!

  1. #1
    PakWheeler Follow
    ShAgY102's Avatar
    Join Date
    Apr 2009
    Location
    Hyderabad
    Age
    21
    Posts
    571
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Angry Cultus 08 VXRi CNG PROBLEM !!

    Hello Pakwheelers,

    From few days I am asking people on PW about this CNG issue. It started a month ago when I start A.C the RPM starts fluctuating and suddenly the engine is closed. I went to different mechanics of CNG, Engine, 3S, Wiring, Electrician and even showed car to many many people. Everyone says it has no problem. I usually drive at low RPM. Now what happened today After coming back from 3S got it laptop checked everything is fine. The car starts missing. My family was sitting in car and that piece of junk did not even wanted to move :\. It was missing heavily on CNG and Petrol both then after 5 minutes I called my driver and he opened the Bonnet and said start it he pulled the race wire for a while and then It started but again It started missing on CNG so I had to switch it to Petrol. My car was tuned 1000 km before from a good mechanic who tune my cars from 9 years (almost) Spark Plugs are also new. Radiator is new 2 channel (Thailand), CND advancer throttel body injectors lambda everything is fine confirmed by three laptop equipped service centers. Please help me Regarding this issue i am too much in trouble now :@ Feels like kicking the car out now. One more thing The car gives very poor mileage on CNG. The car runs smooth on Petrol (mostly) only caused problem today. Car water is to the full mark in bottel and full in the radiator. Engine oil is Havoline Petrol changed it at every 3k. RPM does not drop when fan + CD player + amp + speaker is turned on it only causes problem when A.C is turned on. It also gives very poor mileage. Please help

    Trying to be superman !

  2. #21
    PakWheeler Follow
    quddos's Avatar
    Join Date
    May 2011
    Location
    Lahore
    Posts
    715
    Follows
    0
    Following
    0
    Mentioned
    39 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by ShAgY102 View Post
    So brothers I went to a shop which was recommended by a friend in our plaza (he also had same issue in Cultus VXRi 07) He said this will occur how much you care but it can stop if you get some thing of XLI i.e Sensor and Injectors and plus get this stepper motor removed and let it be manual which he has done in his car. He told me it costed aroun 4.5k. I went to the same mechanic for the checking of ignition coils and rotating distributors he said everything is ok just the stepper needs to be replaced or check 3s if they can re program it ! Whats your advice PW's? 3S asking for 2k for re programming and that guy is asking for 4.5k and he takes guarantee for that !

    go for 3S..

  3. #22
    PakWheeler Follow
    ShAgY102's Avatar
    Join Date
    Apr 2009
    Location
    Hyderabad
    Age
    21
    Posts
    571
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default 3S

    Seriously I don't trust them anymore I have payed like 400 for my every visit been there for a dozen times :/ all they do is Sir ap yahan bethen hum abhi check ker dete hain :@ and they put some laptop in it and check it and after few minutes a guy in tie comes and says sir everything is ok but when i go for other mechanics whom I trust cause i have their experience they say sir ye suzuki waloun ko kujh nahn pata gadi ko kholte nahn sirf laptop lagaya wo galat bhi to hota hai !
    BUT still I will wait for more people advices !
    Trying to be superman !

  4. #23
    PakWheeler Follow
    sahirzzz's Avatar
    Join Date
    Jun 2007
    Location
    Islamabad
    Age
    37
    Posts
    203
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    go to any a/c mechanic and ask him to remove ur car compressor grip and then see the techo meter and liston to the engine, then put the grip on and do it again. also check the current drawn by compressor. most probably it is getting jammed and putting too much load on engine and on slow rpm the engine is nor able to handle the load. so now u have two options
    1. get throttle manually adjusted for higher rpm that when u apply brake the rpm is still high enough to bear the load.
    2. get a kably compressor for RS 4000 and get it installed. they would ask u that xyz is good but go for genuine kably one.
    also get ur choke cleaned up. probably that is also adding to the problem.

  5. #24
    PakWheeler Follow
    ShAgY102's Avatar
    Join Date
    Apr 2009
    Location
    Hyderabad
    Age
    21
    Posts
    571
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by sahirzzz View Post
    go to any a/c mechanic and ask him to remove ur car compressor grip and then see the techo meter and liston to the engine, then put the grip on and do it again. also check the current drawn by compressor. most probably it is getting jammed and putting too much load on engine and on slow rpm the engine is nor able to handle the load. so now u have two options
    1. get throttle manually adjusted for higher rpm that when u apply brake the rpm is still high enough to bear the load.
    2. get a kably compressor for RS 4000 and get it installed. they would ask u that xyz is good but go for genuine kably one.
    also get ur choke cleaned up. probably that is also adding to the problem.
    Brother A.C mechanic is a very trained person I had been to him last week he said Sir A.C ka masla nahn hai he aslo opened everything it was serviced gas was filled fan was cleaned and everything was in proper shape. One more thing if it was a A.C problem then wouldn't it be on Petrol? or when the car is not that much hot (up to the middle of heat needle)
    Trying to be superman !

  6. #25
    PakWheeler Follow
    ShAgY102's Avatar
    Join Date
    Apr 2009
    Location
    Hyderabad
    Age
    21
    Posts
    571
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Bump......
    Trying to be superman !

  7. #26
    PakWheeler Follow
    itsgumbys's Avatar
    Join Date
    May 2007
    Location
    Islamabad
    Posts
    707
    Follows
    0
    Following
    0
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by ShAgY102 View Post
    Bump......
    have you checked your air intake ? change airfilter and make sure there is no vacume leak. If the car is also making issue on patrol, then make sure your IACV is clean and functioning.
    -

  8. #27
    PakWheeler Follow
    ShAgY102's Avatar
    Join Date
    Apr 2009
    Location
    Hyderabad
    Age
    21
    Posts
    571
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by itsgumbys View Post
    have you checked your air intake ? change airfilter and make sure there is no vacume leak. If the car is also making issue on patrol, then make sure your IACV is clean and functioning.
    dude air filter was changed 1000km ago and no problem on petrol.
    Trying to be superman !

  9. #28
    PakWheeler Follow
    itsgumbys's Avatar
    Join Date
    May 2007
    Location
    Islamabad
    Posts
    707
    Follows
    0
    Following
    0
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by ShAgY102 View Post
    dude air filter was changed 1000km ago and no problem on petrol.
    Have you tried replacing the lambda stepper motor with manual T ?
    -

  10. #29
    PakWheeler Follow
    ShAgY102's Avatar
    Join Date
    Apr 2009
    Location
    Hyderabad
    Age
    21
    Posts
    571
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default now this is what i got adviced!

    Quote Originally Posted by itsgumbys View Post
    Have you tried replacing the lambda stepper motor with manual T ?
    yeah i think i would try this xli.system right? clip and screw and sensor for manual. The mechanic says 4.5k for it what u say!!
    Trying to be superman !

  11. #30
    PakWheeler Follow
    itsgumbys's Avatar
    Join Date
    May 2007
    Location
    Islamabad
    Posts
    707
    Follows
    0
    Following
    0
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by ShAgY102 View Post
    yeah i think i would try this xli.system right? clip and screw and sensor for manual. The mechanic says 4.5k for it what u say!!
    i would suggest dont do any thing except replacing the stepper motor with manual T. this experiment should not cost you more then 200 rs and 15 mins.try it, it might work for you.
    -

  12. #31
    PakWheeler Follow
    ShAgY102's Avatar
    Join Date
    Apr 2009
    Location
    Hyderabad
    Age
    21
    Posts
    571
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by itsgumbys View Post
    i would suggest dont do any thing except replacing the stepper motor with manual T. this experiment should not cost you more then 200 rs and 15 mins.try it, it might work for you.
    ok i will try this. can u show some photo of manual t ?
    Trying to be superman !

  13. #32
    PakWheeler Follow
    itsgumbys's Avatar
    Join Date
    May 2007
    Location
    Islamabad
    Posts
    707
    Follows
    0
    Following
    0
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by ShAgY102 View Post
    ok i will try this. can u show some photo of manual t ?
    Just open the bonet of any CNG car, which doesnt have lambda installed, its just a nut through which you adjust the flow of CNG to carburator\ throttle body.
    -

  14. #33
    PakWheeler Follow
    ShAgY102's Avatar
    Join Date
    Apr 2009
    Location
    Hyderabad
    Age
    21
    Posts
    571
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by itsgumbys View Post
    Just open the bonet of any CNG car, which doesnt have lambda installed, its just a nut through which you adjust the flow of CNG to carburator\ throttle body.
    bhai cng wala is asking 500 for pakistani t.
    Trying to be superman !

  15. #34
    PakWheeler Follow
    itsgumbys's Avatar
    Join Date
    May 2007
    Location
    Islamabad
    Posts
    707
    Follows
    0
    Following
    0
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by ShAgY102 View Post
    bhai cng wala is asking 500 for pakistani t.
    thats too much..... he is insane.

    You can first try this out if it works then even 500 is worth spending.

    Explain this to your mechanic.
    -

  16. #35
    PakWheeler Follow
    ShAgY102's Avatar
    Join Date
    Apr 2009
    Location
    Hyderabad
    Age
    21
    Posts
    571
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    ohk i will check some others too but i hope it get fixed thanks sir jee for your kind response.
    Trying to be superman !

  17. #36
    Senior PakWheeler Follow
    roms's Avatar
    Join Date
    Feb 2011
    Age
    33
    Posts
    3,067
    Follows
    5
    Following
    2
    Mentioned
    103 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Bro it has nothing to with stepper motor and nor the manual T will cure it. If there was a problem with lambda then the car would have been OK on petrol.
    Check your plugs and plug wires, i am sure that the plug wires are the culprit and also check your emulator as well along with other sensors
    Solar Hunter armed with a whip and a leash

  18. #37
    PakWheeler Follow
    itsgumbys's Avatar
    Join Date
    May 2007
    Location
    Islamabad
    Posts
    707
    Follows
    0
    Following
    0
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by ShAgY102 View Post
    dude air filter was changed 1000km ago and no problem on petrol.

    Please read... he is having no issues on petrol.
    -

  19. #38
    PakWheeler Follow
    ShAgY102's Avatar
    Join Date
    Apr 2009
    Location
    Hyderabad
    Age
    21
    Posts
    571
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by roms View Post
    Bro it has nothing to with stepper motor and nor the manual T will cure it. If there was a problem with lambda then the car would have been OK on petrol.
    Check your plugs and plug wires, i am sure that the plug wires are the culprit and also check your emulator as well along with other sensors
    Roms bhai i have got them sensors lambda plugs and wires with coils emulators ac things and almost everything even i have my half engine open to check if it is problem of gasket but it was nothing. I checked with another lambda the car was perfect but my cng person say sir ye kharab hojayega Pakistani wala hi kerwao and I know he was right cause i have yet changed 3 lambda's since september :/ btw roms bhai thanks for your kind response.
    Trying to be superman !

  20. #39
    Senior PakWheeler Follow
    roms's Avatar
    Join Date
    Feb 2011
    Age
    33
    Posts
    3,067
    Follows
    5
    Following
    2
    Mentioned
    103 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by ShAgY102 View Post
    Roms bhai i have got them sensors lambda plugs and wires with coils emulators ac things and almost everything even i have my half engine open to check if it is problem of gasket but it was nothing. I checked with another lambda the car was perfect but my cng person say sir ye kharab hojayega Pakistani wala hi kerwao and I know he was right cause i have yet changed 3 lambda's since september :/ btw roms bhai thanks for your kind response.
    did u check the plug wires
    Solar Hunter armed with a whip and a leash

  21. #40
    Newbie Follow
    chnajamn's Avatar
    Join Date
    May 2012
    Location
    Lahore
    Posts
    1
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    aoa
    just read about your problem
    i have vxri 2009 model
    in last summer i suffered same issue

    they just reset your ecu by laptop which u can reset every time by unplug your battery terminals check your Radiator Fan is it on automatic mode as sometimes direct fan causes fluctuation in Rpms.
    also due to dust and hot environment the lambda isnt much successfull in pakistan so just remove it and go on option of 4.5k charges and spark plug cables change

    and never try to simply remove lambda with manual T as your MAF sensor will cause error and chk engine light will make things worst

    so Go to an expert car ecu/electrician mechanic
    as local mechanics arent good they creat mesh of wires and install seprate emulator too for extra charges but good electricians used car's original emulator which is built in in ecu of cultus

    then do the cng kit and cylinder service too

    after all these you will surly get 200km plus on non ac and 170km on ac in city on low rpms

    i am not a technical person but i learned it by experience and experiments too
    you can share your experience too i will polish my knowledge too

+ Reply to Thread
Page 2 of 3 FirstFirst 123 LastLast

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •