Survey by Qualaroo
+ Reply to Thread
Page 1 of 3 123 LastLast
Results 1 to 20 of 52
Like Tree5Likes

Thread: To All Experts: Cultus VXRI 2008 Overheating

  1. #1
    PakWheeler Follow
    Runtimeerror's Avatar
    Join Date
    Oct 2011
    Location
    Khanewal
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default To All Experts: Cultus VXRI 2008 Overheating

    I have Cultus VXRI 2008 with 32k Km Drive.
    now giving me very serious problem about over Heating temperature. I have already Replace its ECT sensor also try to remove the fault by as on manual book but fail. as i remove ECT cable connector radiator fan goes ON & AC stops work.
    Radiator +Radiator Fan, ECT sensor, cables, Relay checked and are OK but fault is still there.

    Kindly Help me to Solve my problem.


    Regards









    To All Experts  Cultus VXRI 2008 Over Heating -1196920
    Attached Images Attached Images   

  2. #2
    PakWheeler Follow
    mfarhansabir's Avatar
    Join Date
    Sep 2012
    Location
    Lahore
    Posts
    842
    Follows
    0
    Following
    0
    Mentioned
    11 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Have you considered checking head gasket?

    Is the radiator throwing water to the side bottle?

    Sent from my Nexus S using Tapatalk 2

  3. #3
    PakWheeler Follow
    Runtimeerror's Avatar
    Join Date
    Oct 2011
    Location
    Khanewal
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Yes, Gasket is OK, ECT cables, voltages are stable & OK, radiator throwing water side bottle.
    Thermostat gauge working fine,

  4. #4
    Senior PakWheeler Follow
    AkbarGr8's Avatar
    Join Date
    Oct 2004
    Location
    Karachi
    Age
    32
    Posts
    5,972
    Follows
    0
    Following
    0
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Tried replacing the coolant?

  5. #5
    PakWheeler Follow
    Runtimeerror's Avatar
    Join Date
    Oct 2011
    Location
    Khanewal
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    yes after replacing the Coolant still faulty.

  6. #6
    PakWheeler Follow
    FederalAgent's Avatar
    Join Date
    Jun 2009
    Location
    Islamabad
    Age
    36
    Posts
    505
    Follows
    0
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Thermostat valve might be stuck. get it check too.

    it happened with me once on my 2008 cultus
    Failing to prepare is preparing to fail.

  7. #7
    PakWheeler Follow
    Runtimeerror's Avatar
    Join Date
    Oct 2011
    Location
    Khanewal
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I think ECT sensor should work if thermostat valve stuck. am i right?

  8. #8
    PakWheeler Follow
    Runtimeerror's Avatar
    Join Date
    Oct 2011
    Location
    Khanewal
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Where are All Experts?

  9. #9
    Senior PakWheeler Follow
    levin's Avatar
    Join Date
    Oct 2005
    Location
    Select City
    Age
    51
    Posts
    23,112
    Follows
    5
    Following
    0
    Mentioned
    95 Post(s)
    Tagged
    6 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    you don't need everybody for a cultus. one person is enough
    ,,, unless you know the track, you're not good enough to sit behind the wheel." K T

  10. #10
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,402
    Follows
    131
    Following
    0
    Mentioned
    3989 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    By your post - it sounds like the radiator fan never switches on and the engine proceeds to overheat. The only test is to remove the connector and the fan should kick on verifying the wiring and relay are good.

    If you are seeing high pressure coolant eject into the expansion bottle from the radiator cap then you have a combustion leak into the coolant - this is a headgasket failure

    However it may also be due to air trapped in the system, try bleeding it with the heater on full. Before anything i would suggest you check the integrity of the radiator cap seals.
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  11. #11
    Senior PakWheeler Follow
    Newton's Avatar
    Join Date
    Mar 2006
    Age
    35
    Posts
    1,872
    Follows
    0
    Following
    0
    Mentioned
    29 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Xulfiqar View Post
    By your post - it sounds like the radiator fan never switches on and the engine proceeds to overheat. The only test is to remove the connector and the fan should kick on verifying the wiring and relay are good.

    If you are seeing high pressure coolant eject into the expansion bottle from the radiator cap then you have a combustion leak into the coolant - this is a headgasket failure

    However it may also be due to air trapped in the system, try bleeding it with the heater on full. Before anything i would suggest you check the integrity of the radiator cap seals.
    Bro I need advice

    I wanted to ask what is the life of denso iridium tip plugs, I have em installed in my 1.3 corolla they are about 35000 kms used and while checking them today I was told by the mechanic they are worn out where as I read on Denso site they last for 1 lac miles which is 160000 kms, I asked him to bring new ones after closely inspecting both new and used plugs what I could feel was the tip of my plug had shrunk, can u guide me please.

    My car was fluctuating rpm in idle and loss of pickup which was cured by throttle body cleaning.

    Sent from my GT-I9300 using Tapatalk 2

  12. #12
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,402
    Follows
    131
    Following
    0
    Mentioned
    3989 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    the precious metal spark plugs are good for atleast 100,000 kms easily. Dont worry about it.
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  13. #13
    PakWheeler Follow
    israrahmedd's Avatar
    Join Date
    Apr 2013
    Posts
    132
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Runtimeerror View Post
    I think ECT sensor should work if thermostat valve stuck. am i right?
    When you start your car check its hosepipes after minute.. one hose pipe will be hot and one wont be hot.. then rev ur engine untill it reaches middle then check now both hosepipes should have to be hot
    otherwise they would mean thermostate valve is stuck

    is it decrease water? did it start heating when u rev it in parking? or just heat up when driving?
    heat up after how many km?

  14. #14
    PakWheeler Follow
    Runtimeerror's Avatar
    Join Date
    Oct 2011
    Location
    Khanewal
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i have follow ur instructions as u write & check all things, All is OK.

  15. #15
    PakWheeler Follow
    Runtimeerror's Avatar
    Join Date
    Oct 2011
    Location
    Khanewal
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Waiting : Fault Is Still

  16. #16
    PakWheeler Follow
    fayzan's Avatar
    Join Date
    Jun 2008
    Location
    Lahore
    Age
    27
    Posts
    5
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    get cleaned your radiator from the radiator shop and then kick out tha thermostate valve which is between radiator pipe nad engine.

  17. #17
    PakWheeler Follow
    fayzan's Avatar
    Join Date
    Jun 2008
    Location
    Lahore
    Age
    27
    Posts
    5
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i was also having the same problem i have also changed my radiator fan but the fault was there than i do these steps now i am my car is fine.

  18. #18
    PakWheeler Follow
    Runtimeerror's Avatar
    Join Date
    Oct 2011
    Location
    Khanewal
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I have Tried to solve this fault as asking all friends. After all checking witch i under stand radiator fan & its system is working fine but as i Switch ON the AC , After 5-10 mints Engine gone Heat up & AC stops work, Radiator Fan also Stop Work.
    As i Switch OFF AC, Radiator Fan worked fine on Automatic mode after 5-10 mints.
    (After Heat up Some time radiator fan run fine some time like dead )

    Help Yaar

  19. #19
    PakWheeler Follow
    NakedTruth's Avatar
    Join Date
    Nov 2011
    Location
    Lahore
    Age
    69
    Posts
    620
    Follows
    0
    Following
    0
    Mentioned
    28 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    You need to replace the radiator. That is the only solution.

    Get it cleaned. If that doesn't work, get a new one.

    The problem you are facing is the one I faced in my Cultus too, albeit a 2005 model.

  20. #20
    Senior PakWheeler Follow
    SER_GTR's Avatar
    Join Date
    Nov 2005
    Location
    Karachi
    Age
    30
    Posts
    9,737
    Follows
    16
    Following
    0
    Mentioned
    489 Post(s)
    Tagged
    19 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    3

    Default

    Possible Checkups

    Radiator Cap.....(Yea They Can Mess And Let You BURN In heat)

    Auto Fan Switching Issue (Check System Integrity By COnnecting And Disconnecting The Switch And Check By Triggering Them While Car is parked) As You Said You Do Check It Means Its Working Fine...

    Air Trapped.....Sometimes Air Trapped In System Due To Low Coolant Or Any Other Reason Can Make Car Overheat.......Make Sure There's No Air Trapped.....Bleed It....Should Have Bleeder Nut On Water Flange Side...

    Gasket Issue.....For 32k Km......If You Didn't Overheat it before......Or You Are Not Unlucky...Chances Are Its Fine......Its The last Thing To Go......

    Blockage In Coolant System...Possible Chances Are Coolant Is Not Flowing In System Correctly Causing The issue.......Can Be Radiator As Well....If Something Real Bad Is Deposited Inside Causing A Blockage..... Check With Thermostat Also And Make Sure Its Opening On Operating Temp


    Mostly Its Something In These Issue.....Since Car Is Not So Much On Miles...I Suggest To Stick To Small Things Which Can Solve Your Issue....!

    After How Long It Gets Heatup...And How Much Temp Raises.......??
    TOYOTA Sprinter 86- AE80 DOHC 20v'D TOYOTA Corolla 98- AE101 4AFE 16v

+ Reply to Thread
Page 1 of 3 123 LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •