Survey by Qualaroo
+ Reply to Thread
Results 1 to 16 of 16
Like Tree5Likes
  • 1 Post By ghaurisk
  • 1 Post By khasscorpio
  • 1 Post By khasscorpio
  • 1 Post By mag88
  • 1 Post By majidmalik1

Thread: Car overheating Cultus VXR 2006

  1. #1
    PakWheeler Follow
    khasscorpio's Avatar
    Join Date
    Nov 2010
    Location
    Karachi
    Posts
    65
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Car overheating Cultus VXR 2006

    My cultus 06 overheating even i poured coolant in it. after driving for 15 km a smoke started from the engine even though the temp needle didnt go up to indicate overheating. water reserved bottle had adequate water and coolant but the radiator was empty. This happened twice. I have already changed the oil recently. what to do? I poured the coolant after removing all the water from radiator by opening its lower valve and it came out clean. please guide me.
    :after heating up and cooling it for a while when i poured water in radiator with engine start it was throwing water (Burping, not a stable level). Please note it seems its not taking water from the bottle.

    edited: Noted air bubble appearing in radiator while engine on start. is it a gasket blown??


  2. #2
    PakWheeler Follow
    mag88's Avatar
    Join Date
    Jun 2008
    Location
    Karachi
    Age
    36
    Posts
    166
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Pressure test ur cooling line with 1BAR(20 PSI) air pressure find and fix the leak.

  3. #3
    PakWheeler Follow
    ghaurisk's Avatar
    Join Date
    Sep 2005
    Location
    Karachi
    Age
    31
    Posts
    20
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    I had the same problem with my cultus , gasket seems to blown another way to check is that check the viscosity of the oil If gasket is blown you will see that a bit of water is there ij the oil


    Sent from my iPhone using PW Forums mobile app

  4. #4
    PakWheeler Follow
    ghaurisk's Avatar
    Join Date
    Sep 2005
    Location
    Karachi
    Age
    31
    Posts
    20
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Get it checked ASAP i lingered on this problem and ultimately i had to redo my head


    Sent from my iPhone using PW Forums mobile app

  5. #5
    PakWheeler Follow
    khasscorpio's Avatar
    Join Date
    Nov 2010
    Location
    Karachi
    Posts
    65
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    It was gasket blown away. My mechanic swapped the gasket. In addition my radiator was seriously rusty so i changed it with "allwin" new radiator. Hope it works good now.

    Sent from my HUAWEI (U8833) Y300-100 [ROM] CynogenMod (CM)-10.2 (JB 4.3)using Tapatalk

  6. #6
    PakWheeler Follow
    shah96's Avatar
    Join Date
    Apr 2013
    Location
    Rawalpindi
    Age
    20
    Posts
    200
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    looks like gasket blown with radiator blockage problem

  7. #7
    Senior PakWheeler Follow
    omarabdullah022's Avatar
    Join Date
    Oct 2012
    Location
    Karachi
    Posts
    2,641
    Follows
    1
    Following
    1
    Mentioned
    96 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by khasscorpio View Post
    It was gasket blown away. My mechanic swapped the gasket. In addition my radiator was seriously rusty so i changed it with "allwin" new radiator. Hope it works good now.

    Sent from my HUAWEI (U8833) Y300-100 [ROM] CynogenMod (CM)-10.2 (JB 4.3)using Tapatalk
    PM me the price for the radiator.

  8. #8
    PakWheeler Follow
    khasscorpio's Avatar
    Join Date
    Nov 2010
    Location
    Karachi
    Posts
    65
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    PM sent.

    Sent from my HUAWEI (U8833) Y300-100 [ROM] CynogenMod (CM)-10.2 (JB 4.3)using Tapatalk

  9. #9
    PakWheeler Follow
    mag88's Avatar
    Join Date
    Jun 2008
    Location
    Karachi
    Age
    36
    Posts
    166
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by khasscorpio View Post
    It was gasket blown away. My mechanic swapped the gasket. In addition my radiator was seriously rusty so i changed it with "allwin" new radiator. Hope it works good now.

    Sent from my HUAWEI (U8833) Y300-100 [ROM] CynogenMod (CM)-10.2 (JB 4.3)using Tapatalk
    I suggest to do a leak test after repair else it will blow the gasket again in an year or 2(20 K Run).
    PS:I learned this the hard way. After test use good coolant, make sure the fan is auto and New Tstat installed.

  10. #10
    PakWheeler Follow
    zahidbahi's Avatar
    Join Date
    Sep 2013
    Posts
    104
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by mag88 View Post
    I suggest to do a leak test after repair else it will blow the gasket again in an year or 2(20 K Run).
    PS:I learned this the hard way. After test use good coolant, make sure the fan is auto and New Tstat installed.
    dear from leak test you mean leakage of water from cooling system.
    and how does it effects gasket

  11. #11
    PakWheeler Follow
    mag88's Avatar
    Join Date
    Jun 2008
    Location
    Karachi
    Age
    36
    Posts
    166
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by zahidbahi View Post
    dear from leak test you mean leakage of water from cooling system.
    and how does it effects gasket
    If there is any leak, even a pin point invisible hole from where hot coolant evaporates with out dripping, then the air is suck in to the coolant and hence it boils creating extensive pressure and eventually causing a leak, corrode water body blades and head edges which causes less flow of water and hence heat spots at the Head and gasket causing it to fail. Do this leak test to save your car become a frequent visitor to the road side mechanic who either don't know the consequences or do it on purpose so that you become his permanent customer every 3-4 months.

    Simply use a Tyre valve weld on an old radiator cap/ or installed on some nipple to make the test. Pressure MAX 1 BAR . leave it for an hour if P drops find the leak. Once fixed fill coolant and then install Tstat.

  12. #12
    PakWheeler Follow
    zahidbahi's Avatar
    Join Date
    Sep 2013
    Posts
    104
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by mag88 View Post
    If there is any leak, even a pin point invisible hole from where hot coolant evaporates with out dripping, then the air is suck in to the coolant and hence it boils creating extensive pressure and eventually causing a leak, corrode water body blades and head edges which causes less flow of water and hence heat spots at the Head and gasket causing it to fail. Do this leak test to save your car become a frequent visitor to the road side mechanic who either don't know the consequences or do it on purpose so that you become his permanent customer every 3-4 months.

    Simply use a Tyre valve weld on an old radiator cap/ or installed on some nipple to make the test. Pressure MAX 1 BAR . leave it for an hour if P drops find the leak. Once fixed fill coolant and then install Tstat.
    very well explained.thanks brother.

  13. #13
    PakWheeler Follow
    zahidbahi's Avatar
    Join Date
    Sep 2013
    Posts
    104
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by mag88 View Post
    If there is any leak, even a pin point invisible hole from where hot coolant evaporates with out dripping, then the air is suck in to the coolant and hence it boils creating extensive pressure and eventually causing a leak, corrode water body blades and head edges which causes less flow of water and hence heat spots at the Head and gasket causing it to fail. Do this leak test to save your car become a frequent visitor to the road side mechanic who either don't know the consequences or do it on purpose so that you become his permanent customer every 3-4 months.

    Simply use a Tyre valve weld on an old radiator cap/ or installed on some nipple to make the test. Pressure MAX 1 BAR . leave it for an hour if P drops find the leak. Once fixed fill coolant and then install Tstat.
    very well explained.thanks brother.

  14. #14
    PakWheeler Follow
    majidmalik1's Avatar
    Join Date
    Oct 2011
    Location
    Lahore
    Posts
    25
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i am owner of cultus vxli 2010. i was facing heatup engine problem in 2011 and 2012 in summer. i visit suzuki township motors suzuki sethi motors suzuki cantt motor and suzuki adil zafar motor in lahore for this problem and every visit i pay 5000 rupees for different parts and service. almost i pay 30,000 rupees. but every one say me that"abb car heatup nai ho gi" issue was "car work well with A/C in city but heatup on long way " what the car mechanic did. (radiator service,radiator cap change, water pump fan chang, coolent change, radiator fan direct,engine gas kit change,AC service,AC gas fill,) but the problem was not solved.and they said that sold the car. i love my car and did not want to sale. finally i change the radiator form a machine suggestion. i buy allwin radiator in 5800.and put it in my cultus. next day 27 june i visit lahore to multan on high way day time. it was hot day. i drive car at 100 k/m speed and A/c on. the car engine was cool. after 2 day 30 june i visit lahore to islamabad via motorway. and speed was 100+ and engine was cool. i was happy that i solved my problem. my car problem was radiator nali was closed and did not crossing water in these nali. if the car do not loss the water level in radiator and the radiator fan is direct working and you car heatup then it is radiator nali problem. if car loss water level then its radiator leak problem.

  15. #15
    PakWheeler Follow
    baowaqas's Avatar
    Join Date
    Oct 2013
    Location
    Islamabad
    Age
    31
    Posts
    18
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Thanks brother seems quite relevant.

  16. #16
    PakWheeler Follow
    faisal-01's Avatar
    Join Date
    Mar 2016
    Location
    N/A
    Posts
    22
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    perfect bro

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •