Survey by Qualaroo
+ Reply to Thread
Page 4 of 4 FirstFirst ... 234
Results 61 to 64 of 64
Like Tree9Likes

Thread: Cultus EFi Check Engine Light

  1. #1
    Senior PakWheeler Follow
    umarkhan1's Avatar
    Join Date
    Nov 2010
    Location
    Sargodha
    Posts
    2,310
    Follows
    6
    Following
    8
    Mentioned
    51 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    2

    Default Cultus EFi Check Engine Light

    Salam!
    My 2010 cultus efi is showing check engine light on at wide open throttle(WOT) and goes off when i release the throttle.it is happening after i had changed the gear oil and cleaned air filter.i have also reset the ecu but its still showing.. @SER_GTR and @Xulfiqar i shall be greatful to you if you help me...

    Just Do It Your Self!!!!!

  2. #61
    Senior PakWheeler Follow
    umarkhan1's Avatar
    Join Date
    Nov 2010
    Location
    Sargodha
    Posts
    2,310
    Follows
    6
    Following
    8
    Mentioned
    51 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    2

    Default

    Quote Originally Posted by Xulfiqar View Post
    so you mean to say that.

    you can hold the throttle at 80% and have no check light and as soon as you boot it to the floor you get a check light? and it shows IAT code?

    That is one crazy ECU
    and after full warm up
    Just Do It Your Self!!!!!

  3. #62
    Senior PakWheeler Follow
    rustam54's Avatar
    Join Date
    Aug 2006
    Location
    Lahore
    Posts
    1,004
    Follows
    1
    Following
    0
    Mentioned
    113 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    First off, what is status of troubleshooting??

    If still not resolved, did you try taking it for a scan (on the go) and note down the Freeze Frame Data??

    I dont know if the scanner used to pull Suzuki's code supports or not, but it would be a good idea to PLOT the IAT over the range of engine load and share the results (Preferable in the form of a snapshot) online.

  4. #63
    Senior PakWheeler Follow
    umarkhan1's Avatar
    Join Date
    Nov 2010
    Location
    Sargodha
    Posts
    2,310
    Follows
    6
    Following
    8
    Mentioned
    51 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    2

    Default

    Quote Originally Posted by rustam54 View Post
    First off, what is status of troubleshooting??

    If still not resolved, did you try taking it for a scan (on the go) and note down the Freeze Frame Data??

    I dont know if the scanner used to pull Suzuki's code supports or not, but it would be a good idea to PLOT the IAT over the range of engine load and share the results (Preferable in the form of a snapshot) online.
    i was about to text you.problem solved by my self.
    the problem was too loose tension of the terminals of iat sensor.replaced the grip and....
    now its rocking shukar alhamulillah
    Just Do It Your Self!!!!!

  5. #64
    Senior PakWheeler Follow
    SER_GTR's Avatar
    Join Date
    Nov 2005
    Location
    Karachi
    Age
    30
    Posts
    9,737
    Follows
    16
    Following
    0
    Mentioned
    489 Post(s)
    Tagged
    19 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    3

    Default

    This Is Why We Told To Check Voltages Physically....
    TOYOTA Sprinter 86- AE80 DOHC 20v'D TOYOTA Corolla 98- AE101 4AFE 16v

+ Reply to Thread
Page 4 of 4 FirstFirst ... 234

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •