Survey by Qualaroo
+ Reply to Thread
Page 2 of 2 FirstFirst 12
Results 21 to 21 of 21
Like Tree5Likes

Thread: Cultus EFI 07 A/C issue

  1. #1
    PakWheeler Follow
    green3003's Avatar
    Join Date
    Jun 2012
    Location
    Nowshera
    Posts
    35
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Cultus EFI 07 A/C issue

    Salam,

    My cultus EFI 07 A/C was good now after summer when i switch on button power up and A/C fan also starts but There is no cooling. Also before A/C working i always feel engine sound changes but now just fan is on no load on Engine i feel like only fan is running ................. after few days i start A/C and it start working like before but some time it work and some time it doesnt .......... what could be my problem pls tell freinds any idea


  2. #21
    PakWheeler Follow
    waqas3003's Avatar
    Join Date
    Dec 2013
    Location
    Nowshera
    Age
    36
    Posts
    94
    Follows
    1
    Following
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by suzukialtomehran View Post
    happy to hear you figured out malfunctioning part and sorted out., for the low blower throw i would suggest you to get it cleaned by any good electrician and make sure your ac is on recycling all the time, it will help reduce getting the dirty air into the blower and stop getting the freezer choke.
    Thanks yar actually as its working fine nw and A/C is chilled so i leave that for next season so far im happy with it

+ Reply to Thread
Page 2 of 2 FirstFirst 12

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •