Survey by Qualaroo
+ Reply to Thread
Results 1 to 6 of 6

Thread: Cultus back firing on petrol

  1. #1
    PakWheeler Follow
    bulldog1993's Avatar
    Join Date
    Nov 2010
    Location
    Lahore
    Age
    23
    Posts
    73
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Cultus back firing on petrol

    Dear friends
    I have a carby cultus 2003. Recently i got its engine overhauled at about 250k since then the engine backfires (thats what the mechanic says) when i switch off the car it keeps something creepy like trying to come back to life and its driving me crazy. A couple of visits to the mechanic but he allways blames it on my driving style that i shut off engine at high RPM but it happens also on low RPM.
    Ps. The car is also knocking on pickups and has a vey rough feeling please help


  2. #2
    PakWheeler Follow
    bulldog1993's Avatar
    Join Date
    Nov 2010
    Location
    Lahore
    Age
    23
    Posts
    73
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    seriously people no reply ?

  3. #3
    Senior PakWheeler Follow
    syncview's Avatar
    Join Date
    Apr 2006
    Location
    Lahore
    Age
    28
    Posts
    3,364
    Follows
    7
    Following
    1
    Mentioned
    436 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Check the idle solenoid on the carburetor

    Sent from my VS980 4G using Tapatalk
    https://www.facebook.com/OsamaAbbasPhotography

  4. #4
    PakWheeler Follow
    bulldog1993's Avatar
    Join Date
    Nov 2010
    Location
    Lahore
    Age
    23
    Posts
    73
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Thankyou @syncview i did some research on idle solenoid seems like its the issue will ask the mechanic to check it

  5. #5
    Senior PakWheeler Follow
    syncview's Avatar
    Join Date
    Apr 2006
    Location
    Lahore
    Age
    28
    Posts
    3,364
    Follows
    7
    Following
    1
    Mentioned
    436 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Great job
    Update us on how it goes

    Sent from my VS980 4G using Tapatalk
    https://www.facebook.com/OsamaAbbasPhotography

  6. #6
    PakWheeler Follow
    bulldog1993's Avatar
    Join Date
    Nov 2010
    Location
    Lahore
    Age
    23
    Posts
    73
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Sorry for such late response
    I took it to the mechanic he opened the solenoid which was cut and actually very recently bcs the cut area was golden instead of blackish. The mechanic said it did not matter so i took the matter in my own hands. Went to a friend whoos unke had a shop in bilal ganj and got the solenoid for free. Fitted it and since then no problem

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •