Survey by Qualaroo
+ Reply to Thread
Results 1 to 11 of 11

Thread: Strange Horn Issue

  1. #1
    PakWheeler Follow
    atifnaeemmalik's Avatar
    Join Date
    Jun 2010
    Location
    Islamabad
    Posts
    98
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Exclamation Strange Horn Issue

    I am having cultus 2003 and experiencing strange horn issue. when car's temperature doesn't reach to optimal temperature, the horn is working but as soon as heat needle rises towards normal temperature, horn stops working.

    I am having a manual switch to radiator fan and when I turn the fan and temperature decreases, horn starts working.


  2. #2
    PakWheeler Follow
    drag80's Avatar
    Join Date
    Feb 2015
    Posts
    61
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by atifnaeemmalik View Post
    I am having cultus 2003 and experiencing strange horn issue. when car's temperature doesn't reach to optimal temperature, the horn is working but as soon as heat needle rises towards normal temperature, horn stops working.

    I am having a manual switch to radiator fan and when I turn the fan and temperature decreases, horn starts working.
    change the horn

  3. #3
    PakWheeler Follow
    atifnaeemmalik's Avatar
    Join Date
    Jun 2010
    Location
    Islamabad
    Posts
    98
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I have installed 2 horns just to make sure. Both horns stop working and no clicking sound is generated in relay.

  4. #4
    Senior PakWheeler Follow
    Fahad.Ayub's Avatar
    Join Date
    Aug 2013
    Location
    Karachi
    Age
    21
    Posts
    1,958
    Follows
    3
    Following
    2
    Mentioned
    32 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    2
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    2

    Default

    So you turn the radiator fan on by yourself ?



    Sent from my iPhone using PW Forums

  5. #5
    PakWheeler Follow
    atifnaeemmalik's Avatar
    Join Date
    Jun 2010
    Location
    Islamabad
    Posts
    98
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Yes I have installed a knob. Pulling it turns on the fan and other state is auto

  6. #6
    Senior PakWheeler Follow
    metalhead's Avatar
    Join Date
    Oct 2006
    Location
    Wah cantt
    Posts
    1,302
    Follows
    1
    Following
    1
    Mentioned
    49 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Did it happened after horn installation?

  7. #7
    PakWheeler Follow
    atifnaeemmalik's Avatar
    Join Date
    Jun 2010
    Location
    Islamabad
    Posts
    98
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I installed 2 horns because I was in doubt that maybe it's the horn issue but the scenario is same. Both start and stop sounding depending upon car's temperature.

  8. #8
    Senior PakWheeler Follow
    metalhead's Avatar
    Join Date
    Oct 2006
    Location
    Wah cantt
    Posts
    1,302
    Follows
    1
    Following
    1
    Mentioned
    49 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Better check your wiring.

  9. #9
    Senior PakWheeler Follow
    Tabish1's Avatar
    Join Date
    Feb 2007
    Location
    Karachi
    Posts
    3,068
    Follows
    1
    Following
    0
    Mentioned
    24 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    2
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    0

    Default

    worst system ieve ever seen.. please install automatic switch for fan or make it direct..
    Pakistan <3

  10. #10
    PakWheeler Follow
    atifnaeemmalik's Avatar
    Join Date
    Jun 2010
    Location
    Islamabad
    Posts
    98
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Tabish1 View Post
    worst system ieve ever seen.. please install automatic switch for fan or make it direct..
    Thanks for your "VALUEABE" comment. I have no issue with the switch that I have installed. I use it rarely when stuck in traffic for long times with AC on "just for precaution" otherwise system runs automatic.

  11. #11
    PakWheeler Follow
    smokin's Avatar
    Join Date
    Mar 2008
    Location
    Muzaffargarh
    Age
    27
    Posts
    386
    Follows
    0
    Following
    0
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    U need a cutout as per your information originally it comes with one horn u installed 2 need more current
    When your cars radiator fan is on it consume more current and doesn't give proper current to horn resulting no horn sound
    As u said when the car cools down the radiator fan turns off the required current then goes to u horn and it honks

    You solution is a cutout which gives extra current to horn and let it work properly

    If u have already installed cutout then it might b faulty change it this might solve your problem


    Sent from my iPhone using PW Forums

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •