Survey by Qualaroo
+ Reply to Thread
Results 1 to 5 of 5

Thread: Engine Knocking Sound when I accelerate Car at Low Speed

  1. #1
    Newbie Follow
    nadeem20154's Avatar
    Join Date
    Jul 2015
    Location
    Rawalpindi
    Posts
    1
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Question Engine Knocking Sound when I accelerate Car at Low Speed

    Asslam O Alaekum Bros,

    I have a Cultus EFI Engine 2007 model. The Issue is that knocking kind of noises are heard from Engine when i accelerate car. Though i try to drive maintaining R.P.M of 3 to 3.2.
    The noises vanished as Car attains the speed proportionate to its R.P.M. Issue has also been noticed when i use to drive on some steep roads or in hilly section of motorway/GT Road.
    It is usually observed when Car engine Temperature needle reaches in Mid of Temperature gauge.

    Need your suggestions in this regards,

    JazakAllah!


  2. #2
    PakWheeler Follow
    addytov1's Avatar
    Join Date
    Mar 2016
    Posts
    42
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    hi,
    i had similar problem in my new cultus 2015, had to go to suzuki dealer, but before that i recognized that once used with high octane, there was no issues with knocking, now i drive mine with it, simple smooth even no knocking in 3rd gear,
    i would suggest to use hi octane and see the difference, if prob persists go to dealer and have check

  3. #3
    Senior PakWheeler Follow
    saboor73's Avatar
    Join Date
    Oct 2013
    Location
    Karachi
    Posts
    10,553
    Follows
    25
    Following
    0
    Mentioned
    351 Post(s)
    Tagged
    14 Thread(s)
    Problems Posted
    0
    Problems Solved
    6
    Best Answers
    2
    Good Answers
    25

    Default

    Get distributor adjusted you might be running too advance

  4. #4
    Senior PakWheeler Follow
    KeiWorks12's Avatar
    Join Date
    Mar 2012
    Location
    Karachi
    Posts
    1,298
    Follows
    13
    Following
    0
    Mentioned
    94 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    1
    Good Answers
    1

    Default

    Start using high octane...happened with me once..sound is like something is loose in engine and pinging when accelerating. Problem vanished when started using high octane. Response is even better now

  5. #5
    PakWheeler Follow
    Superiority's Avatar
    Join Date
    Aug 2006
    Location
    Lahore
    Age
    28
    Posts
    4
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    اپنی سوزوکی کلٹس کی پہلے ٹیونگ کروائیے جس میں ٹیپٹ لازمی چیک کروائیے۔ ٹیونگ کے بعد ہائی آکٹین ڈلوا کر کچھ دن گاڑی چلائیے۔ انشاء اللہ مسئلہ حل ہو جائے گا۔

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •