Survey by Qualaroo
+ Reply to Thread
Results 1 to 14 of 14
Like Tree1Likes
  • 1 Post By moiz2050

Thread: Continuous electric issues in Cultus 2007

  1. #1
    PakWheeler Follow
    moiz2050's Avatar
    Join Date
    May 2016
    Posts
    15
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Post Continuous electric issues in Cultus 2007

    Hi guys

    i have cultus 2007 from sometime i am facing continuous electric issues, i recently replaced my battery also.. issues like dashboard lights turned off, reverse switch problems, tape goes short. one electrician told me that change you fuse box (inside). is it good what you recommend to do?

    also i need to ask i am continuously seeing a red battery sign and another sign below rpm meter. these only show when i just on switch , when i turned on ignition they got disappeared
    what is that mean?
    Continuous electric issues in Cultus 2007 -1720667

    i recently changed my battery..
    please guide me what to do


  2. #2
    Newbie Follow
    farjeelsiddiqui's Avatar
    Join Date
    Sep 2016
    Posts
    1
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    Get you Alternator Checked. For the Battery Sign

    Get your Oil pressure sensor checked for the Engine Oil Sign

  3. #3
    Senior PakWheeler Follow
    abid110's Avatar
    Join Date
    Jan 2014
    Location
    Karachi
    Posts
    3,890
    Follows
    4
    Following
    0
    Mentioned
    90 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    1
    Problems Solved
    3
    Best Answers
    0
    Good Answers
    2

    Default

    alternator issue as battery is not getting charged as shown by constant battery light in ON state...

  4. #4
    Senior PakWheeler Follow
    rozzzzz's Avatar
    Join Date
    Oct 2005
    Location
    Islamabad
    Posts
    21,924
    Follows
    12
    Following
    0
    Mentioned
    140 Post(s)
    Tagged
    5 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    2

    Default

    check alternator charging .....
    MOTOR MANIACS ... An automotive service and repair workshop
    https://www.facebook.com/pages/Motor-Maniacs/721830141231922

  5. #5
    PakWheeler Follow
    moiz2050's Avatar
    Join Date
    May 2016
    Posts
    15
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    Quote Originally Posted by abid110 View Post
    alternator issue as battery is not getting charged as shown by constant battery light in ON state...
    well its not constant , when i start my ignition both got disappeared, these only show when i just on the switch.

  6. #6
    PakWheeler Follow
    moiz2050's Avatar
    Join Date
    May 2016
    Posts
    15
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    Quote Originally Posted by rozzzzz View Post
    check alternator charging .....
    can you tell me what are the actual readings of a good alternator?

  7. #7
    PakWheeler Follow
    moiz2050's Avatar
    Join Date
    May 2016
    Posts
    15
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    Quote Originally Posted by farjeelsiddiqui View Post
    Get you Alternator Checked. For the Battery Sign

    Get your Oil pressure sensor checked for the Engine Oil Sign
    Thanks man, But they got disappeared when i turned on the engine. any idea why?

  8. #8
    Senior PakWheeler Follow
    harib4u's Avatar
    Join Date
    Dec 2013
    Location
    Islamabad
    Posts
    3,436
    Follows
    6
    Following
    0
    Mentioned
    113 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    1

    Default

    Quote Originally Posted by moiz2050 View Post
    can you tell me what are the actual readings of a good alternator?
    Quote Originally Posted by moiz2050 View Post
    Thanks man, But they got disappeared when i turned on the engine. any idea why?
    its normal.

  9. #9
    PakWheeler Follow
    moiz2050's Avatar
    Join Date
    May 2016
    Posts
    15
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    Quote Originally Posted by harib4u View Post
    its normal.
    its normal?? you mean like i didnt have to check my alternator?

  10. #10
    PakWheeler Follow
    ch.talal's Avatar
    Join Date
    Mar 2014
    Location
    Lahore
    Posts
    662
    Follows
    0
    Following
    0
    Mentioned
    19 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    2

    Default

    Quote Originally Posted by moiz2050 View Post
    its normal?? you mean like i didnt have to check my alternator?
    No you don't. These lights turn on in most cars when you put key in ignition and turn it to ON mode.

    Besides check engine light is not lighting up. Check the wiring and meter. May be the bulb is fused.

    Better change the fuse box as it could be the culprit. Make sure no wires are shorted as some stupid electrician may have done some wrong wiring which is causing the problem.

  11. #11
    Senior PakWheeler Follow
    harib4u's Avatar
    Join Date
    Dec 2013
    Location
    Islamabad
    Posts
    3,436
    Follows
    6
    Following
    0
    Mentioned
    113 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    1

    Default

    Quote Originally Posted by moiz2050 View Post
    its normal?? you mean like i didnt have to check my alternator?
    yes its normal, there is no fault in your car.

  12. #12
    PakWheeler Follow
    kazims110's Avatar
    Join Date
    Sep 2016
    Location
    Karachi
    Posts
    95
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    2008 efi
    same problem with me ,
    but i asked mechanic he said ye switch pe show hoti hen lights but start pe off hojati hen
    agar start engine pe show hon tau problem he.

    other wise its ok
    Quote Originally Posted by moiz2050 View Post
    well its not constant , when i start my ignition both got disappeared, these only show when i just on the switch.

  13. #13
    Senior PakWheeler Follow
    tintin1's Avatar
    Join Date
    Jan 2014
    Location
    Lahore
    Posts
    1,829
    Follows
    7
    Following
    2
    Mentioned
    61 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    7
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    5

    Default

    Quote Originally Posted by moiz2050 View Post
    its normal?? you mean like i didnt have to check my alternator?
    Which city you are from ?
    Be Addicted To Help Others.

  14. #14
    PakWheeler Follow
    moiz2050's Avatar
    Join Date
    May 2016
    Posts
    15
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    Quote Originally Posted by tintin1 View Post
    Which city you are from ?
    Karachi

+ Reply to Thread

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •