Survey by Qualaroo
+ Reply to Thread
Results 1 to 15 of 15

Thread: low rpm shutdown problem in cultus efi

  1. #1
    PakWheeler Follow
    kashifsohail's Avatar
    Join Date
    Sep 2007
    Location
    Islamabad
    Age
    41
    Posts
    18
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default low rpm shutdown problem in cultus efi

    Dear I have bought new cultus vxli with factory fitted cng but my car shutdown mostly in low rpm in cng. Suzuki dealer said that its manufacturing fault. so anybody experienced it if so any solution.

    Thanks

  2. #2
    PakWheeler Follow
    rao_hims1's Avatar
    Join Date
    Jul 2007
    Location
    Karachi
    Age
    35
    Posts
    473
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    o yar thts ********. these suzuki dealers are into a habit of bullshitting most of the time. just go to a cng mechanic and get the idle setting readjusted, thts it.

  3. #3
    Senior PakWheeler Follow
    Vajih102's Avatar
    Join Date
    Oct 2004
    Location
    Islamabad
    Age
    32
    Posts
    14,339
    Follows
    4
    Following
    0
    Mentioned
    391 Post(s)
    Tagged
    10 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    exactly. mohsin's city was also doing this and the mechanic simply did some touching and we were free in less than ten minutes.

  4. #4
    PakWheeler Follow
    kashifsohail's Avatar
    Join Date
    Sep 2007
    Location
    Islamabad
    Age
    41
    Posts
    18
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    well, i understand but dealer (azeem motors) here in Islamabad is insisting that its universal problem with this model i.e. cultus efi and they have numbers of person reporting the same.

    Anyway address of any good cng mechanic here in Islamabad.

    Thanks

  5. #5
    PakWheeler Follow
    rao_hims1's Avatar
    Join Date
    Jul 2007
    Location
    Karachi
    Age
    35
    Posts
    473
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    kashif bro
    through my experiance,i can very safely say tht pak suzuki is least bothered about customer services. here, the product already reaches the market and they dont bother to train their technicians before hand. i am pretty sure that same has been the case with new cultus as well. you just get your car tuned by an outside cng mechanic (of repute, ofcourse) and see if your problem gets resolved. do share your experiance with us.

  6. #6
    PakWheeler Follow
    fzaman's Avatar
    Join Date
    Mar 2006
    Location
    Islamabad
    Age
    40
    Posts
    105
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Well i will suggest you to visit Suzuki Islamabad Motors. The technical guy out there is Nasir. I hope he will get your problem resolved.

  7. #7
    PakWheeler Follow
    drsohail30's Avatar
    Join Date
    Dec 2007
    Location
    Bahawalpur
    Age
    45
    Posts
    3
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Dear All
    I have the same problem and my cultus is off when I press the clutch or apply the brakes. I contacted the dealer. They changed The ECU and Timer Processor Advancer. But the problem is still there. I am in bahawalpur and for this purpose went to Multan but they could not resolve the issue.
    Dr.Sohail

  8. #8
    Senior PakWheeler Follow
    SER_GTR's Avatar
    Join Date
    Nov 2005
    Location
    Karachi
    Age
    30
    Posts
    9,737
    Follows
    16
    Following
    0
    Mentioned
    489 Post(s)
    Tagged
    19 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    3

    Default

    ISC Valve......! That Can Be Culprit...!
    These idiots Just Get Changing Things Without Considering What Can Be Actually Problem...!
    TOYOTA Sprinter 86- AE80 DOHC 20v'D TOYOTA Corolla 98- AE101 4AFE 16v

  9. #9
    Senior PakWheeler Follow
    Farhansa's Avatar
    Join Date
    Oct 2006
    Location
    Islamabad
    Posts
    8,715
    Follows
    5
    Following
    1
    Mentioned
    84 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    it is not a big problem. Suzuki walay apni jaan chura rahay hain. they are worst in after sale service / in warranty issues.
    go to any good mechanic, he will adjust idle speed.

  10. #10
    Senior PakWheeler Follow
    rozzzzz's Avatar
    Join Date
    Oct 2005
    Location
    Islamabad
    Posts
    21,925
    Follows
    12
    Following
    0
    Mentioned
    140 Post(s)
    Tagged
    5 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    2

    Default

    yaartiming ka masla ha....just go to normal mechanicfit ho jai ga

    i got my car fitted from g-8 markaz......suzuki wala awain time lagata hain
    MOTOR MANIACS ... An automotive service and repair workshop
    https://www.facebook.com/pages/Motor-Maniacs/721830141231922

  11. #11
    Senior PakWheeler Follow
    bubble's Avatar
    Join Date
    Aug 2006
    Location
    Karachi
    Age
    29
    Posts
    1,780
    Follows
    0
    Following
    0
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    have you checked the air filter and spark plugs?
    There is nothing in this world that can end your potentials for doing something..

  12. #12
    PakWheeler Follow
    Sherkhan291285's Avatar
    Join Date
    Dec 2007
    Location
    Lahore
    Age
    30
    Posts
    163
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    get the cng tuned and if this does not work then chuck your car back in their faces
    -

  13. #13
    Newbie Follow
    aftabahmedk's Avatar
    Join Date
    Mar 2008
    Location
    Islamabad
    Age
    37
    Posts
    1
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I have a 2008 Cultus EFIi, I had the same problem of RPM going to ZERO followed by engine shutdown when clutch applied. I went to my mechanic in F-10 markaz (Gohar 0300-3950645) and the problem was fixed. The problem was due to dust accumulation in the chamber where the air filter duct ends (probably called throttle body). The openings before the butterfly used for intake of air during idle speed (when the accelerator is not pressed) were blocked.
    Another possible symptom for this is, when the engine is started (cold engine) the RPM goes up and down rapidly.

  14. #14
    PakWheeler Follow
    alikanju's Avatar
    Join Date
    Jun 2009
    Location
    Rawalpindi
    Age
    34
    Posts
    413
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Sometimes changing the air filter and spark plugs resolve the missing issue on cng but as u say its new cultus then i think its cng setting problem...

  15. #15
    Senior PakWheeler Follow
    Skill's Avatar
    Join Date
    Aug 2009
    Location
    Select City
    Posts
    7,885
    Follows
    3
    Following
    2
    Mentioned
    94 Post(s)
    Tagged
    40 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    give a try to enercon.
    https://www.facebook.com/skillgrafik

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •