Survey by Qualaroo
+ Reply to Thread
Results 1 to 11 of 11

Thread: CULTUS : CNG KIT PROBLEM

  1. #1
    PakWheeler Follow
    Beamers's Avatar
    Join Date
    Aug 2005
    Location
    Lahore
    Age
    44
    Posts
    443
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default CULTUS : CNG KIT PROBLEM

    DEAR FRIENDS, I HAVE A CULTUS IN WHICH THE CNG KIT WAS FIXED LATER ON i.e NON-FACTORY FITTED. THE PROBLEMS BEING FACED ARE.

    1. THE SHIVERING/VIBRATION IN THE CAR UNTILL THE TEMPRATURES REACHES TO CERTAIN LEVEL.


    2. IF THE ADJUSTER KNOB IN CNG KIT IS ADJUSTED IN ORDER TO NORMALISE THE RPM OF THE CAR WHICH IN TURM LOWER THE VIBRATION BUT BY DOING THIS THERE IS MORE INCREASE IN RPM WHEN THE TEMPRATURE NEEDLE IS AT HALF. AND THE CNG AVERAGE PER KM IS THRASHED.

    3. DUE TO THE ABSENCE OF ADVANCER THE PETROL AVERAGE IS PATHETIC IN CULTUS.

    IS THERE ANY REMEDY YOU PEOPLE HAVE IN YOUR MIND. IF THE ONLY OPTION IS TO CHANGE THE CAR THEN WHAT WILL BE NEXT OPTION.

    REGARDS

    M. Ahsan Ayaz
    03466660999

  2. #2
    Senior PakWheeler Follow
    robin's Avatar
    Join Date
    Jun 2005
    Location
    Islamabad
    Posts
    2,825
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    get it properly tuned and block some passage of intake air flow. this might help.

    As u don't have advancer so u have to advance the spark timing, by adjusting distributor, but remember when u turn to petrol running then u have to retard/set to the original petrol timing.

  3. #3
    PakWheeler Follow
    saadkc's Avatar
    Join Date
    Sep 2005
    Location
    Rawalpindi
    Age
    27
    Posts
    60
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    yaar is sey nichley waley forum ko dekho

  4. #4
    PakWheeler Follow
    Beamers's Avatar
    Join Date
    Aug 2005
    Location
    Lahore
    Age
    44
    Posts
    443
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    DEAR ROBIN, I HAVE TRIED, AS YOU HAVE SAID BUT DID NOT WORK SUCCESSFULLY.
    PRESENTLY I AM VERY UPSET ABOUT THIS SITUATION.
    CAN SOMEONE GUIDE ME TO A SUIATBLE MECHANIC OR AN CNG SPECIALIST.
    REGARDS
    M. Ahsan Ayaz
    03466660999

  5. #5
    Senior PakWheeler Follow
    robin's Avatar
    Join Date
    Jun 2005
    Location
    Islamabad
    Posts
    2,825
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    how about the condition of water pump? is that alright? vibrations could increase substantially with water body's malfucntioning.

    moreover, plz state what's the magnitude of prob, as CNG vehicles have this tendency, slightly more than while running on petrol, it's normal. check air cleaner, is it clean and blocked right (not too much, not too less).

  6. #6
    Senior PakWheeler Follow
    robin's Avatar
    Join Date
    Jun 2005
    Location
    Islamabad
    Posts
    2,825
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i forgot one thing, set the plug gaps correctly, it is noticeable when they are cold.

  7. #7
    PakWheeler Follow
    Beamers's Avatar
    Join Date
    Aug 2005
    Location
    Lahore
    Age
    44
    Posts
    443
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    water pump/water body is in good condtion. Have got it checked. Robin do mean that the plug gap shd be reduced?

    regards
    M. Ahsan Ayaz
    03466660999

  8. #8
    Senior PakWheeler Follow
    sali2002's Avatar
    Join Date
    Feb 2005
    Location
    Karachi
    Age
    30
    Posts
    1,077
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    hello!!
    beamers....u said that car vibrates still when engine was standing at normal temp...hmmm another thing u said about knob so its Idle Adjustment nut.....here are few thimgs hope this can sove ur problem...
    1...check ur plug distance in cold engine...they are default setted to 0.8mm...just reduce it to 0.6mm but plz do it with help of guage....this can solve ur hardstarting and vibration and jerk problem...
    2...check ur air filter wheather air filter was not dirty..after that adjust the knob Anti-clockwise for increase and Clock-wise for decrease...set at best level where u see that there less vibration and rpm range can be b/w 800-1500max...not more than that.....
    after that
    3...check out what is the timing of ur engine....advance it till 15 Degress on CNG..not more than that...check it out with the help of timing torch....but remember running engine with this timing on petrol resulting in excessive knock out....
    check out these things hopefully it can solve ur most of the problems.....any problem after that U are welcome to ask..
    Thanxxx

  9. #9
    Senior PakWheeler Follow
    robin's Avatar
    Join Date
    Jun 2005
    Location
    Islamabad
    Posts
    2,825
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i'd re-iterate that it's normal till engine reaches optimum temp, when it reaches that temp then u have mentioned that everything becomes okay.

    Tip: start ur engine by pulling out the choke, what choke does is it increases fuel supply, blocks some intake air, means a rich air/fuel mixture, gives better starting. but as soon as engine tends to attain optimum temp, ur engine would also tend to stall, when this happens then insert the choke back to its position.
    Actually this is the standard start up procedure ( SOP ) for a carby CNG vehicle.

    it seems everything is normal in ur vehicle except u r not conversant with CNG vehicle.

  10. #10
    PakWheeler Follow
    Beamers's Avatar
    Join Date
    Aug 2005
    Location
    Lahore
    Age
    44
    Posts
    443
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    thanks again,
    Robin, its coke is automatic not manuall, I have again blocked the air intake, it has helped a bit. plug space is yet to be set at 6mm. I think after both settings i.e spark plugs and air intake, I wd be better vehile.
    I'll post outcome later.

    Regards
    M. Ahsan Ayaz
    03466660999

  11. #11
    Senior PakWheeler Follow
    sali2002's Avatar
    Join Date
    Feb 2005
    Location
    Karachi
    Age
    30
    Posts
    1,077
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    hello!
    beamr its 0.6mm buddy not 6mm ...6mm is quiet big
    Thanxx

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •