Survey by Qualaroo
+ Reply to Thread
Results 1 to 18 of 18
Like Tree1Likes
  • 1 Post By Heart_Break_Kid

Thread: Cuore not warming up!

  1. #1
    Senior PakWheeler Follow
    omarabdullah022's Avatar
    Join Date
    Oct 2012
    Location
    Karachi
    Posts
    2,641
    Follows
    1
    Following
    1
    Mentioned
    96 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Exclamation Cuore not warming up!

    A week ago i got my cuore's radiator serviced and head flushed. The guy said that the thermostate valve had worn out and should be removed.- I got a brand new one and got it replaced. But now even though the fan is auto, the car doesnt reach the correct temperature. I've also noticed the fan works for a longer time than required after the flush. Is this okay?
    Attached Images Attached Images  

  2. #2
    Senior PakWheeler Follow
    umarkhan1's Avatar
    Join Date
    Nov 2010
    Location
    Sargodha
    Posts
    2,308
    Follows
    6
    Following
    8
    Mentioned
    51 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    2

    Default

    Read the temp grading from the old t-valve and get a new of the same grade


    Sent from my iPhone 4S using PW Forums mobile app
    Just Do It Your Self!!!!!

  3. #3
    Senior PakWheeler Follow
    omarabdullah022's Avatar
    Join Date
    Oct 2012
    Location
    Karachi
    Posts
    2,641
    Follows
    1
    Following
    1
    Mentioned
    96 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I did. The new one is 82 degrees just like the old one.

  4. #4
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,399
    Follows
    131
    Following
    0
    Mentioned
    3987 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    check the gauge or sensor.
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  5. #5
    Senior PakWheeler Follow
    omarabdullah022's Avatar
    Join Date
    Oct 2012
    Location
    Karachi
    Posts
    2,641
    Follows
    1
    Following
    1
    Mentioned
    96 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Where is it located?

  6. #6
    PakWheeler Follow
    askai37's Avatar
    Join Date
    Sep 2010
    Location
    Karachi
    Posts
    503
    Follows
    0
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    gari ko thaand laag gaey hey qarshi joshanda pilao

  7. #7
    Senior PakWheeler Follow
    whiteangel's Avatar
    Join Date
    Nov 2005
    Location
    Lahore
    Posts
    2,240
    Follows
    9
    Following
    2
    Mentioned
    65 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    1

    Default

    The problem seems to be with the coolant temperature sensor which powers on the fan. It should shut off the fan sooner, but it is not doing so. Remove the sensor and check it.

    Also, did you bleed air from the system when you replaced the thermostat valve?
    Never argue with an idiot, they drag you down to their level and beat you with experience.

  8. #8
    Senior PakWheeler Follow
    omarabdullah022's Avatar
    Join Date
    Oct 2012
    Location
    Karachi
    Posts
    2,641
    Follows
    1
    Following
    1
    Mentioned
    96 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I think this is the sensor......
    Its pretty rusty and dirty-should i clean it?
    i removed the wire connected to it as well but it had absolutely no effect.
    Do you think this is the culprit?

  9. #9
    Senior PakWheeler Follow
    omarabdullah022's Avatar
    Join Date
    Oct 2012
    Location
    Karachi
    Posts
    2,641
    Follows
    1
    Following
    1
    Mentioned
    96 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default



    Cuore not warming up! -1217167

  10. #10
    Senior PakWheeler Follow
    Marwanpasha's Avatar
    Join Date
    Oct 2012
    Location
    Karachi
    Age
    22
    Posts
    2,088
    Follows
    0
    Following
    0
    Mentioned
    71 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Whats the top its reaching..?

    Does the fan get stop..? To check it. When the car engine is cold after 3-4 hours just start it and note the status of fan. Because may be the electrician has mess some wires and the fan still goes auto.


    Sent from my iPhone using PW Forums mobile app
    Yahoo i got the app at last...!

  11. #11
    Senior PakWheeler Follow
    omarabdullah022's Avatar
    Join Date
    Oct 2012
    Location
    Karachi
    Posts
    2,641
    Follows
    1
    Following
    1
    Mentioned
    96 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    No, when the engine is cool and i put it to idle,the fan does not work until the needle touches a little below the half mark. I'm saying that it doesnt stop until the engine is really cool-like in the first picture.
    -

  12. #12
    Senior PakWheeler Follow
    omarabdullah022's Avatar
    Join Date
    Oct 2012
    Location
    Karachi
    Posts
    2,641
    Follows
    1
    Following
    1
    Mentioned
    96 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @Xulfiqar
    i've also noticed that the engine is cooler while driving than while idleing

  13. #13
    Senior PakWheeler Follow
    omarabdullah022's Avatar
    Join Date
    Oct 2012
    Location
    Karachi
    Posts
    2,641
    Follows
    1
    Following
    1
    Mentioned
    96 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Anyone?

  14. #14
    Senior PakWheeler Follow
    Marwanpasha's Avatar
    Join Date
    Oct 2012
    Location
    Karachi
    Age
    22
    Posts
    2,088
    Follows
    0
    Following
    0
    Mentioned
    71 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I think then its working perfect. As the fan starts when the needle touches the midpoint and stops at quarter. It will do that. Because it will not play on and off for two two minutes.


    Sent from my iPhone using PW Forums mobile app
    Yahoo i got the app at last...!

  15. #15
    Senior PakWheeler Follow
    imranbhatti's Avatar
    Join Date
    Nov 2005
    Location
    Lahore
    Age
    39
    Posts
    4,373
    Follows
    1
    Following
    0
    Mentioned
    80 Post(s)
    Tagged
    11 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @omarabdullah022

    Have you check the coolant/Water level in radiator after u start facing this issue ? or got any other work done like heater bypass etc during the recent job ?
    Exploring Machines is my Passion...

  16. #16
    Senior PakWheeler Follow
    omarabdullah022's Avatar
    Join Date
    Oct 2012
    Location
    Karachi
    Posts
    2,641
    Follows
    1
    Following
    1
    Mentioned
    96 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Yes, the coolant level is just right. I went for a full radiator service and after that the problem started.....
    The local radiator wala's think it is okay and the cooler the engine the better-_-...

  17. #17
    Senior PakWheeler Follow
    omarabdullah022's Avatar
    Join Date
    Oct 2012
    Location
    Karachi
    Posts
    2,641
    Follows
    1
    Following
    1
    Mentioned
    96 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Can i open the sensor for cleaning? @Xulfiqar

  18. #18
    PakWheeler Follow
    Heart_Break_Kid's Avatar
    Join Date
    Oct 2010
    Location
    Karachi
    Age
    26
    Posts
    853
    Follows
    1
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    My cuore temp needle stays at that place while AC on. and rarely reach below half during traffic. seems normal to me
    I think I'm cute,I know i'm sexy,I got the looks,I'm just a sexy boy (sexy boy),I'm not your boy toy (boy toy),I'm just a sexy boy (sexy boy),I'm not your boy toy (boy toy)....

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •