Survey by Qualaroo
+ Reply to Thread
Results 1 to 12 of 12

Thread: Nissan Patrol - 1991 ( Wobbling Problem)

  1. #1
    PakWheeler Follow
    ziadshahbaz's Avatar
    Join Date
    Oct 2006
    Location
    Karachi
    Age
    44
    Posts
    9
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Nissan Patrol - 1991 ( Wobbling Problem)

    Dear All,

    I would appreciate if you could provide some advice or guidance for the following problem.

    I have a Nissan Patrol, 1990 model, 5 door. I recently noticed that about 110 - 120 the steering starts vibrating. This problem originally started with the old dunlop tyres steering vibration) and it was discovered that the balance rod bush and stablizer link bush had to be changed which was done. After this the problem went away.

    However 2 months ago, the problem came very minorly and as these dunlop tyres were old we got them balanced and the problem improved. As the dunlop tyres were getting old and frequently punchered, I had them changed and noticed that after the change of tyres the problem is still there at the above speed.

    I have had the wheel balancing done twice from different places and from where I bought the tyres with the tyre wala and my mechanics present together. The problem went away for 3 days but it is back.

    I have had the suspension and shocks checked and they are fine as it was a suspension problem then the problem would not go away in the first place. The jeep has been rarely used off road few years ago.

    I would like to know whether any one has had similiar problems as I know that quite a few people on Pak wheels own Nissan Patrol / Safari and other SUVs. Also, any advice or experience sharing would be nice. Thank you for your time.

  2. #2
    Senior PakWheeler Follow
    qwertypoiu's Avatar
    Join Date
    Feb 2007
    Location
    Lahore
    Posts
    29,130
    Follows
    2
    Following
    1
    Mentioned
    153 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    1
    Good Answers
    1

    Default

    get alignment done
    RIP

  3. #3
    Senior PakWheeler Follow
    akifjanjua's Avatar
    Join Date
    Oct 2005
    Location
    Rawalpindi
    Age
    34
    Posts
    1,097
    Follows
    1
    Following
    0
    Mentioned
    35 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Steering shimmy needs to be dealt with carefully... i suggest check the following step by step

    1. Tire balancing
    2. All steering component, bushing and tie rod ends. Also check the wheel bearings and kingpins for wear
    3. Check brake disc rotors.. a warp rotor can cause this
    4. Steering shock.. it helps dampen this shimmy.. check if its working or try replacing it.. note this should be the last thign u do.. it will cover the problem not cure it

    any one of these components can cause a shimmy..
    75% of earth is covered by water... the rest by Jeep
    www.brokenknucklegarage.com

  4. #4
    Senior PakWheeler Follow
    spectra's Avatar
    Join Date
    Jul 2005
    Location
    Islamabad
    Age
    40
    Posts
    19,667
    Follows
    3
    Following
    0
    Mentioned
    303 Post(s)
    Tagged
    24 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    It can be the rim which is causing vibration
    Keep a cool head and wear seatbelts!

  5. #5
    PakWheeler Follow
    funduro's Avatar
    Join Date
    Jan 2008
    Location
    Lahore
    Age
    45
    Posts
    167
    Follows
    0
    Following
    1
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    does it wobbles when you instant brake at high speed . your problem could be both wheels and suspension .

    any play or imperfection in wheels/hubs should not make the whole car wobble .

    1) check the bushes of panhard rod . its a dialogonal rod on front tube has bushes on both ends . try to replace rubber ones with tefolon ones . also you need to replace your steering damper/shock .

    are ther any oil leaks in ur engine
    he who seeks shall find or he who finds shall seek

  6. #6
    PakWheeler Follow
    ziadshahbaz's Avatar
    Join Date
    Oct 2006
    Location
    Karachi
    Age
    44
    Posts
    9
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Dear All,

    Thankyou for your inputs. I have had the suspension, steering, shocks everything checked out and it is fine, as it has nt been also used as such off road. No leaks in engine, or differential area. Surprising thing is that it could be the rims as one of you also mentioned as they original and came with the jeep.

    However one thing which is strange is that when the engine is cold, it does give this problem. However when the engine is warm, as for the pass 2 or 3 days the jeep is being used quite extensively, there is no wobbling at even 120.

    I discussed the above with the workshop guys, they said there was no co relation between the warm engine and wobbling. Or may be the tyres are setting in....

    What do you guys think ????

  7. #7
    Senior PakWheeler Follow
    levin's Avatar
    Join Date
    Oct 2005
    Location
    Select City
    Age
    51
    Posts
    23,112
    Follows
    5
    Following
    0
    Mentioned
    95 Post(s)
    Tagged
    6 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    only another member who have same jeep can confirm, to me this cold engine and wobble sounds strange
    ,,, unless you know the track, you're not good enough to sit behind the wheel." K T

  8. #8
    PakWheeler Follow
    funduro's Avatar
    Join Date
    Jan 2008
    Location
    Lahore
    Age
    45
    Posts
    167
    Follows
    0
    Following
    1
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    add lift spacer under ur front springs . raise the vehcle few inches then tried .
    he who seeks shall find or he who finds shall seek

  9. #9
    PakWheeler Follow
    NissanSafari's Avatar
    Join Date
    Mar 2009
    Location
    Karachi
    Age
    26
    Posts
    82
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Broda agar yeh masla sahi karwana hai tou merey pass gari ley kar aajaoo mein sahi karwa dunga....

  10. #10
    PakWheeler Follow
    untame's Avatar
    Join Date
    Jun 2005
    Location
    Islamabad
    Posts
    268
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    check your driving shaft, make sure the rubbers and the joints are in good condition
    Life is short, lets go Off Roading!!!

  11. #11
    PakWheeler Follow
    Charged's Avatar
    Join Date
    Apr 2006
    Location
    Islamabad
    Posts
    591
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Worn out universal joints/couplings in propellar shaft produce similar symptoms
    There ain't no mud deep enough and no mountain high enough when you've got a LAND ROVER

  12. #12
    PakWheeler Follow
    ziadshahbaz's Avatar
    Join Date
    Oct 2006
    Location
    Karachi
    Age
    44
    Posts
    9
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Dear All


    Thankyou for your kind support. I have taken everyone advice and have had almost everything checked out as recommended. Mechancially, the vehicle is fine. It is the rims which obviously have not been changed in 18 years and there seems to be play as the ratings get off quite quickly twice in last week. Also the problem improves once the tyres are balanced. The problem as such is only starts after 110 - 120. From 0 to 110 it is fine...


    I am looking for the standard rims, as the alloy rims would put additional weight on the suspension. My tyre guy got two sets of the standard rims but there were no good at the time of balancing. he has requested me to give him sometime. However if anyone knows, then let me know.


    Thanks again.

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •