Survey by Qualaroo
+ Reply to Thread
Results 1 to 9 of 9

Thread: Mileage drop issues with Nissan Mocco 2007, advice needed

  1. #1
    PakWheeler Follow
    bakhtbaryar's Avatar
    Join Date
    Jun 2015
    Location
    Islamabad
    Age
    23
    Posts
    82
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    4
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Mileage drop issues with Nissan Mocco 2007, advice needed

    I took my mother's mocco for a routine check at about 80k kms. Had the following done:

    -Engine oil changed (Earlier was Havoline but it wasn't lasting even 2500 km so tried Kixx on a friend's recommendation)
    -New Filters
    -Spark Plugs Changed
    -Transmission Oil was changed
    -Coolant was replaced

    Now the mileage has dropped from 15 km/l (With A/C urban drive) to about 10 km/l (with A/C urban drive) and the car feels heavier too


    Any suggestions what could be wrong?

  2. #2
    Senior PakWheeler Follow
    KeiWorks12's Avatar
    Join Date
    Mar 2012
    Location
    Karachi
    Posts
    1,298
    Follows
    13
    Following
    0
    Mentioned
    94 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    1
    Good Answers
    1

    Default

    Which grade oil is poured in your car now? And which transmission oil?

    Sent from my SM-J700H using PW Forums mobile app

  3. #3
    Senior PakWheeler Follow
    KeiWorks12's Avatar
    Join Date
    Mar 2012
    Location
    Karachi
    Posts
    1,298
    Follows
    13
    Following
    0
    Mentioned
    94 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    1
    Good Answers
    1

    Default

    Also was the throttle body serviced aswell? I have heard most 660cc cars becomes heavier and gives less mileage when throttle body is serviced. Maybe because of incorrect procedure

    Sent from my SM-J700H using PW Forums mobile app

  4. #4
    PakWheeler Follow
    bakhtbaryar's Avatar
    Join Date
    Jun 2015
    Location
    Islamabad
    Age
    23
    Posts
    82
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    4
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    No Throttle body was not serviced. The Oil was 20/50.

    Could wrong kind of spark plugs be causing this?

  5. #5
    PakWheeler Follow
    waleed96's Avatar
    Join Date
    May 2014
    Location
    Karachi
    Age
    20
    Posts
    334
    Follows
    0
    Following
    0
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    2

    Default

    Was engine oil level decreasing?
    20w50 is a very thick oil for this engine and it isn't recommended.

    Use 5w30 or 5w40 viscosity oils for this engine.
    My advice is to drain your current oil and pour any of the above mentioned oil of either Zic or Shell.

  6. #6
    Senior PakWheeler Follow
    MBILALNAWAZ's Avatar
    Join Date
    Jun 2011
    Location
    Rawala kot
    Posts
    1,223
    Follows
    0
    Following
    0
    Mentioned
    10 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by bakhtbaryar View Post
    No Throttle body was not serviced. The Oil was 20/50.

    Could wrong kind of spark plugs be causing this?
    oil is too thick IMO and knowledge, these 660cc are designed to take 0w-20 or 5w-30( written in manual as well as inside the bonnet), I think i repeat i think max u can opt for is 10w-40. Hope it might help, rest wait and see the senior to come to help.

  7. #7
    PakWheeler Follow
    bakhtbaryar's Avatar
    Join Date
    Jun 2015
    Location
    Islamabad
    Age
    23
    Posts
    82
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    4
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Will change engine oil tomorrow and report back

  8. #8
    PakWheeler Follow
    bakhtbaryar's Avatar
    Join Date
    Jun 2015
    Location
    Islamabad
    Age
    23
    Posts
    82
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    4
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Everyone thanks for the help... the engine oil change solved the problem and the 20-50 Kixx had practically started clogging together chagned it with Byco 10-30

  9. #9
    Senior PakWheeler Follow
    IsbCap's Avatar
    Join Date
    Aug 2009
    Location
    Islamabad
    Posts
    1,865
    Follows
    1
    Following
    0
    Mentioned
    159 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    10w-30 may be fine in current summer conditions, but still too thick for winters. I use 5W-20 in all weathers in my nissan sunny and never faced a problem. Excellent mileage figures even from 1500cc engine on a sedan.

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •