Survey by Qualaroo
+ Reply to Thread
Results 1 to 4 of 4

Thread: CD-70 Dying after hard braking

  1. #1
    PakWheeler Follow
    CrankRaptor's Avatar
    Join Date
    Mar 2012
    Location
    Lahore
    Age
    26
    Posts
    2
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Exclamation CD-70 Dying after hard braking

    I have bought a new cd 70, its just 2000 KM driven. i am facing a problem, because the engine is dying frequently on signals and rushed places.

    My problem is that when i put the bike in 1st or 2nd gear then pull the throttle and release the clutch to start moving, then immediately engaging clutch and both the brakes the bike after a small bump ( can only be felt hardly) it dyies, i dont know whats going on with it, i have already tunned it for this reason, but the problem persists, please help

    I have adjusted the clutch freeplay, but it doesnt help. also what is the ideal idling speed of engine.

    Thanks in advance.


  2. #2
    Senior PakWheeler Follow
    asjdsm's Avatar
    Join Date
    Apr 2009
    Location
    Islamabad
    Age
    30
    Posts
    3,470
    Follows
    4
    Following
    0
    Mentioned
    57 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    0

    Default

    slightly increase the idle speed..
    ideal idling sped is 1500rpm for 70 but with no rpm meter u cant see where is 1500..

    so just rotate clockwise the idle adjustment screw half a turn if its too lound just reduce the turn..

    or go increasing the idle speed...

    http://assets.pakwheels.com/forums/2...-06-20-375.jpg

    the screw near the black wire is whch controls idle speed..

  3. #3
    PakWheeler Follow
    hasnain19's Avatar
    Join Date
    Mar 2011
    Location
    Lahore
    Age
    21
    Posts
    267
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Yup i also had the same problem after tuning the idle speed was too less by the mechanic just gave it a little turn now its perfectly fine
    Life is beauty, admire it.

  4. #4
    Senior PakWheeler Follow
    ToxicDevil's Avatar
    Join Date
    Nov 2010
    Location
    Lahore
    Posts
    1,317
    Follows
    2
    Following
    0
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    13
    Problems Solved
    0
    Best Answers
    3
    Good Answers
    0

    Default

    get the free tuning done

+ Reply to Thread

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •