Survey by Qualaroo
+ Reply to Thread
Results 1 to 20 of 20

Thread: Problem with roadprince 70 charging

  1. #1
    PakWheeler Follow
    abubakker.akram's Avatar
    Join Date
    Sep 2016
    Posts
    17
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default Problem with roadprince 70 charging

    My cd 70 battery is not charging the voltage coming in to charge battery is a lot less.any solution ?


  2. #2
    Senior PakWheeler Follow
    Hassan1991's Avatar
    Join Date
    Mar 2013
    Location
    Lahore
    Age
    20
    Posts
    2,282
    Follows
    4
    Following
    0
    Mentioned
    38 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Voltage is coming or nor?
    The first step towards knowledge is to know that WE are IGNORANT

  3. #3
    Senior PakWheeler Follow
    amjad635's Avatar
    Join Date
    Sep 2011
    Location
    Select City
    Posts
    5,713
    Follows
    13
    Following
    0
    Mentioned
    228 Post(s)
    Tagged
    10 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    change the rectifier and see

    Rectifier is the battery charger in motorcycle

  4. #4
    PakWheeler Follow
    abubakker.akram's Avatar
    Join Date
    Sep 2016
    Posts
    17
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    Quote Originally Posted by Hassan1991 View Post
    Voltage is coming or nor?
    Yes voltage coming is juat 7.9v max. Less voltage.

    Sent from my SM-G925F using PW Forums mobile app

  5. #5
    PakWheeler Follow
    abubakker.akram's Avatar
    Join Date
    Sep 2016
    Posts
    17
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    Quote Originally Posted by amjad635 View Post
    change the rectifier and see

    Rectifier is the battery charger in motorcycle
    How do rectifier look like ? The one with a heat sink or black rectangular ?

    Sent from my SM-G925F using PW Forums mobile app

  6. #6
    Senior PakWheeler Follow
    Hassan1991's Avatar
    Join Date
    Mar 2013
    Location
    Lahore
    Age
    20
    Posts
    2,282
    Follows
    4
    Following
    0
    Mentioned
    38 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by abubakker.akram View Post
    How do rectifier look like ? The one with a heat sink or black rectangular ?

    Sent from my SM-G925F using PW Forums mobile app
    One with Heat sink.
    The first step towards knowledge is to know that WE are IGNORANT

  7. #7
    PakWheeler Follow
    abubakker.akram's Avatar
    Join Date
    Sep 2016
    Posts
    17
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    The engine runs on a.c power and this converts a.c into d.c to charge battery and power front light and back light etc ? How come all the lights are running ok and only power to battery is less ?

    Sent from my SM-G925F using PW Forums mobile app

  8. #8
    PakWheeler Follow
    abubakker.akram's Avatar
    Join Date
    Sep 2016
    Posts
    17
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    Quote Originally Posted by Hassan1991 View Post
    One with Heat sink.
    The engine runs on a.c power and this converts a.c into d.c to charge battery and power front light and back light etc ? How come all the lights are running ok and only power to battery is less ?

    Sent from my SM-G925F using PW Forums mobile app

  9. #9
    Senior PakWheeler Follow
    Hassan1991's Avatar
    Join Date
    Mar 2013
    Location
    Lahore
    Age
    20
    Posts
    2,282
    Follows
    4
    Following
    0
    Mentioned
    38 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by abubakker.akram View Post
    The engine runs on a.c power and this converts a.c into d.c to charge battery and power front light and back light etc ? How come all the lights are running ok and only power to battery is less ?

    Sent from my SM-G925F using PW Forums mobile app
    First tell me how you had checked the voltage??
    You should unplug battery before checking the voltage next thing is a bulb does take all 12 volt I mean to say it's 12 volt bulb but voltage are divided between headlight,backlight and battery so bulb will work fine
    The first step towards knowledge is to know that WE are IGNORANT

  10. #10
    PakWheeler Follow
    abubakker.akram's Avatar
    Join Date
    Sep 2016
    Posts
    17
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    Quote Originally Posted by Hassan1991 View Post
    First tell me how you had checked the voltage??
    You should unplug battery before checking the voltage next thing is a bulb does take all 12 volt I mean to say it's 12 volt bulb but voltage are divided between headlight,backlight and battery so bulb will work fine
    I have checked by multemeter after removing battery and starting the bike.

    Sent from my SM-G925F using PW Forums mobile app

  11. #11
    Senior PakWheeler Follow
    hamikhan's Avatar
    Join Date
    Jun 2014
    Location
    Other
    Posts
    1,261
    Follows
    1
    Following
    0
    Mentioned
    39 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    0

    Default

    Bro accelerate bike then check voltage

  12. #12
    Senior PakWheeler Follow
    Hassan1991's Avatar
    Join Date
    Mar 2013
    Location
    Lahore
    Age
    20
    Posts
    2,282
    Follows
    4
    Following
    0
    Mentioned
    38 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by abubakker.akram View Post
    I have checked by multemeter after removing battery and starting the bike.

    Sent from my SM-G925F using PW Forums mobile app
    I think so it's rectifier fault....but first try to install anyother bike's rectifier just to be sure.
    The first step towards knowledge is to know that WE are IGNORANT

  13. #13
    PakWheeler Follow
    abubakker.akram's Avatar
    Join Date
    Sep 2016
    Posts
    17
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    Quote Originally Posted by hamikhan View Post
    Bro accelerate bike then check voltage
    I have checked .initially the voltage was 4.5 then at top accceleration voltage was 7.9

    Sent from my SM-G925F using PW Forums mobile app

  14. #14
    PakWheeler Follow
    abubakker.akram's Avatar
    Join Date
    Sep 2016
    Posts
    17
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    Quote Originally Posted by Hassan1991 View Post
    I think so it's rectifier fault....but first try to install anyother bike's rectifier just to be sure.
    Ok bro .thanx alot i will let u know what happened

    Sent from my SM-G925F using PW Forums mobile app

  15. #15
    PakWheeler Follow
    abubakker.akram's Avatar
    Join Date
    Sep 2016
    Posts
    17
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    Quote Originally Posted by Hassan1991 View Post
    I think so it's rectifier fault....but first try to install anyother bike's rectifier just to be sure.
    Bro is there a voltage regulator or capacitor type thing in bike.i have seen faulty capacitor outputs a reduced voltage. What is the black rectangular a inch and a half long solid thing ? Whats its purpose.just curious

    Sent from my SM-G925F using PW Forums mobile app

  16. #16
    Senior PakWheeler Follow
    Hassan1991's Avatar
    Join Date
    Mar 2013
    Location
    Lahore
    Age
    20
    Posts
    2,282
    Follows
    4
    Following
    0
    Mentioned
    38 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by abubakker.akram View Post
    Bro is there a voltage regulator or capacitor type thing in bike.i have seen faulty capacitor outputs a reduced voltage. What is the black rectangular a inch and a half long solid thing ? Whats its purpose.just curious

    Sent from my SM-G925F using PW Forums mobile app
    That's cdi(capacitor discharge ignition).....It regulates the ignition current produced by the magnet coil and forwarded it to the big coil which boosted the current.
    The first step towards knowledge is to know that WE are IGNORANT

  17. #17
    PakWheeler Follow
    abubakker.akram's Avatar
    Join Date
    Sep 2016
    Posts
    17
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    Found the problem.battery was faulty .the reason the voltage shown on multimeter is that there is no capacitor to normalize voltage and the multimeter just read the basic reading .if capacitor is added the voltage would be shown proper on multimeter.thanx all of u for help

    Sent from my SM-G925F using PW Forums mobile app

  18. #18
    Senior PakWheeler Follow
    margallar's Avatar
    Join Date
    Oct 2009
    Location
    Lahore
    Posts
    9,960
    Follows
    6
    Following
    2
    Mentioned
    283 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    check wiring, if okay, test another rectifer, else replace stator. all cheap
    haters gonna hate, potatoes gonna potate

  19. #19
    PakWheeler Follow
    alizain5's Avatar
    Join Date
    Nov 2013
    Location
    Faisalabad
    Age
    26
    Posts
    144
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    4
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    I think replacing rectifier will easily solve the problem. rectifier is not much expensive to buy as spare.

  20. #20
    PakWheeler Follow
    abubakker.akram's Avatar
    Join Date
    Sep 2016
    Posts
    17
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    Quote Originally Posted by alizain5 View Post
    I think replacing rectifier will easily solve the problem. rectifier is not much expensive to buy as spare.
    Bro was a battery problem.

    Sent from my SM-G925F using PW Forums mobile app

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •