Survey by Qualaroo
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 20 of 32

Thread: spectra missing on petrol ,running perfect on cng

  1. #1
    Senior PakWheeler Follow
    imrandahar's Avatar
    Join Date
    Jun 2005
    Location
    Sadiqabad
    Age
    34
    Posts
    1,174
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default spectra missing on petrol ,running perfect on cng

    today when i came from my office cng was end thn i converted it to petrol the car started missing, i switched off. again start karney ki koshish ki but start nhi hui buhut bar try kia ,injectors k pas petrol pipe wala valve par key laga k check kia fuel pump petrol de raha tha pressure se, but pata nhi kia masla aya hai injectors ki wires b check ki wo b thek hai aur air blockege b nhi meri gari me, kabhi kabhi idle speed me start hoti hai but jaise hee halka accelerate do band hojati hai magar full padal rakho accelerate p to start hojati hai but backfire karti hai cng p bilkul hee sahi chalti hai plz help me what to do, yaha koi itna acha mechanic b nhi jo sahi kar saky
    ikd

  2. #2
    Senior PakWheeler Follow
    chinyoti's Avatar
    Join Date
    Sep 2005
    Location
    Karachi
    Age
    27
    Posts
    11,954
    Follows
    5
    Following
    0
    Mentioned
    107 Post(s)
    Tagged
    5 Thread(s)
    Problems Posted
    2
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    1

    Default

    seems lyk a faulty fuel pump. do u drive very rare on Petrol?
    Get over the fact that Xli lacks power windows, Its an Xli because it lacks thoose features or else it would be a Gli or an Altis if had all the goodies.

  3. #3
    Senior PakWheeler Follow
    chinyoti's Avatar
    Join Date
    Sep 2005
    Location
    Karachi
    Age
    27
    Posts
    11,954
    Follows
    5
    Following
    0
    Mentioned
    107 Post(s)
    Tagged
    5 Thread(s)
    Problems Posted
    2
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    1

    Default

    or mayb a ignition coil is short. or if it has a Calm shaft sensor ( distributor sensor) mayb thats faulty but that shud give a check engine light
    Get over the fact that Xli lacks power windows, Its an Xli because it lacks thoose features or else it would be a Gli or an Altis if had all the goodies.

  4. #4
    PakWheeler Follow
    addy's Avatar
    Join Date
    Sep 2005
    Location
    Karachi
    Age
    32
    Posts
    354
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    bro its not a big prob..ur car must be tuned for CNG so if u try to drive it on CNG the rotor will not support.cos the distributor is set for cng..if u wanna drive in oetrol than just go to any mechanic and tell him.he will advance the distributor..and if not than the timing for distributor is set for CNG..
    WhEn tHE CiTy sLeEps.. We rUlE The sTrEeTs

  5. #5
    Senior PakWheeler Follow
    spectra's Avatar
    Join Date
    Jul 2005
    Location
    Islamabad
    Age
    40
    Posts
    19,667
    Follows
    3
    Following
    0
    Mentioned
    304 Post(s)
    Tagged
    24 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    There is no distributor in spectra. It is a faulty fuel pump and thats it.
    Keep a cool head and wear seatbelts!

  6. #6
    Senior PakWheeler Follow
    chinyoti's Avatar
    Join Date
    Sep 2005
    Location
    Karachi
    Age
    27
    Posts
    11,954
    Follows
    5
    Following
    0
    Mentioned
    107 Post(s)
    Tagged
    5 Thread(s)
    Problems Posted
    2
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    1

    Default

    thats wats i meant, there is sensor in distibutor less cars, often CNG people try to give the advancer from it, jiss se advancer to on hotjata hai but the Calm shaft sensor,s wire get cut off. and the RPM fluctuates which isnt noticiable of CNG ( hapend to me in our Baleno) altho the chk lite had come on the CNG guy claimed Baleno aur Santro mei check lite ajati hai. but the fact was cuting of a wrong wire then the advancer was re wired with the maf Sensor
    Get over the fact that Xli lacks power windows, Its an Xli because it lacks thoose features or else it would be a Gli or an Altis if had all the goodies.

  7. #7
    Senior PakWheeler Follow
    imrandahar's Avatar
    Join Date
    Jun 2005
    Location
    Sadiqabad
    Age
    34
    Posts
    1,174
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    hv change fuel pump today but prob not solved stil missing on petrol , new fuel pump hv more pressure thn old one,,still missing ,
    ikd

  8. #8
    Senior PakWheeler Follow
    imrandahar's Avatar
    Join Date
    Jun 2005
    Location
    Sadiqabad
    Age
    34
    Posts
    1,174
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    fuel injector treatment b dala hai tank me but petrol par chalti hee nhi to injector saaf kaise hongy, fuel pump ka grip nikal k direct +current deky cng ko start karta hoo
    ikd

  9. #9
    Senior PakWheeler Follow
    imrandahar's Avatar
    Join Date
    Jun 2005
    Location
    Sadiqabad
    Age
    34
    Posts
    1,174
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    agar sensor kharab hota to cng p bhi na chalti prob ye hai k injector open karke humny check kie buhut hee thora petrol spary kar rahy hain joky gari ko start karne k lie nakafi hai but jab garam hoti hai to full paidal p start hojati hai after3000 ya 4000 rpm par chalti hai jaise hee accelerate kam karo below 4000rpm to band hojati hai ya kabhi backfire karti hai
    ikd

  10. #10
    Senior PakWheeler Follow
    argtr65's Avatar
    Join Date
    Dec 2008
    Age
    51
    Posts
    1,645
    Follows
    1
    Following
    0
    Mentioned
    74 Post(s)
    Tagged
    7 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Get the injector and fuel rail cleaned,it seams that fuel spray pattern has gone disturb.
    Never loose hope in life,every step gives u something.

  11. #11
    PakWheeler Follow
    lzf754's Avatar
    Join Date
    Apr 2009
    Location
    Lahore
    Age
    30
    Posts
    238
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    bhai lambay chakron mai mat paro
    i was in a same problem..
    i got toyota altis.it was gud at cng but missing on petrol
    it was due to i never drive it on petrol for long.just drove when cng finished.so i sugest u in the morning start it direct on petrol.drive it for 5 10 k/m on petrol.inshallah soon ur problem u r facing will be vanished
    and one thing else.if u this problem dont run away then get ur fuel pump cheaked..
    Run your car not your mouth =)

  12. #12
    PakWheeler Follow
    lzf754's Avatar
    Join Date
    Apr 2009
    Location
    Lahore
    Age
    30
    Posts
    238
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    har mechnic apni he dastan sunata haii.
    i guess i have much experience wid the mechenics.
    a few months bak i i swaped 1500cc g15 engine in suzuki alto.i went to a mechnic.gari khud band ho jati the.rpm down hotay thay..us nay mujhe sugest kiya ke race ke wore naye dal do..but masla us kay map sensor mai tha
    aik wire titi hui thee
    itnay achay achay mechinic hotay hain
    Run your car not your mouth =)

  13. #13
    Senior PakWheeler Follow
    imrandahar's Avatar
    Join Date
    Jun 2005
    Location
    Sadiqabad
    Age
    34
    Posts
    1,174
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    problem solved by me dear pakwheelers thnx 4 ur nice comments
    ikd

  14. #14
    Senior PakWheeler Follow
    imrandahar's Avatar
    Join Date
    Jun 2005
    Location
    Sadiqabad
    Age
    34
    Posts
    1,174
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    kisi bhi mechanic ki samajh me nhi aya to mene khud wiring open ki fuel injectors advancer etc carb cleaner use kia har grip me aur prob cam sensor k grip me tha uski two wires apas me short horahi thi tap kardi gari start hogai but idle speed kabhi ziada hoti hai kabhi kam aur kabhi band hojati hai petrol par, i think mene injector cleaner dala hai petrol tank me likha tha ful tank me use karo but meri gari me petrol half se bhi kam tha is lie shayad , kal se me petrol p chalao ga kuch dino k lie
    ikd

  15. #15
    PakWheeler Follow
    lzf754's Avatar
    Join Date
    Apr 2009
    Location
    Lahore
    Age
    30
    Posts
    238
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    congrats
    chalo methae khelao
    Run your car not your mouth =)

  16. #16
    Senior PakWheeler Follow
    imrandahar's Avatar
    Join Date
    Jun 2005
    Location
    Sadiqabad
    Age
    34
    Posts
    1,174
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    same prob start again after a day, yar yaha spectra ko computer par scan hee koi nhi karta kehty hain grip nhi, i think cam sensor change karna pary
    ikd

  17. #17
    Senior PakWheeler Follow
    imrandahar's Avatar
    Join Date
    Jun 2005
    Location
    Sadiqabad
    Age
    34
    Posts
    1,174
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    gari advance retire nhi horahi coz cng p 1000 to 3000rpm tak sahi chalti hai jab race do to pick nhi leti ghut jati hai
    ikd

  18. #18
    Senior PakWheeler Follow
    aref's Avatar
    Join Date
    Mar 2006
    Location
    Select City
    Age
    32
    Posts
    3,929
    Follows
    1
    Following
    0
    Mentioned
    28 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    2
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    dd you check the relays in fuse center if they are working fine?
    Check egr, fuel pump and injector micro relays in the fuse center.
    Every time someone refers to Honda Civic as 'reborn', a puppy dies! Oh and I hate increasing my post count.

  19. #19
    Senior PakWheeler Follow
    imrandahar's Avatar
    Join Date
    Jun 2005
    Location
    Sadiqabad
    Age
    34
    Posts
    1,174
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @aref

    what is egr dear?
    ikd

  20. #20
    Senior PakWheeler Follow
    Proverbial_Slang's Avatar
    Join Date
    May 2005
    Location
    Lahore
    Posts
    3,904
    Follows
    0
    Following
    0
    Mentioned
    29 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Backfire points towards an electronic issue. May be one of the plugs is shorted out or one of the plug wires is faulty.
    Death is not the greatest loss in life. The greatest loss is what dies inside us while we live.

+ Reply to Thread
Page 1 of 2 12 LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •