Survey by Qualaroo
+ Reply to Thread
Results 1 to 4 of 4

Thread: Santro cng to petrol problem

  1. #1
    PakWheeler Follow
    voodoo's Avatar
    Join Date
    Jul 2004
    Location
    Karachi
    Age
    37
    Posts
    667
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Santro cng to petrol problem

    hey all
    i have a santo model 2008 which is done approx 36500km. till yesterday the car was running fine.i drive the car on petrol once a week all day. it used to start on petrol and then automatically convert to cng. but now its not working on petrol anymore. i have to directly start the car on cng. the car on petrol keeps on choking and feels like as if there is not enough fuel comming in it also when on petrol the exaust also smells as if its not burning the fuel properly, while on cng the car is running perfect. my car used to take water from cylincer on both petrol and cng. need help on how to fix the petrol problem.
    Thanks


  2. #2
    PakWheeler Follow
    TotaLOverdosE's Avatar
    Join Date
    Sep 2006
    Location
    Islamabad
    Age
    25
    Posts
    963
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    ^^ Shut of the main CNG cylinder valve completely !
    Then try starting it on petrol, if this works then i guess your problem is pretty obvious
    Never chase a lie. Let it alone, and it will run itself to death - Lyman Beecher

  3. #3
    PakWheeler Follow
    voodoo's Avatar
    Join Date
    Jul 2004
    Location
    Karachi
    Age
    37
    Posts
    667
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    issue has been resolved. the problem was with the pipe connecting the fuel pump which was leaking and therefore was unable to pump with the required pressure.

  4. #4
    Senior PakWheeler Follow
    jaggi's Avatar
    Join Date
    Jan 2009
    Location
    Lahore
    Age
    26
    Posts
    7,324
    Follows
    1
    Following
    0
    Mentioned
    50 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    ^^3years ago I had the same prob in ma santro.

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •