Survey by Qualaroo
+ Reply to Thread
Results 1 to 7 of 7

Thread: Santro - Cam Sensor

  1. #1
    a_k
    a_k is offline
    Senior PakWheeler Follow
    a_k's Avatar
    Join Date
    Feb 2005
    Location
    Karachi
    Age
    39
    Posts
    2,015
    Follows
    0
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Exclamation Santro - Cam Sensor

    My Santro, 2003 got problem, it was running fine I parked it in my home and next morning when tried to start, engine was like missing, initially mechanic diagnosed it as faulty injector, later on scanning found out to be Cam Sensor ! Replaced & running fine, <?xml:namespace prefix = o ns = "urn:schemas-microsoft-comfficeffice" /><o:p></o:p>
    <o:p></o:p>
    My question is how the hell check engine light never warned me, even when the mechanic was checking it was functioning normally??!?!?<o:p></o:p>
    <o:p></o:p>
    Should I get wiring checked? or what else could be the problem?<o:p></o:p>
    <o:p></o:p>
    How many more sensor(s) are not linked to check engine light?<o:p></o:p>
    <o:p></o:p>
    Thanx in advance<o:p></o:p>

    If better were within, better would come out.

  2. #2
    a_k
    a_k is offline
    Senior PakWheeler Follow
    a_k's Avatar
    Join Date
    Feb 2005
    Location
    Karachi
    Age
    39
    Posts
    2,015
    Follows
    0
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    hello
    If better were within, better would come out.

  3. #3
    Senior PakWheeler Follow
    osama96's Avatar
    Join Date
    Jun 2008
    Location
    Riyadh
    Age
    26
    Posts
    2,659
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Engine light only indicate low level of engine oil it has nothing to do with cam sensor
    Beshak ALLAH he sy hy sub waqt sy pehly nahin zarorat sy zada nahin.

  4. #4
    Senior PakWheeler Follow
    vagabondpiper's Avatar
    Join Date
    Jun 2010
    Location
    Islamabad
    Age
    34
    Posts
    1,328
    Follows
    1
    Following
    0
    Mentioned
    23 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    r u sure that check light is serviceable? does it illuminate during lamp test?( that is when u give the ignition for starting and all dash lights come on)
    No one cares for Toyota more then Toyota

  5. #5
    a_k
    a_k is offline
    Senior PakWheeler Follow
    a_k's Avatar
    Join Date
    Feb 2005
    Location
    Karachi
    Age
    39
    Posts
    2,015
    Follows
    0
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    check engine indicator is there to lit up if there is any problem which is connected to ECU via sensor, (my limited knowledge), when we switch ignition on it turn on and after few seconds it turn off, it mean that every thing is fine,
    now in my above case check light functions as normal , question is why?
    If better were within, better would come out.

  6. #6
    Senior PakWheeler Follow
    VCheng's Avatar
    Join Date
    May 2010
    Location
    Select City
    Posts
    25,478
    Follows
    7
    Following
    1
    Mentioned
    434 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    0

    Default

    The paramters for setting the MIL to ON may not have been met as defined by the manufacturer.

  7. #7
    PakWheeler Follow
    tauxeef's Avatar
    Join Date
    Jun 2010
    Location
    Dubai
    Age
    28
    Posts
    901
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by a_k View Post
    check engine indicator is there to lit up if there is any problem which is connected to ECU via sensor, (my limited knowledge), when we switch ignition on it turn on and after few seconds it turn off, it mean that every thing is fine,
    now in my above case check light functions as normal , question is why?
    u r rit
    a programmer, webmaster, electronics enthusiast, traveller, adventurer, gizmo's freak by hobby & an electrical engineer by profession tauxeef.com

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •