Survey by Qualaroo
+ Reply to Thread
Results 1 to 12 of 12
Like Tree4Likes
  • 1 Post By oxairshahid
  • 3 Post By Storm

Thread: Santro Drive goes off, Pressing clutch fixes it

  1. #1
    PakWheeler Follow
    oxairshahid's Avatar
    Join Date
    Sep 2010
    Location
    Lahore
    Age
    31
    Posts
    10
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Santro Drive goes off, Pressing clutch fixes it

    hey I have a 2003 Santro on petrol and recently an issue has started arising. While driving suddenly the drive goes off. Engine remains on but no matter how you press the accelerator the drive doesn't comeback. The only way in doing that is to press the clutch and release then the drive returns but pressing the accelerator after few moments again it happens. I have got it checked by number of mechanics but no solution. Some say the it is a sensor issue and i got that replaced 3 times now. After replacement it works fine for few days but then again it resumes.

    Another observation is that when you start the car and press it a contact RPM, few seconds into it, it starts missing. I guess it is something to do with the fuel/air mixture or something like that but am not sure. This normally happens in the morning but then again its random. Yesterday it happened at night and also the engine was hot enough since the car had been running for almost 25KMs. I fail to understand what the issue might be. Someone please guide me or refer me to a good mechanic who knows this issue and can resolve it here in Lahore.

    Thanks
    Uzair Shahid
    03214366093


  2. #2
    Senior PakWheeler Follow
    onlyfaith's Avatar
    Join Date
    Sep 2010
    Location
    Islamabad
    Posts
    5,934
    Follows
    3
    Following
    1
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    clean your fuel injectors..
    top documentaries " Tears of Gaza"

  3. #3
    PakWheeler Follow
    oxairshahid's Avatar
    Join Date
    Sep 2010
    Location
    Lahore
    Age
    31
    Posts
    10
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Thanks will get that done. Someone was telling me that it may be the fuel pump not pumping enough fuel..could that be the case?

  4. #4
    PakWheeler Follow
    cristy's Avatar
    Join Date
    Jul 2011
    Location
    Rawalpindi
    Posts
    213
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    yes it can be.. but firstly clean ur injector and get da ecu checked it myt hav an error

  5. #5
    PakWheeler Follow
    oxairshahid's Avatar
    Join Date
    Sep 2010
    Location
    Lahore
    Age
    31
    Posts
    10
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Thanks alot. I'll get that checked and report back with the update

  6. #6
    PakWheeler Follow
    oxairshahid's Avatar
    Join Date
    Sep 2010
    Location
    Lahore
    Age
    31
    Posts
    10
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    btw how long is the process of getting the injectors cleaned and what will be the approximate charges for it. I need to plan my budget and time

  7. #7
    Senior PakWheeler Follow
    Storm's Avatar
    Join Date
    Feb 2005
    Location
    Select City
    Posts
    40,235
    Follows
    9
    Following
    0
    Mentioned
    48 Post(s)
    Tagged
    5 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    when my accord did this i tried everything and it turned out the fuel pump in the tank was faulty. the filter had blocked really badly in the tank and the pump wasn't running right.

    after replacing the pump and filter the car was back to 100%.
    1. A car is only worth what someone is willing to pay for it, 2. Resale wont save your life in an accident, 3. Genius has limits, stupidity has none, 4. Never argue with an idiot, they will bring you down to their level & beat you with experience, 5. Growing old beats the alternative -- dying young! 6. انّا للہ و انّا الیہ راجعون

  8. #8
    PakWheeler Follow
    oxairshahid's Avatar
    Join Date
    Sep 2010
    Location
    Lahore
    Age
    31
    Posts
    10
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    hmm..Has any of the santro owners in this forum faced this issue? Also can someone recommend me a good mechanic in Lahore somewhere in the modeltown, gulberg, faisal town area..

  9. #9
    jz
    jz is offline
    Senior PakWheeler Follow
    jz's Avatar
    Join Date
    Dec 2004
    Location
    Lahore
    Age
    2
    Posts
    26,106
    Follows
    5
    Following
    0
    Mentioned
    185 Post(s)
    Tagged
    12 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    how about to visit the hyundai workshop,as there the santro experts,im sure some one ther will be able to help you out
    www.facebook.com/performancepartslahore

  10. #10
    PakWheeler Follow
    oxairshahid's Avatar
    Join Date
    Sep 2010
    Location
    Lahore
    Age
    31
    Posts
    10
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    yeah well i am not actually a fan of hyundai workshops but since this problem has not been diagnosed by any of the mechanics...i guess that is my last resort. Any experience with the Township dealership? are they good at what they do? recommendations needed please.

  11. #11
    jz
    jz is offline
    Senior PakWheeler Follow
    jz's Avatar
    Join Date
    Dec 2004
    Location
    Lahore
    Age
    2
    Posts
    26,106
    Follows
    5
    Following
    0
    Mentioned
    185 Post(s)
    Tagged
    12 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by oxairshahid View Post
    yeah well i am not actually a fan of hyundai workshops but since this problem has not been diagnosed by any of the mechanics...i guess that is my last resort. Any experience with the Township dealership? are they good at what they do? recommendations needed please.
    dont have personal experience to be honest but ive heard there okay
    www.facebook.com/performancepartslahore

  12. #12
    PakWheeler Follow
    ali_k's Avatar
    Join Date
    Feb 2008
    Location
    Lahore
    Age
    30
    Posts
    10
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by oxairshahid View Post
    yeah well i am not actually a fan of hyundai workshops but since this problem has not been diagnosed by any of the mechanics...i guess that is my last resort. Any experience with the Township dealership? are they good at what they do? recommendations needed please.

    I also have the same problem with my santro. went to hyundai township motors. they said the problem is due to a fault in fuel pump and so i changed it, but the problem persists. all the sensors are also working fine (as checked by hyundai workshop). So i also cant figure out what the problem is...did u find any solution

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •