Survey by Qualaroo
+ Reply to Thread
Page 2 of 2 FirstFirst 12
Results 21 to 27 of 27
Like Tree2Likes

Thread: Santro Plus Not Going above 100km/h After Engine Overhaul

  1. #1
    PakWheeler Follow
    ZondaF's Avatar
    Join Date
    Feb 2011
    Location
    Lahore
    Posts
    481
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Santro Plus Not Going above 100km/h After Engine Overhaul

    Dear Pakwheelers
    I have recently overhauled my Santro plus 2001 engine with the best quality parts available in the market. The reason for overhaul was due to the weak piston and rings condition, oil was rigging out of the ring seal so it was necessary to do the overhaul. I spend 30k + on the overhaul and overhauling was done by a Santro expert mechanic. Before the overhaul the car was running fine on petrol and it could easily go above 120km/h with AC, but on CNG it was having Santro's generic backfire problem.

    Now after completing the initial running of 3000 km on Petrol. Whenever I try to take the car above 100 km/h it just stays there and nothing happens. Initially i thought the problem is with the CNG settings, but the problem is same with the petrol also. Accerelation is fine, but whenever the speedometer touches 95km/h to 100km/h, the car does not take more speed, no matter how hard you try. I have also checked the fuel pump, plugs, cables and done the tapet cover adjustment but the problem is still there. Kindly tell me what is the problem and how to resolve it ? My mechanic has even replaced the ECU with another Santro's ECU but the problem couldnt be resolved. Please help me.

    Regards

  2. #21
    Senior PakWheeler Follow
    rizkhan2010's Avatar
    Join Date
    Oct 2011
    Location
    Islamabad
    Age
    37
    Posts
    1,858
    Follows
    0
    Following
    0
    Mentioned
    20 Post(s)
    Tagged
    7 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    correction:...@Xulfiqar bhai he said "check engine light is not on".

  3. #22
    Senior PakWheeler Follow
    Vaqas1's Avatar
    Join Date
    Nov 2004
    Location
    Islamabad
    Posts
    5,267
    Follows
    6
    Following
    1
    Mentioned
    49 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    2

    Default

    This happend with me as well. I found the local rebuild of engines stops oil burning and all other issues but some how the power and economy is lost. In my Charade i remember it was doing so well plus very economical as soon as new head and ring job no more power and no more economy. Same with 2E. Even I saw a XLI with rebuilt engine and that car was hardly giving any torque.

    Hmm thats why these qabli or 2nd hand engines people say are better..
    Speed costs money, how fast can you afford to go.

  4. #23
    PakWheeler Follow
    ZondaF's Avatar
    Join Date
    Feb 2011
    Location
    Lahore
    Posts
    481
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by rizkhan2010 View Post
    correction:...@Xulfiqar bhai he said "check engine light is not on".
    You are right. My car engine checklight is not ON.

  5. #24
    PakWheeler Follow
    ZondaF's Avatar
    Join Date
    Feb 2011
    Location
    Lahore
    Posts
    481
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Vaqas1 View Post
    This happend with me as well. I found the local rebuild of engines stops oil burning and all other issues but some how the power and economy is lost. In my Charade i remember it was doing so well plus very economical as soon as new head and ring job no more power and no more economy. Same with 2E. Even I saw a XLI with rebuilt engine and that car was hardly giving any torque.

    Hmm thats why these qabli or 2nd hand engines people say are better..
    You are trying to say that the speed loss is because the engine overhauling has not been done properly. If thats the case, where is the fault. I means what part needs to be replaced again in the engine. The torque and accerelation is fine after the overhaul of my engine.

  6. #25
    Senior PakWheeler Follow
    immad100's Avatar
    Join Date
    Aug 2010
    Location
    Lahore
    Posts
    5,503
    Follows
    1
    Following
    0
    Mentioned
    26 Post(s)
    Tagged
    8 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    ^^did you check the clutch plate?
    ''Peace is an unstable equilibrium,that can only be preserved by acknowledged supremacy and...equal power.'' ''We give up the fort when there is not a man left to defend it.''

  7. #26
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,405
    Follows
    131
    Following
    0
    Mentioned
    3991 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    new built engine losing power is very strange unless the engine was machined and assembled by people who dont know what they are doing, e.g. if the head was faced too much the timing can go out of sync and also cause CR to change. But that still wont cause the engine to lose torque.

    Best bet would be to check compression and oil pressure with engine at working temperature.
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  8. #27
    PakWheeler Follow
    ZondaF's Avatar
    Join Date
    Feb 2011
    Location
    Lahore
    Posts
    481
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by immad100 View Post
    ^^did you check the clutch plate?
    The pressure plate and clutch plate was also replaced with the engine overhaul.

  9. 10-09-2012, 12:25 PM

    Site Banned

    Reason
    spam

+ Reply to Thread
Page 2 of 2 FirstFirst 12

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •