Survey by Qualaroo
+ Reply to Thread
Page 171 of 208 FirstFirst ... 71121161169170171172173181 ... LastLast
Results 3,401 to 3,420 of 4148
Like Tree761Likes

Thread: Self Tunning - Khyber G-10 (Plugs, valve clearance, spark gap etc)

  1. #1
    Senior PakWheeler Follow
    smijaz's Avatar
    Join Date
    Feb 2010
    Location
    Lahore
    Age
    36
    Posts
    1,100
    Follows
    1
    Following
    0
    Mentioned
    60 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Self Tuning - Khyber G-10 (Plugs, valve clearance, spark gap etc)

    Salam

    dear members/experts

    I own a khyber 1996. Recently overhauled its engine completely at home by myself except the mechanist part. It has its first oil change at 1100Km yesterday and i am planning to tune it. I have following query for the learned members/experts

    Q.1. recommended spark plugs for khyber g-10 on CNG
    Q.2. Recommended spark plug gap?
    Q.3. Recommended tappet setting Hot/cold?
    Q.4. Running was on petrol with Caltex Havoline formula and now i have switched to CNG with Shell helix HX7 10-40W (synthetic) , is shell HX7 ok?

    What else should i do or check to get max output and efficiency from my g-10?

    regards


    after-note: In addition to the above queries, this thread also contains info on carburetor, AC, electrical, cooling system, brakes & gear issues related to khyber G-10.

    Special thanks to following experts :
    Xulfiqar, Fas133, Margallar, Ahsanzs, wasay_Ahmad, Xplorer, jz, Daniyal
    for their valuable contributions and last but not least
    I am greatful to Cracked for keeping this thread alive by
    raising all the queries/question.


  2. #3401
    Senior PakWheeler Follow
    margallar's Avatar
    Join Date
    Oct 2009
    Location
    Lahore
    Posts
    9,958
    Follows
    6
    Following
    2
    Mentioned
    283 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    maybe the dashpot isn't holding the throttle long enough
    haters gonna hate, potatoes gonna potate

  3. #3402
    Senior PakWheeler Follow
    DUDE007's Avatar
    Join Date
    Oct 2011
    Location
    Lahore
    Posts
    2,033
    Follows
    0
    Following
    2
    Mentioned
    104 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I set dashpot and it holds throttle for about for a second or 2

  4. #3403
    Senior PakWheeler Follow
    smijaz's Avatar
    Join Date
    Feb 2010
    Location
    Lahore
    Age
    36
    Posts
    1,100
    Follows
    1
    Following
    0
    Mentioned
    60 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by DUDE007 View Post
    @smijaz it feels like engine is choking though I'm not 100% sure but lets say that it is.
    In that case it is power piston not working properly or plunger isn't injecting fuel to accommodate gap between throttle plate opening and primary venturi taking control of providing emulsified fuel

  5. #3404
    Senior PakWheeler Follow
    DUDE007's Avatar
    Join Date
    Oct 2011
    Location
    Lahore
    Posts
    2,033
    Follows
    0
    Following
    2
    Mentioned
    104 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Oh yes....now that i think about it, its plunger because there is a dead spot on sudden acceleration....the gap as you said....

  6. #3405
    Senior PakWheeler Follow
    smijaz's Avatar
    Join Date
    Feb 2010
    Location
    Lahore
    Age
    36
    Posts
    1,100
    Follows
    1
    Following
    0
    Mentioned
    60 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by axe.effect View Post
    Can we fit 145/70 r12 tires in these 12 inch aftermarket alloy rims?.

    How much width (inches) is the standard steel rim?.

    Please suggest some good tires for above size.
    I think but not sure standard is 4 inches and this one is about 5" .
    145/70 will look very odd on this set

  7. #3406
    Senior PakWheeler Follow
    margallar's Avatar
    Join Date
    Oct 2009
    Location
    Lahore
    Posts
    9,958
    Follows
    6
    Following
    2
    Mentioned
    283 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    did you check the accelerator pump?
    haters gonna hate, potatoes gonna potate

  8. #3407
    Senior PakWheeler Follow
    DUDE007's Avatar
    Join Date
    Oct 2011
    Location
    Lahore
    Posts
    2,033
    Follows
    0
    Following
    2
    Mentioned
    104 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    You mean the plunger?

  9. #3408
    Senior PakWheeler Follow
    margallar's Avatar
    Join Date
    Oct 2009
    Location
    Lahore
    Posts
    9,958
    Follows
    6
    Following
    2
    Mentioned
    283 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    nope, a nozzle type thing, that SPRAYS petrol in the throat, it works when you give sudden throttle,a jet of fuel should be visible if you look in the throat and pull the accelerator cable with a jerk.

    that is supposed to prevent hesitation on sudden acceleration.
    haters gonna hate, potatoes gonna potate

  10. #3409
    Senior PakWheeler Follow
    axe.effect's Avatar
    Join Date
    Aug 2014
    Posts
    1,054
    Follows
    2
    Following
    0
    Mentioned
    63 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    This non original piece was very much faded, so i removed for replacement. I want to improve brightness. Its interesting to see no reflectors inside.

    1- Rs. 125 chrome or silver paint in the black area will be helpful?. I saw aluminium foil in previous pages by @Sherazi but i dont want to put that.

    2- how to clean the previous silicone easily?. Its too hard.
    Attached Images Attached Images  

  11. #3410
    Senior PakWheeler Follow
    DUDE007's Avatar
    Join Date
    Oct 2011
    Location
    Lahore
    Posts
    2,033
    Follows
    0
    Following
    2
    Mentioned
    104 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Yes the chrome/silver spray paint will be very helpful as it increases reflection of light and make lights brighter.
    For the hard silicone see if you can scrape it off from edges using small flat head screw driver or tester. Be careful not to damage the plastic.
    Another option is to use a small sharp knife and scrape it.

  12. #3411
    Senior PakWheeler Follow
    speedster_101's Avatar
    Join Date
    Sep 2005
    Location
    Islamabad
    Posts
    3,447
    Follows
    2
    Following
    0
    Mentioned
    54 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    0

    Default

    Quote Originally Posted by axe.effect View Post
    This non original piece was very much faded, so i removed for replacement. I want to improve brightness. Its interesting to see no reflectors inside.

    1- 125 rs chrome or silver paint in the black area will be helpful?. I saw aluminium foil in previous pages by @Sherazi but i dont want to put that.

    2- how to clean the previous silicone easily?. Its too hard.
    My Khyber tail lights were also faded so I replaced them. Bought MALTA tail lights from Waseen Autos Saddar RWP for Rs. 1300/- As the CNG cylinder is removed nowadays, it was easy to install them. Applied silicon on all the outer sides after that.
    "The more we sweat in peace, the less we bleed in war"

  13. #3412
    Senior PakWheeler Follow
    speedster_101's Avatar
    Join Date
    Sep 2005
    Location
    Islamabad
    Posts
    3,447
    Follows
    2
    Following
    0
    Mentioned
    54 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    0

    Default

    Quote Originally Posted by DUDE007 View Post
    What are the reasons for a bad start from a complete stop? The car shakes if i give a little less acceleration and shakes a bit when put in the next gear. The ignition system has been sorted out (new wires, plugs, coil, relay except timing and advance). Tappets were set to spec. Do i need to adjust clutch cable?
    The mixture seems ok because plug are rusty.
    I am having the exact same issue in my car. Also when I accelerate it suddenly, it gives a big jerk.
    "The more we sweat in peace, the less we bleed in war"

  14. #3413
    Senior PakWheeler Follow
    axe.effect's Avatar
    Join Date
    Aug 2014
    Posts
    1,054
    Follows
    2
    Following
    0
    Mentioned
    63 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Updated

    This is sample after cleaning. I purchased chrome spray (rs. 250)that will be used for reflectors.

    There is some translucent type glass too which spreads light, which maybe missing in most khybers.

    Picture 1 is red glass and translucent glass.

    Picture 2 is only red glass with no translucent glass.

    Picture 3 is with translucent glass only.

    Picture 4 is with both glasses.

    @DUDE007
    Info updated.

    @speedster_101
    Did malta lights had this type of translucent glass to spread light?.
    Attached Images Attached Images     

  15. #3414
    Senior PakWheeler Follow
    axe.effect's Avatar
    Join Date
    Aug 2014
    Posts
    1,054
    Follows
    2
    Following
    0
    Mentioned
    63 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Due to tints, rear visibility was very low in dark, so added LEDs in licence plates. Great results.

    No alteration required, though most LEDs require wiring alterations.

    The same type LEDs are working great in my other cars for more than 6 months.
    Attached Images Attached Images  

  16. #3415
    Senior PakWheeler Follow
    saboor73's Avatar
    Join Date
    Oct 2013
    Location
    Karachi
    Posts
    10,553
    Follows
    25
    Following
    0
    Mentioned
    351 Post(s)
    Tagged
    14 Thread(s)
    Problems Posted
    0
    Problems Solved
    6
    Best Answers
    2
    Good Answers
    25

    Default

    Quote Originally Posted by speedster_101 View Post
    I am having the exact same issue in my car. Also when I accelerate it suddenly, it gives a big jerk.
    it look like a faulty engine mount

  17. #3416
    Senior PakWheeler Follow
    speedster_101's Avatar
    Join Date
    Sep 2005
    Location
    Islamabad
    Posts
    3,447
    Follows
    2
    Following
    0
    Mentioned
    54 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    0

    Default

    Quote Originally Posted by axe.effect View Post

    @speedster_101
    Did malta lights had this type of translucent glass to spread light?.
    I did not open the light. The complete unit was installed. MALTA is OEM for Pak Suzuki, I think it has this traslucent glass.
    "The more we sweat in peace, the less we bleed in war"

  18. #3417
    Senior PakWheeler Follow
    speedster_101's Avatar
    Join Date
    Sep 2005
    Location
    Islamabad
    Posts
    3,447
    Follows
    2
    Following
    0
    Mentioned
    54 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    0

    Default

    Quote Originally Posted by saboor73 View Post
    it look like a faulty engine mount
    To me it seems like a carburetor issue but I will get the mounts checked this weekend.
    "The more we sweat in peace, the less we bleed in war"

  19. #3418
    Senior PakWheeler Follow
    margallar's Avatar
    Join Date
    Oct 2009
    Location
    Lahore
    Posts
    9,958
    Follows
    6
    Following
    2
    Mentioned
    283 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by speedster_101 View Post
    To me it seems like a carburetor issue but I will get the mounts checked this weekend.
    i also think its the carburetor. spray carb cleaner into the bowl and pull the cable with a jerking action/jhatka. this should pull the carb cleaner into the accelerator pump passages. try some carb cleaner fuel additive too
    haters gonna hate, potatoes gonna potate

  20. #3419
    Senior PakWheeler Follow
    speedster_101's Avatar
    Join Date
    Sep 2005
    Location
    Islamabad
    Posts
    3,447
    Follows
    2
    Following
    0
    Mentioned
    54 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    0

    Default

    Quote Originally Posted by margallar View Post
    i also think its the carburetor. spray carb cleaner into the bowl and pull the cable with a jerking action/jhatka. this should pull the carb cleaner into the accelerator pump passages. try some carb cleaner fuel additive too
    Will check that.
    Any recommended brands for carb cleaner and fuel additive?
    "The more we sweat in peace, the less we bleed in war"

  21. #3420
    PakWheeler Follow
    tucknoloji's Avatar
    Join Date
    Jan 2010
    Location
    Lahore
    Age
    35
    Posts
    572
    Follows
    3
    Following
    1
    Mentioned
    22 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by speedster_101 View Post
    Will check that.
    Any recommended brands for carb cleaner and fuel additive?
    NASA

    Sent from Mars

+ Reply to Thread

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •