Survey by Qualaroo
+ Reply to Thread
Page 98 of 208 FirstFirst ... 488896979899100108148198 ... LastLast
Results 1,941 to 1,960 of 4148
Like Tree761Likes

Thread: Self Tunning - Khyber G-10 (Plugs, valve clearance, spark gap etc)

  1. #1
    Senior PakWheeler Follow
    smijaz's Avatar
    Join Date
    Feb 2010
    Location
    Lahore
    Age
    36
    Posts
    1,100
    Follows
    1
    Following
    0
    Mentioned
    60 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Self Tuning - Khyber G-10 (Plugs, valve clearance, spark gap etc)

    Salam

    dear members/experts

    I own a khyber 1996. Recently overhauled its engine completely at home by myself except the mechanist part. It has its first oil change at 1100Km yesterday and i am planning to tune it. I have following query for the learned members/experts

    Q.1. recommended spark plugs for khyber g-10 on CNG
    Q.2. Recommended spark plug gap?
    Q.3. Recommended tappet setting Hot/cold?
    Q.4. Running was on petrol with Caltex Havoline formula and now i have switched to CNG with Shell helix HX7 10-40W (synthetic) , is shell HX7 ok?

    What else should i do or check to get max output and efficiency from my g-10?

    regards


    after-note: In addition to the above queries, this thread also contains info on carburetor, AC, electrical, cooling system, brakes & gear issues related to khyber G-10.

    Special thanks to following experts :
    Xulfiqar, Fas133, Margallar, Ahsanzs, wasay_Ahmad, Xplorer, jz, Daniyal
    for their valuable contributions and last but not least
    I am greatful to Cracked for keeping this thread alive by
    raising all the queries/question.


  2. #1941
    Senior PakWheeler Follow
    speedster_101's Avatar
    Join Date
    Sep 2005
    Location
    Islamabad
    Posts
    3,447
    Follows
    2
    Following
    0
    Mentioned
    54 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    0

    Default

    Quote Originally Posted by Xulfiqar View Post
    remove the thermostat valve and check in hot water with thermometer.
    Thanks for replying. Before installation I put it in boiling water and it opened up, and when I put it out of water it was closed after a while, but I didn't check it with a thermometer. Is it possible that both the thermostats are faulty?
    "The more we sweat in peace, the less we bleed in war"

  3. #1942
    PakWheeler Follow
    fas133's Avatar
    Join Date
    Jun 2010
    Location
    Lahore
    Age
    39
    Posts
    177
    Follows
    0
    Following
    0
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @speedster_101

    Also please check the thermostat switch which is responsible for turning on/off the cooling fan.
    Thermostat Valve Specs: Starts to Open @ 82 C, Fully Open @ 95 C
    Thermostat Switch Specs: Conducts @ 86--90 C, Switch Open @ 81--85 C

    Attached Images Attached Images  

  4. #1943
    PakWheeler Follow
    acmaatif's Avatar
    Join Date
    Jan 2014
    Location
    Gujrat
    Age
    37
    Posts
    13
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Khyber carburetor issue

    aoa
    i hv khyber 98 model. it emits black smoke on petrol on CNG its working normally. when vehicle picks speed smoke disappeared. also on petrol very bad average of 5 KM/L in city. hv replaced carburetor kit but not hv change in its condition. someone advice plz

  5. #1944
    Senior PakWheeler Follow
    speedster_101's Avatar
    Join Date
    Sep 2005
    Location
    Islamabad
    Posts
    3,447
    Follows
    2
    Following
    0
    Mentioned
    54 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    0

    Default Issue Resolved

    After half an hour drive I was just checking the water pipes in my Khyber's engine bay when I found out that the rubber pipe which takes water to heater matrix (in dash) was hot while the return pipe was cold, which means that due to some blockage in heater matrix the hot water was not being circulated. That is why the heater was not giving hot air.

    Went to A/C workshop and the guy there told me that whole dashboard needs to be removed in order to take heater matrix out. I use to get my car's A/Cs serviced from this guy, he knows his work and is quite reasonable in prices as well. He removed the dash, took the heater matrix to radiator service shop. It was good in condition (not rusted) but was blocked.

    Installed it back after service and now Alhamdulillah the heater working is superb.
    The blower speed was low so I also got a rely installed with it. Last year I wanted to install a rely with blower but the car was not switching off after the ignition being turned off. The blower needed to be switched off first to switch off the car, so I did not install it, but yesterday he has installed a rely with a component "Electrofier" (as being called by these ustaads) and now the blower is also working great without any issue. The car switches off regardless of heater on or off.

    However the most interesting and weird thing is that after the heater work, the problem of engine running cold is also resolved. Although it should be the other way round i.e if the heater is throwing good amount of heat, the engine temperature should come down but in my case, the temperature has gone to optimum/ normal level now.

    Self Tunning  Khyber G10 Plugs valve clearance spark gap etc -1335717

    Self Tunning  Khyber G10 Plugs valve clearance spark gap etc -1335718

    Self Tunning  Khyber G10 Plugs valve clearance spark gap etc -1335719
    "The more we sweat in peace, the less we bleed in war"

  6. #1945
    PakWheeler Follow
    acmaatif's Avatar
    Join Date
    Jan 2014
    Location
    Gujrat
    Age
    37
    Posts
    13
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    my khyber 98 emits black smoke plus giving very bad avg on petrol. its ok on cng no smoke. i hv already changed the carburetor kit but not solved any problem. its whole engine is overhauled

  7. #1946
    Senior PakWheeler Follow
    metalhead's Avatar
    Join Date
    Oct 2006
    Location
    Wah cantt
    Posts
    1,307
    Follows
    1
    Following
    1
    Mentioned
    49 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    black smoke is usually more fuel than required. You must be having black powdery soot on the silencer lip. Try mixture setting on the carb. if rest is checked...

  8. #1947
    Senior PakWheeler Follow
    MoizIrfan's Avatar
    Join Date
    Dec 2007
    Location
    Dubai
    Age
    26
    Posts
    1,960
    Follows
    1
    Following
    1
    Mentioned
    106 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Great to see your issue resolved.
    I just did my khyber head work now bought a brand new thermostat valve 82 degree. And serviced the radiator aluminium one. Now want to install thermostat valve. Suggest me a good reasonably priced coolant. My fan is direct also

  9. #1948
    PakWheeler Follow
    acmaatif's Avatar
    Join Date
    Jan 2014
    Location
    Gujrat
    Age
    37
    Posts
    13
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    thanx metalhead... yes mechanic told that it is due to more fuel consumption than required and slincer lip is also black powder....i hv changed the whole kit of carburetor including mixture and also setting of mixture have been done but issue not resolved. is this can also be due to bad vaccum pipes installation? if yes then what are the correct vaccum pipe installations. can u send me the picture of them?

  10. #1949
    Senior PakWheeler Follow
    metalhead's Avatar
    Join Date
    Oct 2006
    Location
    Wah cantt
    Posts
    1,307
    Follows
    1
    Following
    1
    Mentioned
    49 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by acmaatif View Post
    thanx metalhead... yes mechanic told that it is due to more fuel consumption than required and slincer lip is also black powder....i hv changed the whole kit of carburetor including mixture and also setting of mixture have been done but issue not resolved. is this can also be due to bad vaccum pipes installation? if yes then what are the correct vaccum pipe installations. can u send me the picture of them?
    your problem is of rich mixture. solve it first. the vacuum pipes are for timing advance, ac idle-up, slow return of throttle, etc.

  11. #1950
    PakWheeler Follow
    acmaatif's Avatar
    Join Date
    Jan 2014
    Location
    Gujrat
    Age
    37
    Posts
    13
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    thnx..... can i setup the mixture myself? if yes then how? coz i m in gujrat and its hard to have good mechanic here

  12. #1951
    Senior PakWheeler Follow
    speedster_101's Avatar
    Join Date
    Sep 2005
    Location
    Islamabad
    Posts
    3,447
    Follows
    2
    Following
    0
    Mentioned
    54 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    0

    Default

    After searching a lot, found genuine radiator cap of Suzuki Khyber for 750 Rs.
    Also poured in 2L Guard coolant along with 50% water.

    Self Tunning  Khyber G10 Plugs valve clearance spark gap etc -1337085

    Self Tunning  Khyber G10 Plugs valve clearance spark gap etc -1337086
    "The more we sweat in peace, the less we bleed in war"

  13. #1952
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,405
    Follows
    131
    Following
    0
    Mentioned
    3991 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    SNA also made good radiator caps - cheap too.

    At one time there was a shop in Plaza Karachi, selling 0.9 bar pressure radiator caps made by Hitachi - they were really high quality, their rubber almost never went hard.
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  14. #1953
    Senior PakWheeler Follow
    speedster_101's Avatar
    Join Date
    Sep 2005
    Location
    Islamabad
    Posts
    3,447
    Follows
    2
    Following
    0
    Mentioned
    54 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    0

    Default

    Quote Originally Posted by Xulfiqar View Post
    SNA also made good radiator caps - cheap too.

    At one time there was a shop in Plaza Karachi, selling 0.9 bar pressure radiator caps made by Hitachi - they were really high quality, their rubber almost never went hard.
    If I am not wrong SNA caps are made in Pakistan. I bought one last year for 125 Rs. It did not suck water from reservoir bottle although there were no leaks in pipe, so I did not use it.
    "The more we sweat in peace, the less we bleed in war"

  15. #1954
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,405
    Follows
    131
    Following
    0
    Mentioned
    3991 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    yep - they are made in Pakistan, I never had issues with them. The only problems I heard with them were people using the wrong style caps on the wrong radiators.

    But please note its been a long time for me.
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  16. #1955
    PakWheeler Follow
    zaeem9236's Avatar
    Join Date
    Apr 2012
    Location
    Islamabad
    Posts
    124
    Follows
    1
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    picture 1

    Self Tunning  Khyber G10 Plugs valve clearance spark gap etc -1338225

  17. #1956
    PakWheeler Follow
    zaeem9236's Avatar
    Join Date
    Apr 2012
    Location
    Islamabad
    Posts
    124
    Follows
    1
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    picture 2

    Self Tunning  Khyber G10 Plugs valve clearance spark gap etc -1338226

  18. #1957
    PakWheeler Follow
    zaeem9236's Avatar
    Join Date
    Apr 2012
    Location
    Islamabad
    Posts
    124
    Follows
    1
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    any 1?????????

  19. #1958
    Senior PakWheeler Follow
    nfssaad's Avatar
    Join Date
    Oct 2006
    Location
    Karachi
    Age
    29
    Posts
    3,179
    Follows
    0
    Following
    1
    Mentioned
    50 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i would say replace the guard coolant with caltex or fuchs after you have removed all leaks
    the problem is not our govt... its the people..

  20. #1959
    Senior PakWheeler Follow
    speedster_101's Avatar
    Join Date
    Sep 2005
    Location
    Islamabad
    Posts
    3,447
    Follows
    2
    Following
    0
    Mentioned
    54 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    0

    Default

    Quote Originally Posted by nfssaad View Post
    i would say replace the guard coolant with caltex or fuchs after you have removed all leaks
    Guard coolant is just for the time being. Approximately one glass of water is lost every week from my car's cooling system. I am trying to catch the leak. Once I catch it, I will pour a good quality coolant after flushing the radiator. Due to red colour of Guard coolant, today I have found one minute leak where a rubber pipe connects the metal pipe and have placed a clamp over there. Lets see it resolves the issue or not.
    "The more we sweat in peace, the less we bleed in war"

  21. #1960
    Senior PakWheeler Follow
    metalhead's Avatar
    Join Date
    Oct 2006
    Location
    Wah cantt
    Posts
    1,307
    Follows
    1
    Following
    1
    Mentioned
    49 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by zaeem9236 View Post
    picture 2


    Self Tunning  Khyber G10 Plugs valve clearance spark gap etc -1338226
    I think you havent googled for it. Here is the installation manual for STAP 00B:
    http://www.landirenzo.com.br/pt/lib/...6acd79ee75.pdf

    Usually the multiple wires with same colors are just duplicate for ease of installation. e.g. you want to connect a line at 2 points... wouldnt it be better to already have two wires?

+ Reply to Thread

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •