Survey by Qualaroo
+ Reply to Thread
Results 1 to 15 of 15
Like Tree3Likes
  • 2 Post By shereabdullah
  • 1 Post By cooldevil

Thread: Strange Problem with Khyber AC

  1. #1
    PakWheeler Follow
    muddasir5022's Avatar
    Join Date
    Jan 2013
    Posts
    30
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Unhappy Strange Problem with Khyber AC

    salam to all Pak wheelers ,

    I have a strange problem with khyber AC , Although it is working fine and cooling is very good also , But often the Car heat gauge goes up and it cross 70% of gauge and after that i turn it OF , Plz help me .


  2. #2
    Senior PakWheeler Follow
    shereabdullah's Avatar
    Join Date
    Jan 2010
    Location
    Lala musa
    Age
    21
    Posts
    1,624
    Follows
    0
    Following
    0
    Mentioned
    31 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    which radiator r u using?? if single naali,, then go for double naali,, ur ^problm solvd
    every man sleeps 1/3 part of a day,, if he makes ABLUTION before sleeping, 1/3rd of his life will be counted as virtue

  3. #3
    PakWheeler Follow
    muddasir5022's Avatar
    Join Date
    Jan 2013
    Posts
    30
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by shereabdullah View Post
    which radiator r u using?? if single naali,, then go for double naali,, ur ^problm solvd
    i am using 3 nali radiator

  4. #4
    Senior PakWheeler Follow
    xenerking's Avatar
    Join Date
    Nov 2009
    Location
    Lahore
    Age
    36
    Posts
    1,028
    Follows
    0
    Following
    0
    Mentioned
    16 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by muddasir5022 View Post
    i am using 3 nali radiator
    cracking

  5. #5
    Senior PakWheeler Follow
    shereabdullah's Avatar
    Join Date
    Jan 2010
    Location
    Lala musa
    Age
    21
    Posts
    1,624
    Follows
    0
    Following
    0
    Mentioned
    31 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by muddasir5022 View Post
    i am using 3 nali radiator
    O TERI KHAIR,, then update to 5 naali
    every man sleeps 1/3 part of a day,, if he makes ABLUTION before sleeping, 1/3rd of his life will be counted as virtue

  6. #6
    Senior PakWheeler Follow
    cooldevil's Avatar
    Join Date
    Nov 2010
    Location
    Islamabad
    Posts
    3,047
    Follows
    1
    Following
    0
    Mentioned
    45 Post(s)
    Tagged
    5 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    use plastic tank radiator! its the best one! my khyber also heated up on ac! but after the installation of plastic radiator, the problem vanished! it costs 3.5 to 4 k without fan

  7. #7
    PakWheeler Follow
    j12johny's Avatar
    Join Date
    Jul 2013
    Posts
    12
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    check radiator fan and condenser fan there is a chance that condenser fan was not running or not working well ,if both are working good and flow of air was excellent then check your radiator if there is a rust in it you need to service it or change with new one ,if there is no rust and radiator was good then 1st check your ac compressor are not taking too much load on engine if compressor was fine then install the aluminum radiator this will solve your prob

  8. #8
    Senior PakWheeler Follow
    meh1's Avatar
    Join Date
    Feb 2012
    Location
    Sahiwal
    Posts
    1,361
    Follows
    0
    Following
    1
    Mentioned
    90 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    0

    Default

    are you using tap water in radiator? if there is only one fan for radiator and condenser, it should be powerful enough and run continuously. also this can be caused by bad thermostat valve.

  9. #9
    Senior PakWheeler Follow
    xenerking's Avatar
    Join Date
    Nov 2009
    Location
    Lahore
    Age
    36
    Posts
    1,028
    Follows
    0
    Following
    0
    Mentioned
    16 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by meh1 View Post
    are you using tap water in radiator? if there is only one fan for radiator and condenser, it should be powerful enough and run continuously. also this can be caused by bad thermostat valve.
    Khyber has separate fans for radiator and condensor each

    Sent from my HTC One X using Tapatalk 2

  10. #10
    PakWheeler Follow
    muddasir5022's Avatar
    Join Date
    Jan 2013
    Posts
    30
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by j12johny View Post
    check radiator fan and condenser fan there is a chance that condenser fan was not running or not working well ,if both are working good and flow of air was excellent then check your radiator if there is a rust in it you need to service it or change with new one ,if there is no rust and radiator was good then 1st check your ac compressor are not taking too much load on engine if compressor was fine then install the aluminum radiator this will solve your prob
    i have check all the mentioned things and find all of them alright ....Some days before i have change the Condensor fan place , i.e before it is placed on the right adjacent to radiator fan , but i change the location of fan to left... Is this cause of problem ?

  11. #11
    PakWheeler Follow
    muddasir5022's Avatar
    Join Date
    Jan 2013
    Posts
    30
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by meh1 View Post
    are you using tap water in radiator? if there is only one fan for radiator and condenser, it should be powerful enough and run continuously. also this can be caused by bad thermostat valve.
    |Yes i am using tap water but before i also try coolant but it is also useless in this case, i have two fans , Radiator fan is direct

  12. #12
    Senior PakWheeler Follow
    meh1's Avatar
    Join Date
    Feb 2012
    Location
    Sahiwal
    Posts
    1,361
    Follows
    0
    Following
    1
    Mentioned
    90 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    0

    Default

    explain the placement of fans. upload a photo if you can.

  13. #13
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,400
    Follows
    131
    Following
    0
    Mentioned
    3988 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    check the water pump and replace the coolant intake pipe from the back of it, also make sure you remove all air from the system.
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  14. #14
    PakWheeler Follow
    j12johny's Avatar
    Join Date
    Jul 2013
    Posts
    12
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by muddasir5022 View Post
    i have check all the mentioned things and find all of them alright ....Some days before i have change the Condensor fan place , i.e before it is placed on the right adjacent to radiator fan , but i change the location of fan to left... Is this cause of problem ?
    well if previously u don't have this prob then change the location of fan & make sure water pump are working good

  15. #15
    PakWheeler Follow
    muddasir5022's Avatar
    Join Date
    Jan 2013
    Posts
    30
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Thanx j12johny for support. i will check it inshallah

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •