Survey by Qualaroo
+ Reply to Thread
Results 1 to 12 of 12
Like Tree3Likes
  • 1 Post By argtr65
  • 1 Post By talhawaleed
  • 1 Post By Naweed

Thread: URGENT: strange cold start problem with Khyber 1990

  1. #1
    Senior PakWheeler Follow
    lotus's Avatar
    Join Date
    Jun 2006
    Location
    Karachi
    Posts
    3,040
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default URGENT: strange cold start problem with Khyber 1990

    Im having a strange problem with my Swift 1990 (Khyber shape).. the car wont start at nights & early mornings but when the sun gets out and the car gets hot (its used to park out in the street) its a half-slef start car,. even when its not used for 2-3 days, it easily starts in day time but on the other hand even if its run the whole day, it wont start at night time when the engine is cold. also its pretty hot these days here in karachi and it should not give such problems during night.

    now when you push start it the car will have seriously rough idling and backfires for a couple of minutes after which the engine becomes running smooth and the car drives normally. and again, there is no such problem during the day time.

    i have got its battery checked, and have opinions with 2-3 different mechanics and cng technicians. no one has been able to get a clue. please note that the head gasket was changed during ramazan and head was refaced also..

    experts please give valuable suggestion how to solve this problem
    if tc=p then hc=m where tc is equal to toyota corolla and p is equal to paindu, and hc is equal to honda civic and m is equal to moron

  2. #2
    Senior PakWheeler Follow
    aamirq's Avatar
    Join Date
    Oct 2006
    Location
    Karachi
    Age
    31
    Posts
    1,726
    Follows
    0
    Following
    1
    Mentioned
    26 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    get the tappets checked maybe the tappets are too tight!
    "The world ain't all sunshine and rainbows. It's a very ruff, mean place, and no matter how tuff you think you are, it will always bring you to your knees and keep you there permanently if you let it.You or nobody ain't never gonna hit as hard as life, but it ain't about how hard you hit, it's about how hard you can get hit and keep moving forward, how much you can take and keep moving forward. If you know what you're worth, go out and get what you're worth, but you gotta be willing to take the hit."
    - Sylvester Stallone

  3. #3
    PakWheeler Follow
    danishijaz's Avatar
    Join Date
    Feb 2012
    Location
    Lahore
    Posts
    160
    Follows
    1
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    tappets problem and also check ignition timing timing

  4. #4
    Senior PakWheeler Follow
    argtr65's Avatar
    Join Date
    Dec 2008
    Age
    51
    Posts
    1,645
    Follows
    1
    Following
    0
    Mentioned
    74 Post(s)
    Tagged
    7 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Its a clear indication of weak battery,get it replaced,as you mentioned that you have already got it checked,but at that time it was charged due to driving for a while.Remember,if any of battery cell gets weakened then it looses its charge retaining property,specially in cold condition.
    Never loose hope in life,every step gives u something.

  5. #5
    Senior PakWheeler Follow
    lotus's Avatar
    Join Date
    Jun 2006
    Location
    Karachi
    Posts
    3,040
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    ^^ the battery is new & was purchased months earlier. still i got it checked and it has full amperes. even if i assume the battery to be a problem, how can you blame the battery for rough idling and backfiring??
    if tc=p then hc=m where tc is equal to toyota corolla and p is equal to paindu, and hc is equal to honda civic and m is equal to moron

  6. #6
    Senior PakWheeler Follow
    usman_arooq2's Avatar
    Join Date
    May 2011
    Location
    Sialkot
    Posts
    1,437
    Follows
    0
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    2
    Good Answers
    1

    Default

    its coil, cdi or some other thing in ignition system thats leaking current along with bad ignition timing.
    Bella, You give me everything just by REVing - NEONLIGHT SAGA: NEWTUBE

  7. #7
    PakWheeler Follow
    Magnitude's Avatar
    Join Date
    Apr 2010
    Location
    Karachi
    Age
    31
    Posts
    508
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    does it start on petrol?
    ZZzzzZZZzzzZZZZzzzzzzzzzZZZ

  8. #8
    Senior PakWheeler Follow
    talhawaleed's Avatar
    Join Date
    May 2009
    Location
    Islamabad
    Posts
    1,812
    Follows
    1
    Following
    0
    Mentioned
    115 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    could be anything, battery, maybe starter motor needs servicing, ignition coils or carburetor cleanup and last of all, the most important correct oil grade for winter season.

  9. #9
    Senior PakWheeler Follow
    Naweed's Avatar
    Join Date
    Jul 2008
    Location
    Karachi
    Age
    50
    Posts
    3,469
    Follows
    12
    Following
    0
    Mentioned
    122 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by lotus View Post
    Im having a strange problem with my Swift 1990 (Khyber shape).. the car wont start at nights & early mornings but when the sun gets out and the car gets hot (its used to park out in the street) its a half-slef start car,. even when its not used for 2-3 days, it easily starts in day time but on the other hand even if its run the whole day, it wont start at night time when the engine is cold. also its pretty hot these days here in karachi and it should not give such problems during night.

    now when you push start it the car will have seriously rough idling and backfires for a couple of minutes after which the engine becomes running smooth and the car drives normally. and again, there is no such problem during the day time.

    i have got its battery checked, and have opinions with 2-3 different mechanics and cng technicians. no one has been able to get a clue. please note that the head gasket was changed during ramazan and head was refaced also..

    experts please give valuable suggestion how to solve this problem
    ================================================== ================
    situation defies logic but still i have a theory that cng freezes .. can't say how or what to do .... try starting on petrol only
    ---------------------------------------------------------------------
    on the lighter side

    gari ko jinn par gaye hain
    and i remember a real life joke where

    someone filed a complaint at the computer shop that, "whenever we use our bathroom flush the computer you sold us reboots" company sent a technician who reported that the flushing in toilet turns ON the automatic water pump, to top up the water tank but the wiring is weak so the overall voltages drop, which reboots the PC
    "You have not lived today until you have done something for someone who can never repay you."

  10. #10
    Senior PakWheeler Follow
    argtr65's Avatar
    Join Date
    Dec 2008
    Age
    51
    Posts
    1,645
    Follows
    1
    Following
    0
    Mentioned
    74 Post(s)
    Tagged
    7 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by lotus View Post
    ^^ the battery is new & was purchased months earlier. still i got it checked and it has full amperes. even if i assume the battery to be a problem, how can you blame the battery for rough idling and backfiring??
    Brother,it is understood,weak battery leads to weak current which results in weak spark.
    Never loose hope in life,every step gives u something.

  11. #11
    Senior PakWheeler Follow
    usman_arooq2's Avatar
    Join Date
    May 2011
    Location
    Sialkot
    Posts
    1,437
    Follows
    0
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    2
    Good Answers
    1

    Default

    Quote Originally Posted by argtr65 View Post
    Brother,it is understood,weak battery leads to weak current which results in weak spark.
    true, my khyber had lost its edge at high rpm, i though vacuum advance wasn't working but when i took it to electrician, battey showed 11.5 volt, i was like wtf..... got it recharged for 24 hours and the car's performing well.....
    Bella, You give me everything just by REVing - NEONLIGHT SAGA: NEWTUBE

  12. #12
    PakWheeler Follow
    tahasoomro's Avatar
    Join Date
    Nov 2009
    Location
    Karachi
    Age
    28
    Posts
    882
    Follows
    1
    Following
    0
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Check Generator Belt I also have the same problem with my Khyber 1990 belts was loose the battery was not charging properly so Check you generator belt ..

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •