Survey by Qualaroo
+ Reply to Thread
Results 1 to 15 of 15

Thread: Callling All Experts, Help needed Liana 08 Rxi FF CNG

  1. #1
    PakWheeler Follow
    autolover1's Avatar
    Join Date
    Jul 2013
    Posts
    10
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Callling All Experts, Help needed Liana 08 Rxi FF CNG

    Dear Sir,

    I have been following pakwheels for a long time now and I really appreciate how people here are helping other people. I am a big fan of xulfiqar bhai as he is the most informative person I have seen on this forum.

    So here is a query of mine I am facing two problems in my 08 liana with factory fitted Landirenzo Omegas cng kit. I bought this car used a couple of years ago. Its in a good nick altogether but I had to replace the ignition coils soon after that as the car was missing badly on CNG, was better on petrol though. But even after all expense, I am not satisfied with its performance.

    1. The main problem is that whenever i accelerate the car, on CNG from idle, the engine hesitates a bit, but as soon a it crosses 2k rpm it picks up fine and things are even worst when ac is on, On traffic signals i have to accelerate till 2~3k before i release the clutch to get the car into the motion. On petrol its better but I can feel it there too..

    2. Second problem which may be related to the first problem as well is that during normal driving, whenever i lift my foot from the gas pedal and then put it back, it takes a bit of a jerk ("Hauka" in local term) before getting into pace. It can be felt on petrol too but the magnitude of it is lot less then that of CNG.

    I have seen many 3S for this problem but none of them have been able to rectify these problems. Most of the time they are interested in replace this replace that, blah blah....

    Any help in this regard from your side will be highly appreciated.

  2. #2
    Senior PakWheeler Follow
    iamadee's Avatar
    Join Date
    Mar 2008
    Location
    Lahore
    Age
    41
    Posts
    1,827
    Follows
    2
    Following
    0
    Mentioned
    22 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by autolover1 View Post
    Dear Sir,

    I have been following pakwheels for a long time now and I really appreciate how people here are helping other people. I am a big fan of xulfiqar bhai as he is the most informative person I have seen on this forum.

    So here is a query of mine I am facing two problems in my 08 liana with factory fitted Landirenzo Omegas cng kit. I bought this car used a couple of years ago. Its in a good nick altogether but I had to replace the ignition coils soon after that as the car was missing badly on CNG, was better on petrol though. But even after all expense, I am not satisfied with its performance.

    1. The main problem is that whenever i accelerate the car, on CNG from idle, the engine hesitates a bit, but as soon a it crosses 2k rpm it picks up fine and things are even worst when ac is on, On traffic signals i have to accelerate till 2~3k before i release the clutch to get the car into the motion. On petrol its better but I can feel it there too..

    2. Second problem which may be related to the first problem as well is that during normal driving, whenever i lift my foot from the gas pedal and then put it back, it takes a bit of a jerk ("Hauka" in local term) before getting into pace. It can be felt on petrol too but the magnitude of it is lot less then that of CNG.

    I have seen many 3S for this problem but none of them have been able to rectify these problems. Most of the time they are interested in replace this replace that, blah blah....

    Any help in this regard from your side will be highly appreciated.



    Try sharing your problem on this thread too....

    https://www.pakwheels.com/forums/whe...wners-fan-club
    Sharing is caring....

  3. #3
    PakWheeler Follow
    autolover1's Avatar
    Join Date
    Jul 2013
    Posts
    10
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Thanks dear. I'll do that right away.

  4. #4
    Senior PakWheeler Follow
    iamadee's Avatar
    Join Date
    Mar 2008
    Location
    Lahore
    Age
    41
    Posts
    1,827
    Follows
    2
    Following
    0
    Mentioned
    22 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Can be coils, not sure though....

    Sent from my TCL A909 using Tapatalk 2
    Sharing is caring....

  5. #5
    PakWheeler Follow
    autolover1's Avatar
    Join Date
    Jul 2013
    Posts
    10
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    bump! ! ! ! ! !! !
    where are all the experts??

  6. #6
    PakWheeler Follow
    autolover1's Avatar
    Join Date
    Jul 2013
    Posts
    10
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @Xulfiqar bhai where are you.....

  7. #7
    Senior PakWheeler Follow
    iamadee's Avatar
    Join Date
    Mar 2008
    Location
    Lahore
    Age
    41
    Posts
    1,827
    Follows
    2
    Following
    0
    Mentioned
    22 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by autolover1 View Post
    Thanks dear. I'll do that right away.
    Tumhara number bhi ayey ga

    Sent from my TCL A909 using Tapatalk 2
    Sharing is caring....

  8. #8
    PakWheeler Follow
    autolover1's Avatar
    Join Date
    Jul 2013
    Posts
    10
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    bump......

  9. #9
    PakWheeler Follow
    rickvanholden's Avatar
    Join Date
    Jun 2013
    Posts
    67
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by autolover1 View Post
    Dear Sir,

    I have been following pakwheels for a long time now and I really appreciate how people here are helping other people. I am a big fan of xulfiqar bhai as he is the most informative person I have seen on this forum.

    So here is a query of mine I am facing two problems in my 08 liana with factory fitted Landirenzo Omegas cng kit. I bought this car used a couple of years ago. Its in a good nick altogether but I had to replace the ignition coils soon after that as the car was missing badly on CNG, was better on petrol though. But even after all expense, I am not satisfied with its performance.

    1. The main problem is that whenever i accelerate the car, on CNG from idle, the engine hesitates a bit, but as soon a it crosses 2k rpm it picks up fine and things are even worst when ac is on, On traffic signals i have to accelerate till 2~3k before i release the clutch to get the car into the motion. On petrol its better but I can feel it there too..

    2. Second problem which may be related to the first problem as well is that during normal driving, whenever i lift my foot from the gas pedal and then put it back, it takes a bit of a jerk ("Hauka" in local term) before getting into pace. It can be felt on petrol too but the magnitude of it is lot less then that of CNG.

    I have seen many 3S for this problem but none of them have been able to rectify these problems. Most of the time they are interested in replace this replace that, blah blah....

    Any help in this regard from your side will be highly appreciated.
    Was your problem solved?

  10. #10
    PakWheeler Follow
    autolover1's Avatar
    Join Date
    Jul 2013
    Posts
    10
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    No response on the thread so far. Still seeking guidance from senior fellas...

  11. #11
    PakWheeler Follow
    rickvanholden's Avatar
    Join Date
    Jun 2013
    Posts
    67
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by autolover1 View Post
    No response on the thread so far. Still seeking guidance from senior fellas...
    Ok. Try changing spark plugs, and put an injector cleaner in your fuel tank.

    Look, personally, I think the Liana was never meant to be driven on CNG. This is like driving a Belta or Vitz on CNG. PakSuzuki made a BIG mistake with an extraordinary car. We need to change our mindset on this matter, its a psychological barrier that CNG will ALWAYS be cheaper than petrol.

    I always treat my Liana like a JDM, and I think thats a good approach. Between you and me, replace air filter, plugs, oil etc. etc., and drive on petrol only. Reset the ECU so it can relearn your patterns. You will find near CNG equivilent fuel economy.

    Let me know if it works, learning all year round.

  12. #12
    PakWheeler Follow
    autolover1's Avatar
    Join Date
    Jul 2013
    Posts
    10
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I have NGK platinum plugs installed, injectors cleaners never worked for me or any of us i have tried that too.. The economy of this car on CNG is excellent while its poor on petrol. The mileage on long without AC is around 13~14 on petrol, its around 200Km in a full tank of CNG on long on the other hand.

  13. #13
    Senior PakWheeler Follow
    iamadee's Avatar
    Join Date
    Mar 2008
    Location
    Lahore
    Age
    41
    Posts
    1,827
    Follows
    2
    Following
    0
    Mentioned
    22 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Try using oem plugs and then give it a try.

    Sent from my TCL A909 using Tapatalk 2
    Sharing is caring....

  14. #14
    Senior PakWheeler Follow
    waqar19's Avatar
    Join Date
    Aug 2011
    Location
    Lahore
    Age
    25
    Posts
    1,110
    Follows
    1
    Following
    0
    Mentioned
    32 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    For CNG pickup problem= check its gas pressure regulator(solenoid valve). An electrician or CNG mechanic can tell better.whether it is short or working fine.
    For little jerks while sudden accelration= check ignition timing
    The best car safety device is a rear-view mirror with a cop in it.

  15. #15
    PakWheeler Follow
    scorpion76's Avatar
    Join Date
    Feb 2013
    Posts
    6
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    once i had problem similar what you have specified and root cause was fuel pump which due to bad fuel from our stations was in poor condition. and this was also not picked by any of 3s dealers, i figure it out myself after doing some research. as far as little jerk you mentioned mine was rectified after cleaning of throttle body. so if you have not tried these things please do so i hope it will help you.

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •