Survey by Qualaroo
+ Reply to Thread
Results 1 to 5 of 5

Thread: No Power in Engine

  1. #1
    PakWheeler Follow
    abbas.hassan's Avatar
    Join Date
    Mar 2014
    Posts
    5
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default No Power in Engine

    My Liana 2007 is having some major issues. It seems there is no power in the engine. I have to put a heavy foot on the accelerator to get it moving fast. Cant even take it to Dam-e-Koh and normally now i have to put it on 5th gear at the speed of 50km/hr. help needed


  2. 28-03-2014, 06:08 PM

    PakWheeler

    Reason
    commercial selling..

  3. #2
    PakWheeler Follow
    Morani's Avatar
    Join Date
    Nov 2008
    Location
    Islamabad
    Age
    33
    Posts
    348
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Daman-e-koh kidhar aur Gulshan-e-Iqbal kidhar...

  4. #3
    PakWheeler Follow
    abbas.hassan's Avatar
    Join Date
    Mar 2014
    Posts
    5
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Bro i am based in Islamabad

  5. #4
    PakWheeler Follow
    haroon959's Avatar
    Join Date
    Jul 2015
    Location
    Select City
    Posts
    102
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    check your air filter.... change it if it is clogged with dust.... and get your CNG flow adjusted if you're running on CNG....

  6. #5
    PakWheeler Follow
    Mun33b's Avatar
    Join Date
    May 2013
    Location
    Karachi
    Posts
    159
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    2

    Default

    Shifting it to 5th gear at 50km/hr?
    Does it rev up and up and cant gain speed? Probably a faulty clutch plate.

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •