Survey by Qualaroo
+ Reply to Thread
Page 1 of 12 12311 ... LastLast
Results 1 to 20 of 223
Like Tree23Likes

Thread: Need Advise of Experts on Mileage Issue with Suzuki Margallah

  1. #1
    Senior PakWheeler Follow
    Thinking's Avatar
    Join Date
    Jul 2008
    Location
    Islamabad
    Age
    34
    Posts
    2,300
    Follows
    4
    Following
    0
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    2
    Good Answers
    1

    Default Need Advise of Experts on Mileage Issue with Suzuki Margallah

    Dear Experts,

    I am stating the problem below along with relevant details. Need your expert advise to resolve the issue at hand.

    Car Details:

    Suzuki Margallah with stock G13B Carby Engine Driven 260K KM. No issues with the performance. Maintained on Fully Synthetic 10-40 Oil (suits with better idle and improved mobility experience). Proper regular maintenance at every 5K KM.

    Had been using LUCAS 4 TIP plugs and was getting at least 11.5-12 KM/L until May 2014 (sometimes even better).

    Issue:

    Car's milage has dropped to 9.5-10.5 KM/L for no apparent reason since last 4 months.

    Fixes applied:

    Plugs have been cleaned (seems irrelevant since there is no starting or performance issue any way).
    A loose hose pipe (for vaccum) has been replaced on carburator, was making shan-shan noise.
    A loose fuel pipe has been replaced.
    Fuel system cleaner from STP has been poured.
    Carburator cleaner from STP has been poured several times (does improve idle and smoothes the drive). Used once a month any way.
    Gear Oil has been changed with Caltex Thuban SAE 90.
    Car Alignment has been re done (believe me it does improve the milage of the car - as per my previous experience).

    A sympton of some issue that i had been observing is a strong petrol smell (for about 20-30 sec) once there is less fuel in the tank and i turn off the engine. Mechanic says that he couldn't find any blockage in the exhaust of fuel tank.

    Result:

    Haven't seen any improvement in milage it is still between 9.5-10.5 KM/L.

    Way Ahead:

    Currently using LUCAS 4 TIP plugs which are in good nick, no issues with starting or idle or acceleration. They are being used for at least 30-40K KMs. Previous Bosch 4 TIP plugs worked 100K KMs without any issue.

    Does changing these plugs with NGK platinum (single tip) be of any use and will improve the milage?

    Using OEM plug wires came with the car in 1998, should i change these to any good 8 MM or 10 MM wires?

    Orignal cylincer came with car Made by Sanki Japan is making small noises like chan chan, should i change it now (since mechanic suggested no need since no apparent issue). I believe if exhaust system is in precise condition it does improve the milage as well.

    I will really appreciate your feed back.

    Regards

  2. #2
    PakWheeler Follow
    yousufshaikh1989's Avatar
    Join Date
    Feb 2014
    Location
    Karachi
    Age
    27
    Posts
    304
    Follows
    1
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Have you tried replacing the fuel filter ??? My car used to smell like petrol too. Eventually found the leaking fuel filter.

  3. #3
    PakWheeler Follow
    malkana's Avatar
    Join Date
    Apr 2005
    Location
    Faisalabad
    Posts
    13
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    You may also check the discharge delivery (return) of fuel in tank. At times flange where return fuel pipe is installed leaks a bit and smells specially at the time of switching off the engine

  4. #4
    Senior PakWheeler Follow
    Thinking's Avatar
    Join Date
    Jul 2008
    Location
    Islamabad
    Age
    34
    Posts
    2,300
    Follows
    4
    Following
    0
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    2
    Good Answers
    1

    Default

    Have replaced the fuel filter, however couldn't find any issue there anyway.

    Also checked discharge delivery and found it to be ok.

    Seems to me something complicated which I have not been able to trouble shoot.

  5. #5
    Senior PakWheeler Follow
    Thinking's Avatar
    Join Date
    Jul 2008
    Location
    Islamabad
    Age
    34
    Posts
    2,300
    Follows
    4
    Following
    0
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    2
    Good Answers
    1

    Default

    Xulfiqar Bhai is requested to give his feed back here please.

  6. #6
    Senior PakWheeler Follow
    capsat's Avatar
    Join Date
    Apr 2006
    Location
    Select City
    Age
    10
    Posts
    12,587
    Follows
    31
    Following
    6
    Mentioned
    1017 Post(s)
    Tagged
    19 Thread(s)
    Problems Posted
    2
    Problems Solved
    5
    Best Answers
    3
    Good Answers
    6
    - www.crackwheels.com - A skilled Dictator is much more beneficial to Country......than a Democracy of Ignorant people

  7. #7
    Senior PakWheeler Follow
    syncview's Avatar
    Join Date
    Apr 2006
    Location
    Lahore
    Age
    28
    Posts
    3,364
    Follows
    7
    Following
    1
    Mentioned
    436 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    What is the valve clearance set to?

    Check the ignition coil and spark plug wire resistances
    https://www.facebook.com/OsamaAbbasPhotography

  8. #8
    Senior PakWheeler Follow
    margallar's Avatar
    Join Date
    Oct 2009
    Location
    Lahore
    Posts
    9,957
    Follows
    6
    Following
    2
    Mentioned
    283 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i would replace those plug wires for new ones (only genuine ones from suzuki dealer).

    check the coil as @syncview mentioned

    replace distributor cap and rotor

    let the car idle in full dark, and see the wires for any blue arcing (sparks)

    check the pcv valve (green valve on the pipe that goes to manifold from air filter and tappet cover

    did you change the fuel station?

    the fuel smell is not normal, there must be a leak somewhere

    11-12 kpl is very good for a margalla, i think your choice of engine oil is partly the reason.

    Did any mechanic "tune" it recently?

    get the old exhaust repaired, the aftermarket ones are garbage, unless you are lucky to find one off a cultus (a genuine one)
    haters gonna hate, potatoes gonna potate

  9. #9
    Senior PakWheeler Follow
    margallar's Avatar
    Join Date
    Oct 2009
    Location
    Lahore
    Posts
    9,957
    Follows
    6
    Following
    2
    Mentioned
    283 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i would hold any work for atleast one month, until the weather gets better, ac reduces fuel avg just by the amount you mention
    haters gonna hate, potatoes gonna potate

  10. #10
    Senior PakWheeler Follow
    aamirq's Avatar
    Join Date
    Oct 2006
    Location
    Karachi
    Age
    31
    Posts
    1,726
    Follows
    0
    Following
    1
    Mentioned
    26 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    use normal ngk/denso copper plugs and ur problem should be solved no need of using fancy plugs!
    "The world ain't all sunshine and rainbows. It's a very ruff, mean place, and no matter how tuff you think you are, it will always bring you to your knees and keep you there permanently if you let it.You or nobody ain't never gonna hit as hard as life, but it ain't about how hard you hit, it's about how hard you can get hit and keep moving forward, how much you can take and keep moving forward. If you know what you're worth, go out and get what you're worth, but you gotta be willing to take the hit."
    - Sylvester Stallone

  11. #11
    Senior PakWheeler Follow
    Thinking's Avatar
    Join Date
    Jul 2008
    Location
    Islamabad
    Age
    34
    Posts
    2,300
    Follows
    4
    Following
    0
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    2
    Good Answers
    1

    Default

    OK margallar & Syncview thanks.

    will get the rotor, coil and plug wires checked. I just m skeptical of any issue there mainly because car starts at half self and there are no issues with acceleration. However i did check the log book yesterday and LUCAS plugs have been driven for nearly 68K KM (however still emerge red when checked) but its time to replace them.

    I have a guy who arranged a Sanki exhaust for me from a cultus EFI. will get it checked and replaced accordingly.

    will share the results.

    No new tune ups for the car recently. car is driven on 100% AC (my bad) even these days.

    Yes synthetic oil does improve the drive and milage after oil change I usually get around 14KM/L on 1st few fuel fill ups however it drops to 11.5 to 12 KM/L once it reaches change interval of 5K KM.
    However since the issue it is remaining constantly at 9.5-10 KM/L (happened on both last oil changes).

    thanks.

  12. #12
    Senior PakWheeler Follow
    syncview's Avatar
    Join Date
    Apr 2006
    Location
    Lahore
    Age
    28
    Posts
    3,364
    Follows
    7
    Following
    1
    Mentioned
    436 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Which synthetic oil are you using?
    https://www.facebook.com/OsamaAbbasPhotography

  13. #13
    PakWheeler Follow
    imrananr's Avatar
    Join Date
    Jun 2014
    Posts
    837
    Follows
    0
    Following
    5
    Mentioned
    19 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    I think it's the carburettor.
    Check vacuum pipes. Carry out carb. Disassembly and cleaning from a reputed mechanic who really knows what he's doing.
    Other than that, check ignition timing and ignition timing advance mechanism. ( use of timing gun).
    Don't leave a highway for a byway....

  14. #14
    Senior PakWheeler Follow
    margallar's Avatar
    Join Date
    Oct 2009
    Location
    Lahore
    Posts
    9,957
    Follows
    6
    Following
    2
    Mentioned
    283 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Definitely replace spark plugs, use denso w20ex-u

    Look at the wires in a dark garage at night time, let the car idle and see if there are any blue sparks around the wires.

    There is a vent hole on the carburetor, it is a small hole, next to the place where it sucks air, you can spray a small amount of carburetor cleaner in there while revving the engine
    haters gonna hate, potatoes gonna potate

  15. #15
    PakWheeler Follow
    faisalkarim55's Avatar
    Join Date
    Oct 2014
    Posts
    14
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Unhappy

    dear experts,

    i am really glad to see such technical discussion over here. I regret why didnt I try pakwheels forums earlier. Treasure of knowledge.
    I am here to share a problem of my car and seeking your kind advice and expert opinion.
    Here is my and my cars profile:

    Car: Suzuki margalla , model: 95 mileage: 200K plus
    Engine: 1300 cc (CNG/petrol) Repaired last year, new pistons and god knows what else he changed (fell prey of an idiot mechanic)

    History:
    The car used to give a very good mileage of around 11 km/ltr without ac 1.5 years back. It started making trouble after my father started to go to an idiot mechanic (whom people call margalla expert and i suppose he is not even a khota gadi expert). The car used to stop with brakes and slow rpm and it was not getting any better no matter how much we struggled. The mechanic suggested a full engine overhaul. We literally expended 30000 on engine overhaul. After that the car became smooth like a new one, no jerks no problems etc. BUT, the mileage went to insane levels. Hardly 6km/ltr or 6.5 on highways. First he said the tappets are not fully tightened due to recent engine overhauls, ok, tight them. Problem was still there, then by a miracle he got to know there is a leakage just over the generator (just think, leakage of gasoline over generator, waiting for a blast). We got the leakage stopped from plaza. This man again made us fool and said the average is good but due to recent engine overhaul it is giving low average, will improve by time and running. Until this time the car was mainly in my fathers use. I am almost a novice to automobiles and have very little knowledge other than driving a car. Recently the car has come in my hands as I changed my job as no more company transport.

    Current Status:
    The car gave jerks on petrol and cng both and oil leakage was also there. When turned off on CNG it would not start in the next morning until your self start starts crying or your battery goes down. I gave the car to another mechanic who is a (self acclaimed) 2S dealer of Pak suzuki and is contractor for my company's vehicles maintenance. He stopped the leakage somehow (not completely) and asked me to take it to Carburator wala to get its carburetor fixed because thats the reason for jerks and low mileage, it sound logical to me. I got the carburetor serviced and repaired the butterfly from a renowned carb expert (mehmood) in karachi. After that, my car is giving no jerks on petrol, but on CNG it works fine only when engine is hot enough, in cold condition it stops and kills me till it gets hot, say after running 2 to 3 kilometers. The mileage is still not improved (hardly 7.5 now which i tested on national highway), with CNG it gives 110 km for a full cylinder without ac.

    please help me.... I am not in a position to sell this and buy another one. This car used to be a gem but after that engine overhaul its just getting on my nerves whenever i drive - the amount of fuel it eats.

  16. #16
    PakWheeler Follow
    imrananr's Avatar
    Join Date
    Jun 2014
    Posts
    837
    Follows
    0
    Following
    5
    Mentioned
    19 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by faisalkarim55 View Post
    dear experts,

    i am really glad to see such technical discussion over here. I regret why didnt I try pakwheels forums earlier. Treasure of knowledge.
    I am here to share a problem of my car and seeking your kind advice and expert opinion.
    Here is my and my cars profile:


    Car: Suzuki margalla , model: 95 mileage: 200K plus
    Engine: 1300 cc (CNG/petrol) Repaired last year, new pistons and god knows what else he changed (fell prey of an idiot mechanic)

    History:
    The car used to give a very good mileage of around 11 km/ltr without ac 1.5 years back. It started making trouble after my father started to go to an idiot mechanic (whom people call margalla expert and i suppose he is not even a khota gadi expert). The car used to stop with brakes and slow rpm and it was not getting any better no matter how much we struggled. The mechanic suggested a full engine overhaul. We literally expended 30000 on engine overhaul. After that the car became smooth like a new one, no jerks no problems etc. BUT, the mileage went to insane levels. Hardly 6km/ltr or 6.5 on highways. First he said the tappets are not fully tightened due to recent engine overhauls, ok, tight them. Problem was still there, then by a miracle he got to know there is a leakage just over the generator (just think, leakage of gasoline over generator, waiting for a blast). We got the leakage stopped from plaza. This man again made us fool and said the average is good but due to recent engine overhaul it is giving low average, will improve by time and running. Until this time the car was mainly in my fathers use. I am almost a novice to automobiles and have very little knowledge other than driving a car. Recently the car has come in my hands as I changed my job as no more company transport.

    Current Status:
    The car gave jerks on petrol and cng both and oil leakage was also there. When turned off on CNG it would not start in the next morning until your self start starts crying or your battery goes down. I gave the car to another mechanic who is a (self acclaimed) 2S dealer of Pak suzuki and is contractor for my company's vehicles maintenance. He stopped the leakage somehow (not completely) and asked me to take it to Carburator wala to get its carburetor fixed because thats the reason for jerks and low mileage, it sound logical to me. I got the carburetor serviced and repaired the butterfly from a renowned carb expert (mehmood) in karachi. After that, my car is giving no jerks on petrol, but on CNG it works fine only when engine is hot enough, in cold condition it stops and kills me till it gets hot, say after running 2 to 3 kilometers. The mileage is still not improved (hardly 7.5 now which i tested on national highway), with CNG it gives 110 km for a full cylinder without ac.

    please help me.... I am not in a position to sell this and buy another one. This car used to be a gem but after that engine overhaul its just getting on my nerves whenever i drive - the amount of fuel it eats.
    With all you have gone through and what all has been repaired you may check the following:

    1) Valve timing
    2) Ignition timing
    3) Ignition timing advance mechanism functional operation. (Use timing gun)
    4) Ensure that a thermostatic valve has been installed in the cooling system
    5) Radiator fan is operated on auto.
    Don't leave a highway for a byway....

  17. #17
    Senior PakWheeler Follow
    COOLTAHIR's Avatar
    Join Date
    Feb 2011
    Location
    Select City
    Age
    19
    Posts
    4,702
    Follows
    9
    Following
    0
    Mentioned
    132 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    1
    Good Answers
    0

    Default

    Plz correct spell
    Its suzuki Margalla not margallah
    FeeL YoUng DriVE YoUnG......

  18. #18
    PakWheeler Follow
    faisalkarim55's Avatar
    Join Date
    Oct 2014
    Posts
    14
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    can you suggest a good (allah ka bnda) mechanic who is God fearing and doesnt lies to clients and knows his work. the thing i hate about this mechanic community is that they tell a lot of lies and while repairing one thing they mess up four other things

  19. #19
    Senior PakWheeler Follow
    Thinking's Avatar
    Join Date
    Jul 2008
    Location
    Islamabad
    Age
    34
    Posts
    2,300
    Follows
    4
    Following
    0
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    2
    Good Answers
    1

    Default

    i think i got the culprit.

    got 13 KM/L on the same plugs and wires on last fill up. I am verifying that its not a miss calculation and will share the details accordingly.

  20. #20
    Senior PakWheeler Follow
    Thinking's Avatar
    Join Date
    Jul 2008
    Location
    Islamabad
    Age
    34
    Posts
    2,300
    Follows
    4
    Following
    0
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    2
    Good Answers
    1

    Default

    I am using Micking MAX SUPER 10W-40 fully synthetic for quite some time now.

+ Reply to Thread
Page 1 of 12 12311 ... LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •