Survey by Qualaroo
+ Reply to Thread
Page 8 of 12 FirstFirst ... 678910 ... LastLast
Results 141 to 160 of 223
Like Tree23Likes

Thread: Need Advise of Experts on Mileage Issue with Suzuki Margallah

  1. #1
    Senior PakWheeler Follow
    Thinking's Avatar
    Join Date
    Jul 2008
    Location
    Islamabad
    Age
    34
    Posts
    2,307
    Follows
    4
    Following
    0
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    2
    Good Answers
    1

    Default Need Advise of Experts on Mileage Issue with Suzuki Margallah

    Dear Experts,

    I am stating the problem below along with relevant details. Need your expert advise to resolve the issue at hand.

    Car Details:

    Suzuki Margallah with stock G13B Carby Engine Driven 260K KM. No issues with the performance. Maintained on Fully Synthetic 10-40 Oil (suits with better idle and improved mobility experience). Proper regular maintenance at every 5K KM.

    Had been using LUCAS 4 TIP plugs and was getting at least 11.5-12 KM/L until May 2014 (sometimes even better).

    Issue:

    Car's milage has dropped to 9.5-10.5 KM/L for no apparent reason since last 4 months.

    Fixes applied:

    Plugs have been cleaned (seems irrelevant since there is no starting or performance issue any way).
    A loose hose pipe (for vaccum) has been replaced on carburator, was making shan-shan noise.
    A loose fuel pipe has been replaced.
    Fuel system cleaner from STP has been poured.
    Carburator cleaner from STP has been poured several times (does improve idle and smoothes the drive). Used once a month any way.
    Gear Oil has been changed with Caltex Thuban SAE 90.
    Car Alignment has been re done (believe me it does improve the milage of the car - as per my previous experience).

    A sympton of some issue that i had been observing is a strong petrol smell (for about 20-30 sec) once there is less fuel in the tank and i turn off the engine. Mechanic says that he couldn't find any blockage in the exhaust of fuel tank.

    Result:

    Haven't seen any improvement in milage it is still between 9.5-10.5 KM/L.

    Way Ahead:

    Currently using LUCAS 4 TIP plugs which are in good nick, no issues with starting or idle or acceleration. They are being used for at least 30-40K KMs. Previous Bosch 4 TIP plugs worked 100K KMs without any issue.

    Does changing these plugs with NGK platinum (single tip) be of any use and will improve the milage?

    Using OEM plug wires came with the car in 1998, should i change these to any good 8 MM or 10 MM wires?

    Orignal cylincer came with car Made by Sanki Japan is making small noises like chan chan, should i change it now (since mechanic suggested no need since no apparent issue). I believe if exhaust system is in precise condition it does improve the milage as well.

    I will really appreciate your feed back.

    Regards

  2. #141
    Senior PakWheeler Follow
    Thinking's Avatar
    Join Date
    Jul 2008
    Location
    Islamabad
    Age
    34
    Posts
    2,307
    Follows
    4
    Following
    0
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    2
    Good Answers
    1

    Default

    Kenwood 4 channel amp is used for powering the speakers.

    2 channel amp is used for woofer in bridged mode.

  3. #142
    Senior PakWheeler Follow
    Thinking's Avatar
    Join Date
    Jul 2008
    Location
    Islamabad
    Age
    34
    Posts
    2,307
    Follows
    4
    Following
    0
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    2
    Good Answers
    1

    Default

    pioneer c010 are competition grade and vocals are very vivid and crisp.

  4. #143
    Senior PakWheeler Follow
    Thinking's Avatar
    Join Date
    Jul 2008
    Location
    Islamabad
    Age
    34
    Posts
    2,307
    Follows
    4
    Following
    0
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    2
    Good Answers
    1

    Default

    JBL are installed as rear speakers without cross over.

    tweeters are installed at the front.

    pic of rear speakers.


    Need Advise of Experts on Mileage Issue with Suzuki Margallah -1539379

  5. #144
    Senior PakWheeler Follow
    Thinking's Avatar
    Join Date
    Jul 2008
    Location
    Islamabad
    Age
    34
    Posts
    2,307
    Follows
    4
    Following
    0
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    2
    Good Answers
    1

    Default

    final installation looked likewith tweeters at front.

    Need Advise of Experts on Mileage Issue with Suzuki Margallah -1539383 both amps underneath front seats and woofer in the trunk.

  6. #145
    Senior PakWheeler Follow
    Thinking's Avatar
    Join Date
    Jul 2008
    Location
    Islamabad
    Age
    34
    Posts
    2,307
    Follows
    4
    Following
    0
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    2
    Good Answers
    1

    Default

    please do say MA.Its all i could manage with my limited hard earned money. and it took me 10 years to make it a complete system.sound is more inclined towards SQ than SPL. However i understand that there is always room in SQ system. however not much with the possibility of only 4 inch front speakers.

  7. #146
    Senior PakWheeler Follow
    Thinking's Avatar
    Join Date
    Jul 2008
    Location
    Islamabad
    Age
    34
    Posts
    2,307
    Follows
    4
    Following
    0
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    2
    Good Answers
    1

    Default

    Guys got a very interesting analysis regarding reduced milage.

    I had to travel very slowly for about 30 minutes in pindi recently. what i observed that my speedometer is not working at slow speeds and consequently cars milage is not getting updated.

    This means the when i am calculating the total number of KM travelled and total amount of fuel that went in, i am missing on the miles that have been travelled at slow speeds.

    i have tried factoring those Miles however precise calculation is difficult. got the orignal speedometer wire replaced with a new japanese one however there seems to be no improvement. wasted the money.

    what to do now?

  8. #147
    PakWheeler Follow
    imrananr's Avatar
    Join Date
    Jun 2014
    Posts
    849
    Follows
    0
    Following
    5
    Mentioned
    19 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by Thinking View Post
    Guys got a very interesting analysis regarding reduced milage.

    I had to travel very slowly for about 30 minutes in pindi recently. what i observed that my speedometer is not working at slow speeds and consequently cars milage is not getting updated.

    This means the when i am calculating the total number of KM travelled and total amount of fuel that went in, i am missing on the miles that have been travelled at slow speeds.

    i have tried factoring those Miles however precise calculation is difficult. got the orignal speedometer wire replaced with a new japanese one however there seems to be no improvement. wasted the money.

    what to do now?
    Are you sure what you are saying has been confirmed? Please re-check.
    Don't leave a highway for a byway....

  9. #148
    Site Banned Follow
    deltabudy's Avatar
    Join Date
    Mar 2014
    Posts
    26
    Follows
    0
    Following
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default



    Need Advise of Experts on Mileage Issue with Suzuki Margallah -1541837

  10. #149
    Senior PakWheeler Follow
    Thinking's Avatar
    Join Date
    Jul 2008
    Location
    Islamabad
    Age
    34
    Posts
    2,307
    Follows
    4
    Following
    0
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    2
    Good Answers
    1

    Default

    @margallar

    Bro please suggest if i should go for this? Any improvement expected? Further how to silent this not interested in any sound only the looks and performance matters in margallah

    hks hiper burnt tip exhaust for sale in Lahore - Car Accessory 1289375 | PakWheels

  11. #150
    Senior PakWheeler Follow
    margallar's Avatar
    Join Date
    Oct 2009
    Location
    Lahore
    Posts
    9,960
    Follows
    6
    Following
    2
    Mentioned
    283 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    no need for this. it won't make any meaningful difference. and the noise will irritate you after a while.

    stick to the original exhaust.
    haters gonna hate, potatoes gonna potate

  12. #151
    Senior PakWheeler Follow
    margallar's Avatar
    Join Date
    Oct 2009
    Location
    Lahore
    Posts
    9,960
    Follows
    6
    Following
    2
    Mentioned
    283 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i was experiencing an issue of low voltage on my margalla. i added an extra ground wire to the alternator. Now headlights are much whiter.

    I really recommend this DIY
    haters gonna hate, potatoes gonna potate

  13. #152
    Senior PakWheeler Follow
    harib4u's Avatar
    Join Date
    Dec 2013
    Location
    Islamabad
    Posts
    3,436
    Follows
    6
    Following
    0
    Mentioned
    113 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    1

    Post

    Quote Originally Posted by margallar View Post
    i was experiencing an issue of low voltage on my margalla. i added an extra ground wire to the alternator. Now headlights are much whiter.

    I really recommend this DIY
    can you share pictures too??

  14. #153
    Senior PakWheeler Follow
    Thinking's Avatar
    Join Date
    Jul 2008
    Location
    Islamabad
    Age
    34
    Posts
    2,307
    Follows
    4
    Following
    0
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    2
    Good Answers
    1

    Default

    Quote Originally Posted by margallar View Post
    i was experiencing an issue of low voltage on my margalla. i added an extra ground wire to the alternator. Now headlights are much whiter.

    I really recommend this DIY
    Similar issue with slow speed of my wipers. Got my electrician to open the toggle lever box for wipers. got it cleaned and installed back improved the wipers speed.

    However will surely check for the ground wires and will try to install one you suggested. i believe this is required after 16 years of use.

  15. #154
    Senior PakWheeler Follow
    Thinking's Avatar
    Join Date
    Jul 2008
    Location
    Islamabad
    Age
    34
    Posts
    2,307
    Follows
    4
    Following
    0
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    2
    Good Answers
    1

    Default

    Quote Originally Posted by imrananr View Post
    Are you sure what you are saying has been confirmed? Please re-check.
    confirmed bro. conclusion is my car always gives more milage than i calculate .

    However issue was not fixed after replacing the speedo wire and now i m cursing myself for replacing the orignal wire which was far better (in quality) than the japenese one i put in.

    what to do now?

  16. #155
    Senior PakWheeler Follow
    Thinking's Avatar
    Join Date
    Jul 2008
    Location
    Islamabad
    Age
    34
    Posts
    2,307
    Follows
    4
    Following
    0
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    2
    Good Answers
    1

    Default

    Quote Originally Posted by margallar View Post
    i was experiencing an issue of low voltage on my margalla. i added an extra ground wire to the alternator. Now headlights are much whiter.

    I really recommend this DIY
    please share pics for us and guide what to do and how?

  17. #156
    Senior PakWheeler Follow
    Thinking's Avatar
    Join Date
    Jul 2008
    Location
    Islamabad
    Age
    34
    Posts
    2,307
    Follows
    4
    Following
    0
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    2
    Good Answers
    1

    Default

    @margallar

    response awaited bro.

  18. #157
    Senior PakWheeler Follow
    margallar's Avatar
    Join Date
    Oct 2009
    Location
    Lahore
    Posts
    9,960
    Follows
    6
    Following
    2
    Mentioned
    283 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    bro my smartphone is out of order so the pics are delayed. i will try to arrange them by sunday. but it is too simple anyways. its just a wire from battery negative to the bolt that holds the alternator to the engine. there are two of those bolts, i used the one on the upper side as it was easy to access.

    i used a cheap wire and thimbles. i recommend 8 gauge or minimum 12 gauge wire for this, audio grade wire is good quality wise and also aesthetically
    haters gonna hate, potatoes gonna potate

  19. #158
    Senior PakWheeler Follow
    Thinking's Avatar
    Join Date
    Jul 2008
    Location
    Islamabad
    Age
    34
    Posts
    2,307
    Follows
    4
    Following
    0
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    2
    Good Answers
    1

    Default

    gonna get all grounding wires checked on the car any way.

    will share the details accordingly. Any idea how much does a good grounding kit cost? Also is it a good improvement after 17 years of use.

  20. #159
    Senior PakWheeler Follow
    Thinking's Avatar
    Join Date
    Jul 2008
    Location
    Islamabad
    Age
    34
    Posts
    2,307
    Follows
    4
    Following
    0
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    2
    Good Answers
    1

    Default

    experts please advice. my radiator is not sucking water from the reservior bottle. what could be the issue?

  21. #160
    Senior PakWheeler Follow
    Thinking's Avatar
    Join Date
    Jul 2008
    Location
    Islamabad
    Age
    34
    Posts
    2,307
    Follows
    4
    Following
    0
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    2
    Good Answers
    1

    Default

    My battery died yesterday. Changed it with Phoenix 60 Amps 11 plates battery. got it done late night so had no other option .

+ Reply to Thread
Page 8 of 12 FirstFirst ... 678910 ... LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •