Survey by Qualaroo
+ Reply to Thread
Results 1 to 2 of 2

Thread: Margalla Battery Issue

  1. #1
    PakWheeler Follow
    novakaan's Avatar
    Join Date
    Apr 2007
    Location
    Karachi
    Age
    37
    Posts
    31
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Margalla Battery Issue

    I have a margalla 95. I haven't driven it for quite some days and I couldn't make it start when I tried yesterday. So I took out its battery and charged it with UPS.

    When I put it in the car in the morning (UPS was showing battery full when I un plugged), it couldn't even turn on the switch, i.e. no response at all. Could it be that I connected wrong terminals (connected red with positive and black with negative, that is standard practice) or there might be some other reason.

    Any ideas?

    Ijaz

  2. #2
    PakWheeler Follow
    ali747's Avatar
    Join Date
    Jul 2007
    Location
    Islamabad
    Age
    11
    Posts
    101
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Once same problem happened with my khyber 7 years back... but that was actually a generator problem...was showing same symptoms and also drained car's new battery bcoz of some short circuting in generator...now I dont know well about your margalla...
    .

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •