Survey by Qualaroo
+ Reply to Thread
Results 1 to 10 of 10

Thread: Mehran TWO Problems URGENT RESPONCE REQUIRED

  1. #1
    PakWheeler Follow
    Rarif's Avatar
    Join Date
    Feb 2007
    Location
    Lahore
    Age
    43
    Posts
    8
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Mehran TWO Problems URGENT RESPONCE REQUIRED

    Dear All,fficeffice" /><?xml:namespace prefix = o ns = "urn:schemas-microsoft-com<img src=" /><o:p></o:p>
    <o:p></o:p>
    I am facing two problem with my Mehran-08 (Nov)<o:p></o:p>
    <o:p></o:p>
    1- Very low fuel consumption problem from the start. In city its do only 80 – 85 @ 6.5 kg(Full Cylinder) on the other side good milege 130 – 140 at highway. <o:p></o:p>
    2- From few day I am facing a series problem that my car become off in running position, after this immediately start with ignition switch. Same problem on petrol also, following steps were taken to remove the problem but prob not solve<o:p></o:p>
    a. Point changed<o:p></o:p>
    b. Plugs cleaned<o:p></o:p>
    c. Tuning on CNG done<o:p></o:p>
    d. Air Filter changed<o:p></o:p>
    e. Engine oil changed
    <o:p></o:p>
    <o:p></o:p>
    Kindly help/ guide me.


  2. #2
    Senior PakWheeler Follow
    Automotorsport_Lover's Avatar
    Join Date
    May 2008
    Location
    Lahore
    Age
    25
    Posts
    3,834
    Follows
    5
    Following
    2
    Mentioned
    82 Post(s)
    Tagged
    6 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Bhai Mehran kay battery kay Clamps bi bhot fazul hain pehlo wo check karao!! Itna kuch apnay bilkul billa waja hi change kara lia, apnay guess mar kay? Take it 2 a mechanic...

    My mehran also switched off in the way, it had Battery Clamps/Clips prob... They were too loose thats why Garri off ho jati thi.

  3. #3
    PakWheeler Follow
    NawazLhr's Avatar
    Join Date
    May 2009
    Location
    Lahore
    Posts
    74
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Agree wid Automotorsport_Lover.

    If problem persists, get your carborator serviced.

  4. #4
    PakWheeler Follow
    Rarif's Avatar
    Join Date
    Feb 2007
    Location
    Lahore
    Age
    43
    Posts
    8
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Automotorsport_Lover/ Nawaz Thanks for reply

    All things done on recommendation of mechanic, durring tunning mechanic check and found Battery Clamps are okay and tight.
    carborator also clean with cleaner available in market.

  5. #5
    PakWheeler Follow
    civic_90's Avatar
    Join Date
    Nov 2006
    Location
    Karachi
    Age
    30
    Posts
    764
    Follows
    1
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    1

    Default

    the mechanic is not professional tuner...
    simple....
    For Mechanical Works and Car Detailing, Contact 0333-3738698

  6. #6
    PakWheeler Follow
    bilal552's Avatar
    Join Date
    Dec 2009
    Location
    Rawalpindi
    Posts
    2
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    yr me too having almost same problem. my car mehran 2005 doesnt get off but start vibrating after a very good drive at half or full paddle but as soon as it gets slow and stops it start vibrating. and when i switch it off and start again then it comes very smooth. i have checked all the things but the problem still exists. can anyone please give any suggestion. thats only on cng. on petrol its perfectly fine. my mechanic told me that it may be a cng venturi fitiing as it gets extra air on high rpm and when it runs on slow rpm the air flow is still there and cng supply becomes less. but i have checked the fitting as well. plz help me out.

  7. #7
    PakWheeler Follow
    Rarif's Avatar
    Join Date
    Feb 2007
    Location
    Lahore
    Age
    43
    Posts
    8
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Still problem exist, brothers plz help me out......
    Any recommendation of good machanic in Lahore

  8. #8
    PakWheeler Follow
    cloud100's Avatar
    Join Date
    Dec 2009
    Location
    Lahore
    Age
    29
    Posts
    927
    Follows
    1
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @poster
    bro get ur cylinder serviced aswell cz if ur having oil in it then even when u get ur tank full the gas does not get in full cz oil there is occuping its space.
    for the second problem get ur ignition coil checked an ur alternator aswell but dont go changing these things ryt away. cz if ur battery is not getting fully charged this auto shut-off thingi drops in.

  9. #9
    Senior PakWheeler Follow
    IsbCap's Avatar
    Join Date
    Aug 2009
    Location
    Islamabad
    Posts
    1,865
    Follows
    1
    Following
    0
    Mentioned
    159 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Consumption depends on running conditions. If you drive most of the time in 2nd-3rd and have too many stop and go in your path, consumption's gonna be in the higher range.

    For 2nd problem, i think point is set for optimum consumption. You change the point and things must be fine (at the expense of more consumption of course!!!)

  10. #10
    PakWheeler Follow
    Rarif's Avatar
    Join Date
    Feb 2007
    Location
    Lahore
    Age
    43
    Posts
    8
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Cloud100<?xml:namespace prefix = o ns = "urn:schemas-microsoft-comfficeffice" /><o:p></o:p>
    My car is on 16 month old, do u think i really need to get cylinder serviced? <o:p></o:p>
    Ignition coil checked and found okay.<o:p></o:p>
    <o:p></o:p>
    IsbCap<o:p></o:p>
    Yes my way to home (shahdra) to office (Gulberg) heave too much traffic rush normally i drive my car in 3rd and 4th gear. <o:p></o:p>
    Before facing this Switch Off problem at old point setting car perform very well, after this problem set the point even change the point and set it twice but problem not solved.
    Anyhow thanks for reply & help.


+ Reply to Thread

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •