Survey by Qualaroo
+ Reply to Thread
Results 1 to 4 of 4

Thread: Mehran missing and starting issue (yesterday)

  1. #1
    PakWheeler Follow
    saddal's Avatar
    Join Date
    Jun 2006
    Location
    Islamabad
    Age
    86
    Posts
    87
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Mehran missing and starting issue (yesterday)

    I have Suzuki Mehran that has been tuned up on CNG on by mechanic about a week ago and the air filter has been changed. I even had the CNG kit cleaned by the CNG installer about month ago. Now the trouble is that the car is missing (very light) on unspecified interval on idle sitting. The car accelerates fine, with no trouble. I feel the car missing (very light) also when I am coasting ( the car is in gear, accelerator not pressed and the clutch is not pressed).

    Yesterday at the shopping mall, when I came back to start the car. The car would start, but the it would shut off immodestly. This happened 5 times. On the sixth time I waited for 30 seconds. Then the car started on full accelater pressed. The little missing is still felt, and I believe when it misses the temperature gauge goes up a notch.

    What could be the problem? I have shown it to two mechanics and they say its fine. I think it could be some electrical problem. What do you say?
    BTW I am Karachi, So any go mechanic near Ayesha Manzil for diagnosie would be helpful, or a DIY would be a better option for me.

    Thanks in advance ya all!


  2. #2
    PakWheeler Follow
    manofpk's Avatar
    Join Date
    Oct 2005
    Location
    Karachi
    Age
    29
    Posts
    513
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    adjust the golden knob thing on the CNG kit... CAREFULLY..... it will remove the missing on idling.... so will not give problem while driving as well... a little movement of the screw will do the job or may require a few turns... depends on how much its missing... the starting problem will be solved with the same thing...
    Dont Work Hard, Work Smart...

  3. #3
    PakWheeler Follow
    ya123's Avatar
    Join Date
    Nov 2009
    Location
    Islamabad
    Age
    31
    Posts
    110
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by manofpk View Post
    adjust the golden knob thing on the CNG kit... CAREFULLY..... it will remove the missing on idling.... so will not give problem while driving as well... a little movement of the screw will do the job or may require a few turns... depends on how much its missing... the starting problem will be solved with the same thing...
    yes i agree, seems like CNG setting issue.

  4. #4
    PakWheeler Follow
    saddal's Avatar
    Join Date
    Jun 2006
    Location
    Islamabad
    Age
    86
    Posts
    87
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Thanks ya all!. I will try this and will update it here!

+ Reply to Thread

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •