Survey by Qualaroo
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 20 of 29
Like Tree3Likes

Thread: Mehran Headlights draining battery like hell

  1. #1
    Senior PakWheeler Follow
    nasirjavaid's Avatar
    Join Date
    Jul 2013
    Location
    Lahore
    Posts
    3,084
    Follows
    8
    Following
    3
    Mentioned
    77 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    0

    Default Mehran Headlights draining battery like hell

    Update: Sold out my mehro

    Hi Experts,

    Another issue I am facing now a days: My Mehran 1996 is running fine for all day long and even starts fine after 2 days. alternator is charging normal. But I noticed that when travelling at night with headlights on, Battery is totally drained even car is running. I also noticed minor missing while headlamps are on. Last day while coming back from fortress it just stopped in our street and won't move the self. I checked with meter and voltage was 11.85

    I then charged the battery by attaching it to my UPS and charging for 10 minutes and put it back in car and it started fine. I suspect something wrong with headlight relay or wiring.... This only happens when I drive with headlights ON.

    Anyone with any idea what could be wrong and how can i fix it myself?

  2. #2
    Senior PakWheeler Follow
    CarSaaz's Avatar
    Join Date
    Apr 2008
    Location
    Karachi
    Age
    40
    Posts
    1,648
    Follows
    2
    Following
    0
    Mentioned
    16 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    has similiar problem with my cuore yesterday....
    "A government that robs Peter to pay Paul can always depend on the support of Paul. "If at first you don't succeed, failure may be your style."

  3. #3
    Senior PakWheeler Follow
    capsat's Avatar
    Join Date
    Apr 2006
    Location
    Select City
    Age
    10
    Posts
    12,597
    Follows
    31
    Following
    6
    Mentioned
    1018 Post(s)
    Tagged
    19 Thread(s)
    Problems Posted
    2
    Problems Solved
    5
    Best Answers
    3
    Good Answers
    6

    Default

    Your car generator needs servicing, since it is a suzuki you are lucky you can drive upto any place with suzuki pickups & vans and get it services for under Rs. 500.00 with parts.

    I love Suzuki I wish i can bring one home But am already married.


    Quote Originally Posted by nasirjavaid View Post
    Hi Experts,

    Another issue I am facing now a days: My Mehran 1996 is running fine for all day long and even starts fine after 2 days. alternator is charging normal. But I noticed that when travelling at night with headlights on, Battery is totally drained even car is running. I also noticed minor missing while headlamps are on. Last day while coming back from fortress it just stopped in our street and won't move the self. I checked with meter and voltage was 11.85

    I then charged the battery by attaching it to my UPS and charging for 10 minutes and put it back in car and it started fine. I suspect something wrong with headlight relay or wiring.... This only happens when I drive with headlights ON.

    Anyone with any idea what could be wrong and how can i fix it myself?
    - www.crackwheels.com - A skilled Dictator is much more beneficial to Country......than a Democracy of Ignorant people

  4. #4
    Senior PakWheeler Follow
    dr3vil's Avatar
    Join Date
    May 2009
    Posts
    11,930
    Follows
    11
    Following
    0
    Mentioned
    201 Post(s)
    Tagged
    7 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    it could be more simple
    the generator belt might be loose so not charging battery
    Hanjiii Kaa Storeey Eehh !

  5. #5
    Senior PakWheeler Follow
    nasirjavaid's Avatar
    Join Date
    Jul 2013
    Location
    Lahore
    Posts
    3,084
    Follows
    8
    Following
    3
    Mentioned
    77 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by capsat View Post
    Your car generator needs servicing, since it is a suzuki you are lucky you can drive upto any place with suzuki pickups & vans and get it services for under Rs. 500.00 with parts.

    I love Suzuki I wish i can bring one home But am already married.
    Hey buddy thanks for suggestion but I don't understand link of suzuki with being married

  6. #6
    Senior PakWheeler Follow
    nasirjavaid's Avatar
    Join Date
    Jul 2013
    Location
    Lahore
    Posts
    3,084
    Follows
    8
    Following
    3
    Mentioned
    77 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by ekdrifter View Post
    it could be more simple
    the generator belt might be loose so not charging battery
    Hey ekdrifter bro, I posted same in another thread to reach you. luckily you reached here too ... As posted there, the belt was installed new a month ago and looks fine. Also it is charging the battery fine when headlights are off. I checked by attaching multimeter with battery leads and starting the engine and gassing up.... on idle voltage shown is 12.8 - 12.9... when pushing the accelerator it shows up to 13.7 so I think no issue with generator.

  7. #7
    Senior PakWheeler Follow
    dr3vil's Avatar
    Join Date
    May 2009
    Posts
    11,930
    Follows
    11
    Following
    0
    Mentioned
    201 Post(s)
    Tagged
    7 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by nasirjavaid View Post
    Hey ekdrifter bro, I posted same in another thread to reach you. luckily you reached here too ... As posted there, the belt was installed new a month ago and looks fine. Also it is charging the battery fine when headlights are off. I checked by attaching multimeter with battery leads and starting the engine and gassing up.... on idle voltage shown is 12.8 - 12.9... when pushing the accelerator it shows up to 13.7 so I think no issue with generator.
    how about the rad fan
    or ur ride has an ac
    or sound system is heavy
    something might be draning battery
    a quick tip
    open the dhakkkanns on battery and check for electrode color
    if they are whiteish then ok
    if blackish then battery khatam hai
    and necxt time go for 48 or 50amp battery
    Hanjiii Kaa Storeey Eehh !

  8. #8
    Senior PakWheeler Follow
    nasirjavaid's Avatar
    Join Date
    Jul 2013
    Location
    Lahore
    Posts
    3,084
    Follows
    8
    Following
    3
    Mentioned
    77 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by ekdrifter View Post
    how about the rad fan
    or ur ride has an ac
    or sound system is heavy
    something might be draning battery
    a quick tip
    open the dhakkkanns on battery and check for electrode color
    if they are whiteish then ok
    if blackish then battery khatam hai
    and necxt time go for 48 or 50amp battery
    Ok Buddy, I will check the battery electrode color today... by the way NO AC and NO heavy sound system.... only FM & USB player
    If something other than lights were draining battery then battery should be low everyday but it is fine if I use my ride at daytime. problem is only when headlights turned on.... and left at idle for couple of minutes too.

    On Eid day I drove it back from Anarkali with headlamps on but didn't left it run idle with headlamps on.... and it was ok.

  9. #9
    Senior PakWheeler Follow
    dr3vil's Avatar
    Join Date
    May 2009
    Posts
    11,930
    Follows
    11
    Following
    0
    Mentioned
    201 Post(s)
    Tagged
    7 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by nasirjavaid View Post
    Ok Buddy, I will check the battery electrode color today... by the way NO AC and NO heavy sound system.... only FM & USB player
    If something other than lights were draining battery then battery should be low everyday but it is fine if I use my ride at daytime. problem is only when headlights turned on.... and left at idle for couple of minutes too.

    On Eid day I drove it back from Anarkali with headlamps on but didn't left it run idle with headlamps on.... and it was ok.
    it needs to run at a little high rpm on idle
    Hanjiii Kaa Storeey Eehh !

  10. #10
    Senior PakWheeler Follow
    nasirjavaid's Avatar
    Join Date
    Jul 2013
    Location
    Lahore
    Posts
    3,084
    Follows
    8
    Following
    3
    Mentioned
    77 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    0

    Smile

    Got it !!!

  11. #11
    PakWheeler Follow
    tahasoomro's Avatar
    Join Date
    Nov 2009
    Location
    Karachi
    Age
    28
    Posts
    882
    Follows
    1
    Following
    0
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by ekdrifter View Post
    it needs to run at a little high rpm on idle
    Help for khyber battery

  12. #12
    Senior PakWheeler Follow
    dr3vil's Avatar
    Join Date
    May 2009
    Posts
    11,930
    Follows
    11
    Following
    0
    Mentioned
    201 Post(s)
    Tagged
    7 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by tahasoomro View Post
    Help for khyber battery
    wana replace ags 55 or 60
    Hanjiii Kaa Storeey Eehh !

  13. #13
    PakWheeler Follow
    tahasoomro's Avatar
    Join Date
    Nov 2009
    Location
    Karachi
    Age
    28
    Posts
    882
    Follows
    1
    Following
    0
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    No bro i had today very bad problem i purchased khyber few days ago it was giving me little current in door meni light lia kuch din baad woh daka start ho gae i took to mechanic he said aap ki battery ka ek cell khtam hai change it i got new battery today same problem new battery got drained dhaka start on new battery

  14. #14
    PakWheeler Follow
    tahasoomro's Avatar
    Join Date
    Nov 2009
    Location
    Karachi
    Age
    28
    Posts
    882
    Follows
    1
    Following
    0
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by ekdrifter View Post
    wana replace ags 55 or 60
    No bro i had today very bad problem i purchased khyber few days ago it was giving me little current in door meni light lia kuch din baad woh daka start ho gae i took to mechanic he said aap ki battery ka ek cell khtam hai change it i got new battery today same problem new battery got drained dhaka start on new battery

  15. #15
    PakWheeler Follow
    tahasoomro's Avatar
    Join Date
    Nov 2009
    Location
    Karachi
    Age
    28
    Posts
    882
    Follows
    1
    Following
    0
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Bro i spent Rs 4000 with battery cost on car still my problem didn't get fixed please suggest me here in Larkana mechanics can't diagnose what the problem is why new battery car got drained ?

  16. #16
    PakWheeler Follow
    tahasoomro's Avatar
    Join Date
    Nov 2009
    Location
    Karachi
    Age
    28
    Posts
    882
    Follows
    1
    Following
    0
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Still I'm crying new year starts with Dhaka Start

  17. #17
    Senior PakWheeler Follow
    dr3vil's Avatar
    Join Date
    May 2009
    Posts
    11,930
    Follows
    11
    Following
    0
    Mentioned
    201 Post(s)
    Tagged
    7 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by tahasoomro View Post
    Still I'm crying new year starts with Dhaka Start
    which oil ur using
    20w 50 tends to freze in thand and takes a lot more umph to start it
    current status of the car ?
    oil rad fan auto or direct
    might be ur cars needs tuning and points need to be changed try that
    and i only know Zulfikar bhutto from larkana not any one else
    Hanjiii Kaa Storeey Eehh !

  18. #18
    PakWheeler Follow
    tahasoomro's Avatar
    Join Date
    Nov 2009
    Location
    Karachi
    Age
    28
    Posts
    882
    Follows
    1
    Following
    0
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Ok bro woh tu har cheez sahi hai lekin chal nhe rahi self nhe le rahi

  19. #19
    PakWheeler Follow
    leo_ali's Avatar
    Join Date
    Oct 2013
    Location
    Lahore
    Posts
    143
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    AOA friends,
    i have 2004 mehran 100000+ km driven its fan is not working can this harm engine ? or any other loss due to this plz tell me

  20. #20
    PakWheeler Follow
    tahasoomro's Avatar
    Join Date
    Nov 2009
    Location
    Karachi
    Age
    28
    Posts
    882
    Follows
    1
    Following
    0
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by leo_ali View Post
    AOA friends,
    i have 2004 mehran 100000+ km driven its fan is not working can this harm engine ? or any other loss due to this plz tell me
    Kon sa fan ?

+ Reply to Thread
Page 1 of 2 12 LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •