Survey by Qualaroo
+ Reply to Thread
Page 8 of 17 FirstFirst ... 678910 ... LastLast
Results 141 to 160 of 322
Like Tree90Likes

Thread: New EFI Mehran Missing Problem

  1. #1
    Senior PakWheeler Follow
    turbo_charge's Avatar
    Join Date
    Aug 2006
    Location
    Islamabad
    Age
    29
    Posts
    1,470
    Follows
    1
    Following
    0
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default New EFI Mehran Missing Problem

    I bought a new mehran 2 months back and now its Odo shows 7550 Km. Tuned twice from Suzuki Texila motors. Every thing is fine and smooth ride till now. only problem is that when i drove car with ac on all time for 2 3 hours it start giving jerks... jhatky start. some kind of missing .. this only happen when i accelerate car from 1st and 2nd gear... people in suzuki checked thoroughly and said no problem observed.. Help please.. i never faced any issue like this before..
    Ac on/off dono time same problem hy.. as soon as I put in 3rd gear jerks gone and ride smooth again....
    slow n steady wins the race..

  2. #141
    Senior PakWheeler Follow
    turbo_charge's Avatar
    Join Date
    Aug 2006
    Location
    Islamabad
    Age
    29
    Posts
    1,470
    Follows
    1
    Following
    0
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by ch.talal View Post
    If idle was fine and there were no jerks, then just directly connect hose from charcoal canister (black box) to throttle and drive for few days and observe if check engine light appears. Also observe the mileage and check if there is any starting issue. Do not cut paste the genuine wiring or connect any relay or you will simply void the warranty.
    Yes will do this and test... warranty is very important otherwise there is no way to counter 3s guys if I cut paste wiring...

    Sent from my SM-G530H using PW Forums mobile app
    slow n steady wins the race..

  3. #142
    Senior PakWheeler Follow
    umarkhan1's Avatar
    Join Date
    Nov 2010
    Location
    Sargodha
    Posts
    2,309
    Follows
    6
    Following
    8
    Mentioned
    51 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    2

    Default

    Quote Originally Posted by turbo_charge View Post
    Perfect.. relay is better...
    Can voltage stabilizer works well?? I have one spare in my yard..

    Sent from my SM-G530H using PW Forums mobile app
    It won't do anything and I am sure that the ecu would be providing full 12V to the solenoid.
    Check by your self


    Sent from my iPhone using PW Forums
    Just Do It Your Self!!!!!

  4. #143
    Senior PakWheeler Follow
    turbo_charge's Avatar
    Join Date
    Aug 2006
    Location
    Islamabad
    Age
    29
    Posts
    1,470
    Follows
    1
    Following
    0
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by umarkhan1 View Post
    It won't do anything and I am sure that the ecu would be providing full 12V to the solenoid.
    Check by your self


    Sent from my iPhone using PW Forums
    Before relay or after installing relay??

    Sent from my SM-G530H using PW Forums mobile app
    slow n steady wins the race..

  5. #144
    Senior PakWheeler Follow
    umarkhan1's Avatar
    Join Date
    Nov 2010
    Location
    Sargodha
    Posts
    2,309
    Follows
    6
    Following
    8
    Mentioned
    51 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    2

    Default

    Quote Originally Posted by turbo_charge View Post
    Before relay or after installing relay??

    Sent from my SM-G530H using PW Forums mobile app
    Before installing obviously


    Sent from my iPhone using PW Forums
    Just Do It Your Self!!!!!

  6. #145
    Senior PakWheeler Follow
    turbo_charge's Avatar
    Join Date
    Aug 2006
    Location
    Islamabad
    Age
    29
    Posts
    1,470
    Follows
    1
    Following
    0
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by umarkhan1 View Post
    Before installing obviously


    Sent from my iPhone using PW Forums
    Then where van be fault.. can any one know price of cultus valve so that I can replace and test

    Sent from my SM-G530H using PW Forums mobile app
    slow n steady wins the race..

  7. #146
    Senior PakWheeler Follow
    turbo_charge's Avatar
    Join Date
    Aug 2006
    Location
    Islamabad
    Age
    29
    Posts
    1,470
    Follows
    1
    Following
    0
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by ch.talal View Post
    So you are trying to tell that ECU is faulty and that is why those a## holes of 3S are reluctant to rectify this problem because they know that will cost them heck a lot of money? If Cultus purge valve is same, how about swapping that just for testing purpose?
    From where I can get from one Islamabad??? Suzuki 3s guy is not attending my call any more now.... lol

    Sent from my SM-G530H using PW Forums mobile app
    slow n steady wins the race..

  8. #147
    Senior PakWheeler Follow
    saboor73's Avatar
    Join Date
    Oct 2013
    Location
    Karachi
    Posts
    10,553
    Follows
    25
    Following
    0
    Mentioned
    351 Post(s)
    Tagged
    14 Thread(s)
    Problems Posted
    0
    Problems Solved
    6
    Best Answers
    2
    Good Answers
    25

    Default

    Quote Originally Posted by umarkhan1 View Post
    It won't do anything and I am sure that the ecu would be providing full 12V to the solenoid.
    Check by your self


    Sent from my iPhone using PW Forums
    Purge valve operates on 9v btw I dont think its culprit as its suppose to open at high rpms (atleast that how theory goes) that op is experiencing jerk in low speeds

  9. #148
    PakWheeler Follow
    harisabid's Avatar
    Join Date
    Jul 2010
    Location
    Islamabad
    Age
    29
    Posts
    72
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by saboor73 View Post
    Purge valve operates on 9v btw I dont think its culprit as its suppose to open at high rpms (atleast that how theory goes) that op is experiencing jerk in low speeds
    Its not working on high rpm...its only work in low rpm...u can check my remove hose pipe from throttle

    Sent from my SM-G925F using PW Forums mobile app

  10. #149
    Senior PakWheeler Follow
    turbo_charge's Avatar
    Join Date
    Aug 2006
    Location
    Islamabad
    Age
    29
    Posts
    1,470
    Follows
    1
    Following
    0
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by saboor73 View Post
    Purge valve operates on 9v btw I dont think its culprit as its suppose to open at high rpms (atleast that how theory goes) that op is experiencing jerk in low speeds
    At high rpms no jerks observed... problem only arises when going slow on lower gears at speed 0 to 20. After that car get smoother...

    Sent from my SM-G530H using PW Forums mobile app
    slow n steady wins the race..

  11. #150
    Senior PakWheeler Follow
    saboor73's Avatar
    Join Date
    Oct 2013
    Location
    Karachi
    Posts
    10,553
    Follows
    25
    Following
    0
    Mentioned
    351 Post(s)
    Tagged
    14 Thread(s)
    Problems Posted
    0
    Problems Solved
    6
    Best Answers
    2
    Good Answers
    25

    Default

    Quote Originally Posted by harisabid View Post
    Its not working on high rpm...its only work in low rpm...u can check my remove hose pipe from throttle

    Sent from my SM-G925F using PW Forums mobile app
    If we see it other way maybe it was open all the time thus engine jerking now the thing is you disconnected it left it open in engine bay fuel vapours in engine bay is alarming man

  12. #151
    PakWheeler Follow
    harisabid's Avatar
    Join Date
    Jul 2010
    Location
    Islamabad
    Age
    29
    Posts
    72
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by saboor73 View Post
    If we see it other way maybe it was open all the time thus engine jerking now the thing is you disconnected it left it open in engine bay fuel vapours in engine bay is alarming man
    New EFI Mehran Missing Problem - 47ca4c663c303e349c4c5ae1eef82b85

    Sent from my SM-G925F using PW Forums mobile app

  13. #152
    Senior PakWheeler Follow
    turbo_charge's Avatar
    Join Date
    Aug 2006
    Location
    Islamabad
    Age
    29
    Posts
    1,470
    Follows
    1
    Following
    0
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by saboor73 View Post
    If we see it other way maybe it was open all the time thus engine jerking now the thing is you disconnected it left it open in engine bay fuel vapours in engine bay is alarming man
    If it is stuck open already all the time and engine in getting rich mixture.. then valve is obviously faulty...
    If I by pass this valve bat same hy jerks phr b wysy e rehengy...

    Why no jerks in high gears and high rpms... if this open all time.. idling is also ok in cold.. little bubbling in hot

    Sent from my SM-G530H using PW Forums mobile app
    slow n steady wins the race..

  14. #153
    PakWheeler Follow
    harisabid's Avatar
    Join Date
    Jul 2010
    Location
    Islamabad
    Age
    29
    Posts
    72
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by turbo_charge View Post
    If it is stuck open already all the time and engine in getting rich mixture.. then valve is obviously faulty...
    If I by pass this valve bat same hy jerks phr b wysy e rehengy...

    Why no jerks in high gears and high rpms... if this open all time.. idling is also ok in cold.. little bubbling in hot

    Sent from my SM-G530H using PW Forums mobile app
    Ap log bas hose pipe ko by pass kerlo...khud hi pata chal jayega...

    Sent from my SM-G925F using PW Forums mobile app

  15. #154
    PakWheeler Follow
    harisabid's Avatar
    Join Date
    Jul 2010
    Location
    Islamabad
    Age
    29
    Posts
    72
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Ap jab throttle se pipe utaro ge throttle sucking air continuosly on idle rpm..jab ap race do ge to throttle sucking kerna chordega

    Sent from my SM-G925F using PW Forums mobile app

  16. #155
    PakWheeler Follow
    harisabid's Avatar
    Join Date
    Jul 2010
    Location
    Islamabad
    Age
    29
    Posts
    72
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Let me tell.u one thing..mere neighbour ne li hai gari 2015 model hai .me ne us se poocha ke jhatkay marti hai us ne kaha ke nahi..me ne check kia tu pata chala ke us purge valve on rehti hai on idle rpm....

    Sent from my SM-G925F using PW Forums mobile app

  17. #156
    PakWheeler Follow
    harisabid's Avatar
    Join Date
    Jul 2010
    Location
    Islamabad
    Age
    29
    Posts
    72
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Koi mileage ka bhi bata de ..kese setting hogi

    Sent from my SM-G925F using PW Forums mobile app

  18. #157
    Senior PakWheeler Follow
    turbo_charge's Avatar
    Join Date
    Aug 2006
    Location
    Islamabad
    Age
    29
    Posts
    1,470
    Follows
    1
    Following
    0
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    I have by pass purge valve and directly connect purge pipe to throttle.. weather is ok that's why proper check ni hwa... sound of air being sucked into throttle is observed... one thing I observed that pick increased a little....

    Sent from my SM-G530H using PW Forums mobile app
    slow n steady wins the race..

  19. #158
    Senior PakWheeler Follow
    turbo_charge's Avatar
    Join Date
    Aug 2006
    Location
    Islamabad
    Age
    29
    Posts
    1,470
    Follows
    1
    Following
    0
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    But this is not solution..

    Sent from my SM-G530H using PW Forums mobile app
    slow n steady wins the race..

  20. #159
    PakWheeler Follow
    harisabid's Avatar
    Join Date
    Jul 2010
    Location
    Islamabad
    Age
    29
    Posts
    72
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Masla yeh hai ke ecu me purge ki setting nahi hai

    Sent from my SM-G925F using PW Forums mobile app

  21. #160
    Senior PakWheeler Follow
    turbo_charge's Avatar
    Join Date
    Aug 2006
    Location
    Islamabad
    Age
    29
    Posts
    1,470
    Follows
    1
    Following
    0
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Ecu ka software update ho sakta?

    Sent from my SM-G530H using PW Forums mobile app
    slow n steady wins the race..

+ Reply to Thread
Page 8 of 17 FirstFirst ... 678910 ... LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •