Survey by Qualaroo
+ Reply to Thread
Results 1 to 4 of 4

Thread: Mehran Euro 2 Start up issue - Engine (Efi) light is continuously ON

  1. #1
    PakWheeler Follow
    smasood's Avatar
    Join Date
    Oct 2012
    Location
    Lahore
    Posts
    8
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Mehran Euro 2 Start up issue - Engine (Efi) light is continuously ON

    It is 2014 model Mehran VXR Euro 2, It was running fine, but suddenly when i parked the car and tried to restart, it does not work. It is not taking Self/Sulf , and the red light of engine/Efi is continuously ON during ignition. I managed to get it started via push start with the help of few people around and it started and kept running but again when i switched off and tried to restart, it goes on the same problem. No ignition/Sulf, and Red light ON.

    ANy quick help would be appreciated. Thanks

  2. #2
    PakWheeler Follow
    shoaib.civil87's Avatar
    Join Date
    Sep 2016
    Posts
    6
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    meray sath b yehi problem hoi last 3 days say...

  3. #3
    PakWheeler Follow
    shoaib.civil87's Avatar
    Join Date
    Sep 2016
    Posts
    6
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Community Votes: 1
    Aj subha jub car start ki to selef nai lia.battry change kar kay dakha phr b selef ki koi awaz nai i.phe touchin kar ka start ki or electrition ka pass lay kar gaya.us na pahlay battry check ki wo farig.. phr selef ko open kia or us ko wash kia petrol say......Now selef in working with new battry.

    selef repair charges 300
    nEW battry with old battry eXIDE gl50 2900

  4. #4
    PakWheeler Follow
    smasood's Avatar
    Join Date
    Oct 2012
    Location
    Lahore
    Posts
    8
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by shoaib.civil87 View Post
    meray sath b yehi problem hoi last 3 days say...
    Shaoib found it well,
    Whenever such an issue occur, check 2 things that could be problematic.

    1) Battery + it's terminals: Sometimes the rusty terminals dont spark, also the battery might itself might have been a problem. There is a small connector under the ignition point, sometimes it gets lose. Try to kickstart battery by connecting another charged battery with it, (if the battery cables are not available, simply try to join other battery's terminals with yours upside down). Another way to test your battery is to place a steel key alongside motor belt (at bottom left side, under air filter) if the battery is good, it will attract the key towards itself due to magnetic field due to charge

    2) Plugs: A heavy wash could result draining the plugs, get them out, dry well, replace.

    My problem was solved with a replacement of batteries as they were all dead. i got 50 Volt batteries instead of 40 with replacement of older one, in PKR 2900.

    Thanks.

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •