Survey by Qualaroo
+ Reply to Thread
Results 1 to 5 of 5

Thread: EPS Light shows on - Toyota Passo 2005

  1. #1
    PakWheeler Follow
    sazzadjn's Avatar
    Join Date
    Oct 2010
    Location
    chittagong
    Posts
    2
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default EPS Light shows on - Toyota Passo 2005

    I'm Using a Toyota Passo 2005 1000 CC since 2 n half years.
    Recently sometimes EPS light is showing when engine is started and it doesnt go off and steering becomes haarder. I've checked in garage the tested with another reconditioned Controler but It didn't work out. Electroninc scanning showed ERROr C 1555 (MOTOR RELAY WELDING FAILURE). I'm in a quite lost situation, pls help what to do next. FYI when engine started ok (with no signal) it doesn't show up again until egine is restarted. means the light shows sporadically & whimsically. RGDS


  2. #2
    Site Banned Follow
    6037550's Avatar
    Join Date
    Jan 2009
    Location
    Sargodha
    Age
    29
    Posts
    551
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i have drove one passo and it has one of best lightest steerings.but EPS light should turn off after 5 seconds of engine starts.hope u get solution

  3. #3
    PakWheeler Follow
    automaster's Avatar
    Join Date
    Nov 2008
    Location
    Karachi
    Posts
    185
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default TOYOTA EPS Service Training

    Quote Originally Posted by sazzadjn View Post
    I'm Using a Toyota Passo 2005 1000 CC since 2 n half years.
    Recently sometimes EPS light is showing when engine is started and it doesnt go off and steering becomes haarder. I've checked in garage the tested with another reconditioned Controler but It didn't work out. Electroninc scanning showed ERROr C 1555 (MOTOR RELAY WELDING FAILURE). I'm in a quite lost situation, pls help what to do next. FYI when engine started ok (with no signal) it doesn't show up again until egine is restarted. means the light shows sporadically & whimsically. RGDS

    plz check this link may HELP you.

    http://www.timloto.org/download/pdf_...aDiagOnCar.pdf
    Try to change what you can't accept & try to accept what you can't change

  4. #4
    Newbie Follow
    ahmad.latif1's Avatar
    Join Date
    Jun 2013
    Location
    Lahore
    Age
    22
    Posts
    1
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    had you got this problem solved or not?

  5. #5
    Newbie Follow
    anwartanvir's Avatar
    Join Date
    Oct 2016
    Posts
    1
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default Passo 2008 EPS problem c1555

    I am having this problem for couple of weeks. EPS light comes up sometimes after starting the car and the steering gets harder. After couple of ignition it goes off and doesn't show up when the car is running. Scanning shows error c1555 motor relay welding failure. My garage is suggesting to replace eps motor and sensor. What should I do?

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •