Survey by Qualaroo
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 20 of 26
Like Tree2Likes

Thread: GLi performance problem

  1. #1
    PakWheeler Follow
    ahsandon007's Avatar
    Join Date
    May 2011
    Location
    Faisalabad
    Posts
    105
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default GLi performance problem

    I have Gli 2011 model with 55,000km millage .I have experiencing car performance issues .I feel that my car acceleration/power is not good...And I also noticed bit noisy engine...I change oil at every 4000kms and oil filters too...I need suggestions about any service so that my car can perform well.


  2. #2
    Senior PakWheeler Follow
    asim510's Avatar
    Join Date
    Nov 2009
    Location
    Islamabad
    Age
    33
    Posts
    3,393
    Follows
    0
    Following
    0
    Mentioned
    72 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    1
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    1

    Default

    r u the first owner ? seems like clutch plates issue, but this usually happens after 150k
    Before you criticize someone, Make sure you are better than them.............

  3. #3
    PakWheeler Follow
    ahsandon007's Avatar
    Join Date
    May 2011
    Location
    Faisalabad
    Posts
    105
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by asim510 View Post
    r u the first owner ? seems like clutch plates issue, but this usually happens after 150k
    Yup 1st owner....i don't think so its clutch issue...:/

  4. #4
    PakWheeler Follow
    ahsandon007's Avatar
    Join Date
    May 2011
    Location
    Faisalabad
    Posts
    105
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    I once pour petrol from some local pump I think after that I'm facing this issue...maybe fuel quality affected that

  5. #5
    PakWheeler Follow
    bakhtbaryar's Avatar
    Join Date
    Jun 2015
    Location
    Islamabad
    Age
    23
    Posts
    82
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    4
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Knocking is the issue... use a petrol cleaner with a full tank and put in high octane a few times a month.

  6. #6
    PakWheeler Follow
    ahsandon007's Avatar
    Join Date
    May 2011
    Location
    Faisalabad
    Posts
    105
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by bakhtbaryar View Post
    Knocking is the issue... use a petrol cleaner with a full tank and put in high octane a few times a month.
    You mean fuel injector cleaner addictives?
    Guide me furtherr about how to use and which one plz.

  7. #7
    PakWheeler Follow
    Farzad's Avatar
    Join Date
    Jun 2009
    Location
    Islamabad
    Age
    31
    Posts
    29
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Lightbulb Get your catalytic converter checked out...

    One of the main reasons of loss in power/acceleration or general load on engine is a clogged catalytic converter.

    Basically your car might not have a free flow exhaust. Cars in Pakistan commonly get a clogged catcon at about 30-60 thousand KMs.
    ~~~~~Riders on the storm~~~~~

  8. #8
    PakWheeler Follow
    shabbir.53's Avatar
    Join Date
    Jul 2013
    Location
    Islamabad
    Age
    63
    Posts
    690
    Follows
    1
    Following
    0
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    I had similar problem. Got catalytic converter cleaned. Problem disappeared.

  9. #9
    PakWheeler Follow
    ahsandon007's Avatar
    Join Date
    May 2011
    Location
    Faisalabad
    Posts
    105
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Whats price and can I get this job done by local mechanic?

  10. #10
    PakWheeler Follow
    ahsandon007's Avatar
    Join Date
    May 2011
    Location
    Faisalabad
    Posts
    105
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    1.3 gli has catalytic converter?

  11. #11
    PakWheeler Follow
    bakhtbaryar's Avatar
    Join Date
    Jun 2015
    Location
    Islamabad
    Age
    23
    Posts
    82
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    4
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    As far as I remember, my Gli 2011 March Crystal lights version had no catalytic converter. Plus your car is driven around 50k catalytic converter should not be clogged as such but it is worth getting it looked at.

    I should suggest using a good quality petrol cleaning additive (any good imported brand from a reliable place is fine), and put in high octane a few times. Try to see if the sound improves and performance goes up.

    Here is a list of what you should do in order
    1) Add cleaner and high octane and see if it helps

    2) if it does not, have spark plugs replaced complete tuning done and reset the computer

    If the above do not work (they should inshAllah, its a new car)

    3) Have its air to fuel ratio checked

    3) Have fuel injectors cleaned and the fuel pump checked

    3) Get a compression test done (Especially if the car has been driven on CNG)


    My brand new gli '16 gives me knocking and poor acceleration on bad fuel!

  12. #12
    PakWheeler Follow
    ahsandon007's Avatar
    Join Date
    May 2011
    Location
    Faisalabad
    Posts
    105
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by bakhtbaryar View Post
    As far as I remember, my Gli 2011 March Crystal lights version had no catalytic converter. Plus your car is driven around 50k catalytic converter should not be clogged as such but it is worth getting it looked at.

    I should suggest using a good quality petrol cleaning additive (any good imported brand from a reliable place is fine), and put in high octane a few times. Try to see if the sound improves and performance goes up.

    Here is a list of what you should do in order
    1) Add cleaner and high octane and see if it helps

    2) if it does not, have spark plugs replaced complete tuning done and reset the computer

    If the above do not work (they should inshAllah, its a new car)

    3) Have its air to fuel ratio checked

    3) Have fuel injectors cleaned and the fuel pump checked

    3) Get a compression test done (Especially if the car has been driven on CNG)


    My brand new gli '16 gives me knocking and poor acceleration on bad fuel!
    Thanks for reply..
    I need you to answer few qs.
    Petrol cleaning addictive or fuel injector cleaner is it same thing?
    I have driven my car 16000km after changing plugs...And no cng totally petrol driven.
    And what you mean by complete tuning what things are included in that?

  13. #13
    Senior PakWheeler Follow
    biloo's Avatar
    Join Date
    Sep 2004
    Location
    Lahore
    Age
    33
    Posts
    1,289
    Follows
    2
    Following
    0
    Mentioned
    16 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Cat converter came in 2013 onward models. And your car has no problem , trust me. Just change ur fuel station or maybe get some hi octane poured in ur tank.

    Sent from my SM-N910G using Tapatalk

  14. #14
    PakWheeler Follow
    ahsandon007's Avatar
    Join Date
    May 2011
    Location
    Faisalabad
    Posts
    105
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Ok I'll pour hi octane in my car

  15. #15
    Senior PakWheeler Follow
    biloo's Avatar
    Join Date
    Sep 2004
    Location
    Lahore
    Age
    33
    Posts
    1,289
    Follows
    2
    Following
    0
    Mentioned
    16 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by ahsandon007 View Post
    Ok I'll pour hi octane in my car
    Do share the results

    Sent from my SM-N910G using Tapatalk

  16. #16
    PakWheeler Follow
    ahsandon007's Avatar
    Join Date
    May 2011
    Location
    Faisalabad
    Posts
    105
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    I poured fuel cleaner and hi octane I noticed improvement..
    Now I'm gona change plugs

  17. #17
    Senior PakWheeler Follow
    biloo's Avatar
    Join Date
    Sep 2004
    Location
    Lahore
    Age
    33
    Posts
    1,289
    Follows
    2
    Following
    0
    Mentioned
    16 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by ahsandon007 View Post
    I poured fuel cleaner and hi octane I noticed improvement..
    Now I'm gona change plugs
    Fuel additives are not recommended i reckon. Hi octane only would have done the job.

    Sent from my SM-N910G using Tapatalk

  18. #18
    Senior PakWheeler Follow
    haseeb.basharat's Avatar
    Join Date
    Mar 2015
    Location
    Lahore
    Posts
    1,636
    Follows
    2
    Following
    1
    Mentioned
    43 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    2
    Best Answers
    1
    Good Answers
    2

    Default

    When was the last time you changed plugs?
    If haven't changed, than change immediately them to Denso iridium plugs.
    Genuine/OEM lasts only 30k kms


    Sent from my iPhone using PW Forums

  19. #19
    PakWheeler Follow
    ahsandon007's Avatar
    Join Date
    May 2011
    Location
    Faisalabad
    Posts
    105
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by haseeb.basharat View Post
    When was the last time you changed plugs?
    If haven't changed, than change immediately them to Denso iridium plugs.
    Genuine/OEM lasts only 30k kms


    Sent from my iPhone using PW Forums
    I don't remember when I exactly changed plugs...I think its 16k kms or 26k kms ...not sure but ill change it soon...no doubt irridium plugs has more milage but are expensive :p...so ill use simple one and change it after every 20k kms ..

  20. #20
    PakWheeler Follow
    ahsandon007's Avatar
    Join Date
    May 2011
    Location
    Faisalabad
    Posts
    105
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by biloo View Post
    Fuel additives are not recommended i reckon. Hi octane only would have done the job.

    Sent from my SM-N910G using Tapatalk
    Ok bro thanks I'll not pour addictives nxt time

+ Reply to Thread
Page 1 of 2 12 LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •